Routine not firing on a Schedule

scheduling
routines

#1

Let me start out by saying, I’m no novice. I wrote LANnoucer, fer cryin’ out loud!

But I cannot figure out how to get a routine to fire on a schedule. I set “Good Morning” to fire daily at 6am, to turn on some lights. It never does. No mode restrictions, nothing else, it just doesn’t fire. Nothing in the “Recent Activity” either.

What am I missing? This seems like it really should be trivial.

Thanks


(Joshua Moore) #2

I think what you are missing is that schedules aren’t working (for the most part) with ST. Some folks have had luck using unusual times such as 5:57 instead of 6:00. You may want to give that a try.


(Matt) #3

I am thinking of using Amazon Echo. Alexa set an alarm for 6AM and have the alarm trigger the event you want to happen. That gets off the ST timer


(Rick Pittser) #4

How does the Alexa alarm trigger an ST event? That sounds very similar I thought about doing but didn’t think it was possible.


(Matt) #5

Im researching. I dont have yet and am trying to figure that out right now…


(Ren Eric) #6

Isn’t that possible through IFTTT?


#7

I could do that. Alexa to trigger a virtual switch that RulesEngine (e.g.) watches.

But that seems ridiculous. ST already has “routines” and options for when to fire them.


(Matt) #8

yes it is ridiculous but we all know and there are tons of threads on the subject that ST has issues with any timed event.


(ts) #9

Yep, routine to arm and disarm daily has failed ever since the 'droid app update. Was working fine before the last update, but now it works one and not the next day. Heck even TTS is not working too.

Smart Lighting app works like a charm however.


(Rick Pittser) #10

Yes, didn’t think of that, but just checked and that is a trigger.


(fightingmajor) #11

Not for me! Two different locations and both have at least 1 item that fails to run every day. I’ve changed the time to start at weird times and it still doesn’t always work. I’d say about 50% of the time at either location.


(Ren Eric) #12

Yeah, still sucks. IFTTT is pretty slow but we basically have no choice at the moment.


(Daniel) #13

ST continues to have issues on their end with routines and certain based triggers. Below is an email from support on my issue with them:

Hi Dan,

Ok, I understand. So the issues we’re having platform side affect scheduling for time based triggers, as well as sunrise/sunset (which is effectively a time based event).

I have sent the refresh command from my end, and this should get it working again. It’s possible that it might fail again, as this is a problem on our end that we’re working on. You can perform the update from your end, and it should do the same thing, but it’s possible I may need to do it again for you if it continues. My apologies for the trouble.

Best Regards,
Kyle
SmartThings Support


(Matt) #14

you would think they know there is an issue so they would do a global refresh on everyone every so often just to keep things kind of running


(Ren Eric) #15

What does he mean by that?


(Matt) #16

click on My location then Installed Smart Apps and you can update any of them there.


(Ren Eric) #17

Thanks! DIdn’t know about that one.


#18

Everything was working great for the last week and last night certain areas didn’t fire up and I came home to a dark house. They MUST fix these simple issues…no way to trust the system with more complex systems like locks, etc.without this working without a hitch. With that said, I also run LIFX led bulbs and their routines fire right on time EVERY time. Not once has it not worked. Kudos.


(Ren Eric) #19

Same exact situation for me. For the first time, I came home to a dark home and no triggers were working.


(ts) #20

That’s too bad fightingmajor, for me at least the lighting has been the only thing that has not yet failed (fingers x).

Also doing the update from the hub end doesn’t really do much to make the routines work again.