Time-based automations failing


(Patrick Shoemaker) #1

I have a few time-based automations (two routines and one Smart Lighting automation) that have stopped working in the past few days. Interestingly, some other time-based actions are still working properly. Any suggestions for troubleshooting this? I opened a ticket with support.


(Andy T) #2

My routines are not working as well. Not really sure why. I’m a bit new here so not really concerned (yet). Please post here on what you find.

Thanks!


(Ray) #3

All my local processing time based with smart lighting apps work but I know 2 of my cloud based failed the last couple of days. Some of the members on here reported random failure the last few days so sounded like ST is having issue.


#4

I have all but given up on ST scheduler. All but 1 of my (scheduled apps) are called via EventGhost schedules and python macros(eg: urllib.urlopen(“https://graph.api.smartthings.com/api/smartapps/installations/xxxxxxxxxxxxxxxxx/onTheHour/runLog?access_token=xxxxx”). ). Reliability using this method is 99.99% Only time I have a failure is due to my own doing or on the very rare occasion when internet is down. I have used EG for at least 6 months now when ST schedule failures were insane.

Last week, based on what I read on this forum, it appeared to me that St schedules seem to be working pretty good. This week my remaining ST app started to fail. Conclusion: Sticking with EG :slight_smile:


(Aaron S) #5

Please submit a ticket or email support@smartthings.com with the approximate time/date of the failures, the name of the automation that failed, and what the expected action was. The team is digging into this now to figure out what is going on.

Thanks!


(Patrick Shoemaker) #6

Aaron, I opened a ticket last night, #238628. They rebuilt the events that I mentioned and said they should be working now.

Support also suggested, to fix this if it happens again, opening any automations that are having problems, adjusting the time slightly, saving, reopening, and adjusting back to the desired time.

I will note that one of the automations that wasn’t working previously started working last night after I just opened the settings and re-saved it. Maybe a coincidence.

Support also mentioned that this was a known problem that was being actively worked. Hopefully it’s gone soon.


(Patrick Shoemaker) #7

My good night routine failed to run last night. Guess this problem hasn’t been permanently sorted out yet.


(Sal Marano) #8

My lock door command failed to execute at 9 pm as well and having issues with other time scheduled commands.


(Andy T) #9

I just deleted and recreated all of my routines and they seem to be (fingers crossed) working now. I’ll monitor in the coming days.


(Andy T) #10

Well, not working again. Routines does not seem very reliable for now.


(Aaron S) #11

We pushed/are pushing (I’m not 10000% sure on timing relative to your experience) a series of updates to mitigate this. Can you send details of the failure to support? Please include the name of the automation, expected result, and date/approximate time it failed.


(Bobby) #12

That’s NOT five…0s. Are you sure about that?!


(Aaron S) #13

Honestly, I am not always sure what time zone I wake up in - let alone the timing for releases… but we are working on some updates that should help. We’ll have notes in Announcements soon


(Bobby) #14

Yeah, me neither, sometimes my hub is set to EST, sometimes to CST…:slight_smile: Just kidding, I know what you mean…


(Patrick Shoemaker) #15

Another observation:

On Monday night, 7/18/16 at 2300 EDT, my good night routine failed to run on schedule.
On Tuesday night, 7/19/16 at 2300 EDT, the routine ran as scheduled.

I didn’t rebuild the routine between those two times, so it seems to me like this is a hit-and-miss scheduling issue, not an event corruption issue that requires rebuilding.


(Andy T) #16

@Aaron, used that link that you gave and sent an email to support.


(Richard) #17

Is there any known issue with routines across multiple users in same account? I have a v2 hub with right now one Zwave outlet controlled to turn on / warm up espresso machine before we wake, and turn it off a few hours later if we forgot.

Invited wife and her Smartthings interface on android shows the turn on / turn off weekday routines I created. She can fire the switch manually and edit those routines and they’ve worked. She created a turn on routine for the weekend…which I do not see on my app, and which didn’t fire this morning.

Not sure if its related to recent issues others appear to be having with routines. Apologies if inappropriate crosspost/threadjack.


(Aaron S) #18

If you shoot an email over to support@SmartThings.com with the approximate time the failure occurred, they can review the smartapp settings & event history, and help you figure out what’s going on.