Routine creating in smartthings mobile app

Hi. I’ve been trying to create routines in my smartthings mobile app. I’ve developed some devices using smartthings CLI. now I want to add some triggers for these devices. But when I to on if or then my Devices status can’t be clicked as an option and in ‘then’ the control devices can’t be clicked. How can I turn them on

@Kiarash_Kianian some virtual devices created from SmartThings CLI or my.smartthings.com have some limitations, What type of devices are you using? Could you share evidence about the problem? it sounds like there might be a presentation issue.

1 Like

I have a Lamp virtual device. I haven’t yet made presentations but I don’t think the problem is coming from the device. You can see the limit in the pictures I provided.


Mmm, could you enable the support access to check the device’s data?

Support access

Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM.
2. Enable support access to your account:

  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

I did it. I’m waiting for you now. Thanks for your help

@Kiarash_Kianian I tried with the email address that is registered here on SmartThings Community but I couldn’t use the support access, Are you using a different email address for your account in SmartThings? if yes, please share it in a DM.

I guess I have another account for it
Can you try this one?

@Kiarash_Kianian Thanks, I will check it. Also, I don’t recommend sharing your email address in that way because this post is public. For that reason, I previously commented to send it via DM (Direct Message)

I deleted it to protect you

2 Likes

@Kiarash_Kianian Sorry for the delay, I was checking the devices in your locations and I found 2 virtual devices both using a device profile that you created but unfortunately, both don’t have a presentation which is causing the issue, because the automation option requires a presentation.

To solve your case you can do the following

In the case that you can create a custom virtual device:

  1. Create a device config, in this case, you will need to create an automation view in other to add this option on the SmartThings App, after to create it you need to update your device profile. Documenation

If you need a “standard device”:

  1. You can create it using my.smartthings.com or use the smartthings cli to create one from the available list, this process will also generate the presentation. If you encounter any issues with these methods, please let me know.
1 Like