[REMOVED] Nest Manager 4.0

@Townsmcp I followed the directions for using GitHub yes. On the smart apps panel of the IDE its showing published and OAuth true. Under the device handlers it says published for each of the items but OAuth is blank but I don’t know how/where to enable OAuth for device handlers.

In the smart apps section it’s showing the category for the nest manager as convience. I can’t seem to change that and I don’t have a convience section on my mobile app either.

Make sure you are using the correct IDE link.
See this post

@sykocus have you clicked on Save and then Publish when in the device handler page?

@tonesto7 I went to https://graph-na02-useast1.api.smartthings.com/ and nothing was setup so I went thought the instructions again now it’s showing up in My Apps. I had no idea there were two IDE sites. Thanks for the help.

This is happening a lot more frequently and it’s a shame that ST hasn’t addressed it yet.
I glad you got it sorted out though :slight_smile:

@sykocus that’s means your on the European setup. Check out the following site to get GitHub installed:

SmartThings + GitHub Integration Issues

He is in North America, just on the 2nd shard.

1 Like

Doh! At least it’s all sorted

1 Like

Is there any way possible to setup an automation based on a remote sensor to turn the HVAC fan on for a set amount of time? There is a way to manually turn on the fan within the Nest app but I would like to do it triggered on a remote sensor temp threshold.

Basically my thermostat is in the central part of the house. A room near the exterior corner of the house gets cooler in the winter than the other rooms and if it gets to a certain temp I want the fan to kick on and circulate the warmer air into that room.

Is this possible?

I’ve deleted the handler for the Virtual Thermostat. Should I also delete the DTH for Sim Thermostat? It may have been held over from a previous version of NM

tonesto7 : Nest Sim Thermostat

10:31:53 PM: error groovy.lang.MissingMethodException: No signature of method: physicalgraph.device.DeviceTypeExecutorBase$_closure5.doCall() is applicable for argument types: (java.lang.String, java.lang.NumberFormatException) values: [generateEvent Exception:, java.lang.NumberFormatException: For input string: “>120”]
Possible solutions: doCall(), doCall(java.lang.Object), call(), call([Ljava.lang.Object;), call(java.lang.Object), findAll() @ line 441

Getting this on one of the two thermostats. I removed it, made sure it was gone, added it back. It appears to be working sorta ok.

A CoRE piston might do the job - [RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

I looked and didn’t see the solution. I installed the Nest Manager app and it’s working perfectly (Thanks for the hard work!).
Is there a way to decrease the time delay between changing the temp on my phone (Android if it matters) and it updating the nest? Right now, when I manually change the temperature, it takes a minute or so to update the Nest.

I saw the polling options and set the one I think it was to 1 minute but that was the minimum and seemed like it was still too slow. Using the Nest app updates the thermostat almost immediately so hopefully it’s fixable or we’ll just keep the Nest app on our phones (I’d rather go to 1 app).


All NestMode automations have been flawless since the update. Nice work!!


So far with 4.1, the NestMode automation has been flawless for me as well! Thanks!

Seriously excellent work @tonesto7!

-Ben K

1 Like

Thanks for letting us know… Seriously though this project has gotten so large and complex that it takes a few of us to make it what it is. So I want to make sure that @E_Sch and @desertblade get their due credit as well.


Thanks for pointing that out! @E_Sch and @desertblade: Excellent work as well! Thank you!


Thanks for all the great work on 4.1 and the previous versions of this app.

Like many people I’ve had a lot of issues with Nest since their introduction of “Eco” temperatures. My main problem is that the thermostat now “pops out” of the Away functionality. It doesn’t matter if it’s set manually or through an app like Nest Manager. I have all the Thermostat sensors and Protect sensors disabled (pets) but it doesn’t seem to matter. After 1-2 hrs it’s back out of Away mode into Home mode and then Eco turns off as well.

None of this is your problem, it’s with Nest. I’ve had conversations with their support about it but have been told multiple times this is “expected” - even though it never did it before. In any case what would really help is a way to use the Presence sensor to toggle the Eco mode directly instead of toggling the Home/Away functionality. I’ve noticed if you set the thermostat into Eco mode directly it works until told to turn back off.

Is this something that could be added, or is modifying the code for this basic enough I could attempt it? I’ve done some basic App writing but this one is way more complex. Just a pointer on where to look or what to change and I’m willing to add it myself. The thermostat is basically useless without automating itself when I’m not home. Thanks! (sorry for the length)

1 Like

@robwrberjr I have found this to work fine so far. I have my setup set to run the routine ‘Goodbye!’ when me and the wife leave home (set by being outside the geofence). That routine sets the mode to ‘Away’. In Nest Manager I have Precense enabled and in Nest Automations I have Nest Mode Automation Config set to ‘Away’ for when away:

In the Nest app itself I have switched off the Protects in Home/Away assist so the the dog doesn’t trigger Nest to think someone is at home.

I just updated via IDE and noticed that you recommend removing the virtual thermostat device and then delete the virtual device code from the IDE. How should I go about doing this?

On IDE, under Device Handlers, I see tonesto7: Nest Virtual Thermostat listed directly below tonesto7: Nest Thermostat. I could click on that and delete it but I want to make sure that this is the right thing to do as I don’t see anything about removing the device and then deleting the device code.

Do you mind spelling this out a bit?