SmartThings + GitHub Integration Issues

Continuing the discussion from SmartThings + GitHub Integration:

I received an e-mail from SmartThings, saying that,

We noticed a problem with our SmartThingsPublic GitHub Repo which was just made public a few hours ago. We had to make some changes to fix the problem, and as a result you will need to delete your forks and refork the new SmartThingsPublic.

So, I removed the repository from SmartThings IDE and deleted it on Github. Now I can no longer connect my SmartThings IDE with Github. When I click on the “Enable GitHub Integration” link, I’m kicked back to the IDE top page Any ideas?

Did you remove SmartThings on the github authorized apps list in your github settings?

Yes, I did. Also logged out and logged back in from both Github and SmartThings.

@kelli any ideas on this one?

I have an open ticket with support on this same issue. We’ve tried a few things that havent helped and haven’t heard anything in the last 24 hours

Oh, dear! Hope it will be resolved soon. :frowning:

P.S. I opened support ticket too.

Thats the best avenue to get fixed Geko, It is probably due to forking it before we changed permissions.

We’ll get you sorted my friend :smile:

@kevintierney I see your ticket and it looks like we asked for some more information on Wednesday at 6:26pm.

1 Like

@slagle thanks for checking. I missed the last email from the gmail thread. Responding now

1 Like

@slagle got me all fixed up. Seems they may have had to delete some records in the DB. That and I had to go into my github settings go to apps and revoke ST’s access

1 Like

Same here. Support fixed it. Seems to be working now. Thanks!


Is there a way to know if your GitHub integration is working? When I log into the IDE, it doesn’t say disconnected and I am able to check for updates (even though none are available)…

I was getting when doing repo, hence I decided to removed repository and smart over on github integration.

I followed all the suggestion on this page. However, still pressing “enable Github Integration” takes me to

Any idea?

Having similar issue after removing a repo which I thought is not necessary in my Github. Now ide complain unable to integrate to github after removing repository. I added repository back, revoked application from github. Cannot get it going again. Now application is not showing up in github as an authorized app, and cannot connect back from ST ide. Smart things ide some how remember my old settings, and never let me continue, and complain that it do not have permissions, to access my repository. I think this need a clean up to revert back to my initial setup, some where. Hope support will help someday. Wrote them an email .

I am in the UK and there doesn’t appear to be any way of doing GitHub integration from:

Somehow I did log into the US one and it shows the GitHub button, but as all my apps and the hub are on the eu01 system, it doesn’t help me…

Are there still issues re-enabling Github integration? Similar to other people here I previously had it linked and had turned it off. When I log in and click on Enable it just dumps me back to the main page. Not sure if it’s a known issue or just something I need to contact them about for my account.

Hi all

I’m having some issues getting Github integration setup. I did manage to do it once up a time, (I guess maybe through the US graph… IDE URL, however I just don’t see the option at all on:

Any ideas how as a UK user you can enable GitHub integration? Right now I am missing a ‘settings’ button on the My SmartApps page.


I was having problems with my GitHub integration, well it had disappeared.
I am in the UK btw
The staff at STT support have been so helpful and pointed me here -

And its all working ok again :wink:

1 Like

I was told that GitHub integration is not supported for the UK - this was from ST support?! did something change and I missed it?


Thanks for the heads up! it works now, I’ve been looking for this for a while, but had given up on hearing from ST support that it’s not supported for the UK