Unable to add Philips Hue bridge to my smartthings devices


#1

hello, I have a Philips Hue Bridge connected (currently all my Hue bulbs work fine with Google Assistant and with Hue Apps for iOS and Android)

I wanted to add Philips Hue to my Smartthings ecosystem (currently have Lutron setup perfectly) but Philips is not showing up.

I tried the smartthings (both versions) Android App to add Philips Hue and the message I get as soon as I select white LED Bulb (A1) is “coundn’t add device - you need a hub to connect to this device”
If I try the with smartthings iOS app I get a little further into the process but the Philips Hue Bridge is never found.

Any help would be appreciated.

Note: I am using a Nvidia Shield Smartthings Link


#2

Did you follow those steps?

In the SmartThings mobile app:

From the Dashboard, tap Add device
Android: Tap Add Device Manually
Select Light bulb
Tap Philips Hue
The app will say Searching for devices…
Wait a moment for the Hub to automatically discover your Hue Bridge. Then, as prompted, press the button on the Hue Bridge to link it with the SmartThings Hub
SmartThings will then automatically discover all of your Hue lights connected to that Hue Bridge. When each device is discovered, it will be listed on the screen
Tap Edit to rename a device
When finished, tap Done
Tap Done again to confirm
******Note: Your Philips Hue devices and the SmartThings Hub will have to be on the same local network in order to work together.


#3

thanks for the reply.
Yes, I am following those steps … but as soon as I tap Philips Hue I get the “couldn’t add device…”
see attachement


#4

Please use the Smartthings Classic App.


#5

no luck with classic app.


(Patrick) #6

How much other “smart” stuff do you have on your network? The hue bridge is really temperamental about responding to SSDP requests (how we discover the hue bridge), it likes to respond 10’s of seconds too late (on a 5 second window) when there’s other things on the network making SSDP discovery requests (to anything, not just those specifically trying to discover hue).

The easiest way to get it discovered is to start discovery (“Add A Thing”) and then soon after that plug in the hue bridge’s power. That will hopefully make it so it receives requests from the ST hub first and we’ll actually get responses in a timely manner.

If this doesn’t get it to work it could be something more fundamental with how you have your network configured. You should make sure the bridge and the hub can talk to each other.


#7

Same issues (everything works Hue app, third party mobile apps, Google Home integration, IFTTT, etc, but NOT ST), had Hue ecosystem integrated with ST for many months then one day GONE, now a month later STILL unable to ‘works with ST’. Tried the SSDP discovery workaround, with cautious optimism, but no joy.

EDIT: Everything appears to work in adding the Hue bridge through both IOS and Android apps up until the point when Super LAN Connect needs to add the mac address, I presume of the Hue bridge. I looked at Philips Hue API debugger and the Token is in the whitelist, hence it is authorized.

Live Logging:
4586494a-d79a-48dc-a19d-XXXXXXXXX 3:52:25 PM: error super_connect_error Hue add failure for mac. Existing macs: [.,.,.,.,.]
4586494a-d79a-48dc-a19d-XXXXXXXXXXX 3:52:25 PM: trace userToken: yJHZKByvjGv7FxYitqzvmAECoxXXXXXXX
4586494a-d79a-48dc-a19d-XXXXXXXXXXXX3:52:25 PM: trace body: [[success:[username:yJHZKByvjGv7FxYitqzvmAECoxXXXXXXX]]]
4586494a-d79a-48dc-a19d-XXXXXXXXXXX3:52:25 PM: trace in usernameHandler
4586494a-d79a-48dc-a19d-XXXXXXXXXXX3:52:25 PM: debug --------------------------------------------end of request--------------------------------------------
4586494a-d79a-48dc-a19d-XXXXXXXXXXXXX3:52:25 PM: debug dni: router_mac
4586494a-d79a-48dc-a19d-XXXXXXXXXXXXX3:52:25 PM: debug token: 4586494a-d79a-48dc-a19d-XXXXXXXXXXXXXX
4586494a-d79a-48dc-a19d-XXXXXXXXXXX3:52:25 PM: debug host: 192.168.10.116:80
4586494a-d79a-48dc-a19d-XXXXXXXXXX3:52:25 PM: debug --------------------------------------------in developer username request--------------------------------------------


#8

i finally got it to work… for 1 day :frowning:

i have a mesh network so I connected the phillips directly to 1 of the pods and voila the phillips hue bridge was immediately found and populated my smartthings app .

all was good but today all the phillips hue devices in my app are disconnected and I am unable to reconnect.


#9

What really perplexes and frustrates me, is that everything else works fine in my environment with integrating and discovering and operating Philips Hue Lighting (i.e. Amazon Echo, Google Home, third party apps within IOS, Android, and PC/Windows, Logitech Harmony, Hue app itself, IFTTT, Stringify), what makes ST so different in discovering the Hue bridge and maintaining said connection? Worse thing is I would trade everything else (minus Google Home integration) for ST to work…really sucks to have something work for many many months and now for several months not have it work…


(Paul Barden) #10

Hi all.

I’m in exactly the same boat although my problem started when I upgraded my Hue bridge the newer Square bridge.
For the past 2 years I had integration with hue and all my bulbs working perfectly.

Last week I deleted my old hue bridge from ST and all the associated lights. I then replaced my bridge and tried to search ever since but ST never finds the Hue bridge.

I have no problem with the hue app and associated third party apps connecting to the hub. All but ST can connect!. This is so dissapointing considering how integrated all my lights were in ST up to this point.

I’ve tried everything to resolve and have raised a ticket with SmartThings support (first time I’ve ever had to raise a support ticket).

Slowly running out of faith I can get my lights re-integrated.


#11

Not sure what has happened internally with ST support, it used to be good and really technical, which I liked, I am an engineer by education, so I avoid tech support like the plague, unless I am certain it is something in the infrastructure side or something that I am unaware of with a product that I need help.

Recently support has been lacking like this year really, response has been delayed (right now, still waiting from when I AGAIN asked for help since Monday 2 CST and still no answer - I think this is now the third time for the same issue) and when it is a response it is always a Tier One response:
Have you rebooted, the ST Hub, bridge, network, changed cables, is fw up to date blah, blah… etc…stuff that I have already have done multiple times, trying to get this to work.

I know and am aware perhaps for the average user, that may be ok, but not really with the ST platform, most of the guys here seem to have the know how go beyond the obvious. I wish there was a press 2 for advanced technical support…

Maybe they have been too busy plugging the security flaws…:wink:


(Paul Barden) #12

Is there merit in disconnecting all other devices making SSDP requests in my network in an effort to try and connect the Hue bridge. Its for sure the only thing I havent tried at this stage.

In my case, nothing has changed except upgrading the Hue bridge and deleting the old one from ST.

Also, how can I check if the bridge and ST hub can talk to eachother?. To my knowledge I cant ping out from either of the devices. I can obviously ping each separately from a computer and they are functioning fine independently?.

I’m really consumed with getting this to work again!.


#13

I can empathize with being consumed with it, I have been dealing with this on and off when I have time and am not travelling for work…at this time, with all that I have done trying to unravel this, I just can’t buy that this an issue with my setup or at least with the limited knowledge of how the integration works and what may be needed network-wise, but more on their side. I have Ubiquiti Switch, which is managed, in which both the ST Hub and Philips Bridge are connected to (and always has been, i.e. when it worked) - no VLANs, flat network. Got to admit, on a positive note, I have been getting intimate in trying to understand multicasting, IGMP, etc trying to get this to work.

In my particular situation, I am quite certain that my Hue Bridge is being discovered as is evident by:
a) ST app telling me to press the Hue Bridge button
b) Looking at the logs for both ST via IDE and Philip Hue ‘CLIP API Debugger’.

From this I can ascertain the folliowing:

  • ST can see the Hue Bridge, so it has been discovered on the LAN.

  • After a request from ST and then a Hue button press, Philips Hue receives request from ST to adds it to the whitelist

  • Hue Bridge then assigns and gives ST user string, in other words Hue has given it’s OK to use it’s API to control it.

  • This is where my issue happens from the Live logging in IDE (see above post):
    Super LAN Connect, the ST smart app being used to integrate LAN devices, such as the Hue bridge, apparently is unable to add the MAC address of the Hue. This is also where I don’t know where the smart app gets the MAC address from - I tried looking for the code, but was not able to find it.
    I think once ST gets this MAC address, I would be squared away, but alas, at this point, my hands are tied.

Finally, I reiterate, I don’t understand how all the other third party platforms (some are wireless, some wired) using the Philips API, has absolutely no issue controlling my Hue, but the one platform that I really need does.


#14

On a separate note, uncertain if it is related - but at this point in time, I am grasping at straws:

An interesting behavior is observed, when I log into IDE with my migrated(?) Samsung account vs the Smartthings account credentials I originally had.

After logging in successfully with Samsung account, I am led to the main page, but it shows:

SmartThings Groovy IDE
The Groovy IDE allows you to integrate devices directly with the SmartThings hub using ZigBee, Z-Wave, or LAN/HTTP protocols.

Get started integrating a hub-connected device.

To me - seems odd to tell me to get started by integrating a hub-connected device as I am well past that, I would have expected it go straight to my Location or my Hub.

So anyway, I then proceed to My Hubs Link at the top of the page and it shows:

You don't have any hubs yet. Please use the SmartThings mobile app to claim your hub.

So to see my already claimed hub, I have to first go to My Locations, which there is only one Location - my home, and only then do I ‘see’ my hub/devices.

Again, not sure if related, but to me it does seems something is awry when they moved me - this was not the case before.


(jkp) #15

Are you logging into IDE with https://account.smartthings.com ?


#16

Thanks for the reply, I typically go to Google and search for smarthings ide, then click on top hit, which is:

https://graph.api.smartthings.com/


(jkp) #17

There is the problem. You need to use https://account.smartthings.com which will automatically redirect you to the shard your hub is on.


#18

OK, thanks @jkp for the info, so this is an unrelated observation.


(jkp) #19

Some things to try to get Hue bridge connected to ST:

  • use the ST Classic app.
  • assign a static ip # to the hue bridge

#20

Thanks for your help and welcome all ideas.

However I have already tried DHCP, address reservation, and static IP in my testing. Static IP is what it was and is currently set at.

I am using ST Classic app and do all my configurations on it, I only use the new app to see states.