[RELEASE] TKB TZ69 Home On/Off Switch with Power Meter

dth_pocketsocket

(Adam V) #1

Hope this helps someone!

I created this handler as I could find similar TKB devices here but not this exact one - and none of the similar devices worked.

It’s a simple enough device and based it on the in built Smartthings Z-Wave Switch Secure handler. I’ve hardcoded that when on it reports power every 25s, and every 30min when off. If anyone needs to be able to change these settings I can update the handler so that these are customisable through settings.

Enjoy!


[Release] TKB TZ68E Z-Wave Outlet
FAQ: Wall plugs (Europe) (pocket sockets)
#2

Nice work!


#3

Added to the pocket socket list. :sunglasses:

And for those who aren’t sure what device this is:

http://www.vesternet.com/z-wave-tkb-tz69e-wall-plug-switch-meter-gen5-uk


(Tony) #4

I just got a TKB TZ69E and out of the box, discovery picked it up as a Z-Wave Relay. This allowed me to turn it on and off but no power readings.

I added this Device Handler and had problems with the switch not working. Initially it was showing the power drawn but this also stopped working after a while. It’s probably me as I’m a newbie to Smartthings so I probably did something wrong but the reason I’m writing this is that the stock Z-Wave Metering Switch device type works fine and shows power and energy reported.


(www.smartukhome.co.uk) #5

I’m getting the same @AdamV any ideas why this is happening?

My Raw Description zw:L type:1001 mfr:0118 prod:0004 model:0002 ver:2.51 zwv:4.05 lib:03 cc:5E,86,72,5A,73,32,85,59,25,20,27,70,7A role:05 ff:8701 ui:8700


(Stephen Hill) #6

Does this DTH have the ability to switch the LED light around on the actual unit itself?

Other ones have allowed me to make it so that when the unit is on, the led is on and vice versa. Weirdly it’s the opposite way round out of the box.


(Adam V) #7

@Hilly_2015 @tmleafs @phit03

I have a feeling you guys didn’t hit the configure button?

Can you hit that button, wait a bit then turn off and on again and then let me know how it goes. If you are still having no luck then please post logs here and I’ll take a look.

Re: light switch - I believe this is possible but I haven’t added it in. When the guys above get back to me I’ll see if I can add this in at the same time as doing any other fixes (if necessary). I can also add something to let the power update frequency be adjustable if anyone would find that useful.


(Stephen Hill) #8

Nice one. Look forward to the possible next update!


(Mark Elder) #9

Hi Adam,
I’m exactly same as @phit03. TZ69 with generic works as a switch but no power meter. Tried your handler and it will not switch on or off now (or show power!). So I hit the configure button (which has “Configure” overwritten with “CONFIGURE”), (nothing obvious happens), waited a while, tried switching on (it changes to “TURNING ON”) and just gets stuck there. What are we all doing wrong?

(My first attempt at using a non-standard handler so could easily be that I don’t know what I’m doing!!)

Thanks


(Adam V) #10

To be honest - I have no idea why it’s not working for you guys.

Can you send me some logs?

Go to the IDE and go to logging and send me what happens when you try to turn on / off etc


(Tony) #11

Hi Adam

I went in to the IDE to try to re-create the device and test it to create some logs but everything except the device handler has disappeared! I’ve no idea why and it’s late so I’ll have a look tomorrow. The smartphone app is still working OK (using the standard Z-Wave Metering Switch device type) although I’ve just migrated the app to a new phone and deleted the app off the old. Can’t see how that would cause a problem though.

The IDE just says You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub." under MY Hubs and “You don’t have any devices yet. Add one now.” under My Devices.


(Tony) #12

Hi Adam

I gave it another try and after logging in twice everything re-appeared. I re-created the device using your device handler and still have the same problem as described by myself and others. I’ve uploaded a picture of the smartphone screen showing the overwritten configure button. Not sure where to go for logging. If I go to "Live Logging"there’s nothing. If I got to the device and click on “List Events” I see as list of events (see screen shots). Is this what you want?
Sorry I can only put 1 image per post so I’ll do 2 more posts with the images.


(Tony) #13

Second image


(Adam V) #14

Hi - I was looking for logs - from live logging?

also what does this mean: [quote=“phit03, post:12, topic:62406”]
I re-created the device using your device handler
[/quote]

You did edit the device that you paired to add the device handler - rather than creating a new device… because creating a random device with my handler wont do anything. You need to add the handler to the included device.


(Tony) #15

Yes, I paired the device and it paired as Z-Wave Relay (this works for on/off). I then edited the device and changed the device to Z-Wave Switch Secure TKB TZ69. The display on the smartphone changed to the one attached. Pressing configure seems to do nothing. Pressing on/off does nothing.

Nothing appears in the live logging for the device apart from:

980595df-015a-4c4d-87e2-4428ef9ff98c 11:58:37 AM: debug power: 0.0 Watts
980595df-015a-4c4d-87e2-4428ef9ff98c 11:58:26 AM: debug power: 0.0 Watts
980595df-015a-4c4d-87e2-4428ef9ff98c 11:58:16 AM: debug power: 0.0 Watts
980595df-015a-4c4d-87e2-4428ef9ff98c 11:58:06 AM: debug power: 0.0 Watts
980595df-015a-4c4d-87e2-4428ef9ff98c 11:55:37 AM: debug power: 0.0 Watts
980595df-015a-4c4d-87e2-4428ef9ff98c 11:55:27 AM: debug power: 0.0 Watts
980595df-015a-4c4d-87e2-4428ef9ff98c 11:55:17 AM: debug power: 0.0 Watts
980595df-015a-4c4d-87e2-4428ef9ff98c 11:55:07 AM: debug power: 0.0 Watts


(Tony) #16

Further to my last post.

I’ve sussed that I need to login to the IDE twice. The first login just shows an initial screen and I have to select My Locations/Home whereby it asks me to login again. This time I see all my devices. This is why I wasn’t seeing anything before. Is this normal?

Turning the switch on/off manually using the switch on the socket results in the smartphone display updating correctly to show the correct status and the wattage seems to be displayed correctly. It’s just that you can’t operate the switch remotely. If the switch is turned on and I press to turn it off, the display changes to TURNING OFF but nothing happens and nothing is shown in the Live Log relating to the turn off event. After a while the smartphone display changes back to ON. If I press configure nothing shows up in the log.

Is it because the device handler is based on the Z-Wave Switch Secure handler rather than the default of Z-Wave Relay chosen when I pair the switch? As I said in an earlier post, it works fine if I use the Smartthings standard Z-Wave Metering Switch device type allowing me to turn the switch on and off and also view the power used.


(Adam V) #17

This is not normal. Are you using the EU link for the IDE?

Based on what you have said I think that this is the problem.

Have you tried a secure join?

Adam


(Alex Lamaison) #18

What is a secure join? Z-wave n00b here. I’m seeing the same behaviour as @phit03

Also ‘Z-Wave Metering Switch’ doesn’t reliable report power metering for me. It did for a couple of hours after I first paired the socket, but the value hasn’t increased since.


(Stephen Hill) #19

Did anyone ever get this DTH to work?


(www.smartukhome.co.uk) #20

It works as a power monitor but a switch nope. I will be changing to these in the near future http://www.vesternet.com/z-wave-greenwave-1-port-powernode
[RELEASE] GreenWave PowerNode (Single) (NS210-G-EN) - Advanced DTH