TZ88E-GEN5 - Power Meter


#1

Hello,

Anyone using this device? Does it work as both a switch and power meter for you?

Thanks
Sam


(Tim Watts) #2

I too would like to know - I would like to dump Fibaro HC-Lite as being limited and a bit unreliable. But I have a bunch of the TKB TZ88E power plugs with the energy meters,

Cheers,

Tim


#3

I would also like to know as I have a bunch of tkb meters


(codersaur) #4

Hi Sam, I finally splashed out on a SmartThings hub last week, along with some TZ88E-GEN5 metering switches (UK version). I can confirm they work fine with SmartThings, including switching and reporting energy/power/current/voltage/power factor. They also support an auto-off timer, and you can alter the behaviour of the switch state when power is restored. :slightly_smiling:

I’ve even taken my first steps at SmartThings development by writing a specific device handler for them. Code is here: TKB Metering Switch (TZ88E-GEN5).groovy

It’s my first ever SmartThings device handler, so all feedback is welcome.

David


#5

Hi David

Thanks for sharing! I have updating my device types from Z wave relay/switch to the newly added logic and am now getting Power Consumption which is great.

However I noticed I am unable to remotley switch off/on the device. Any ideas? Not sure if this related but when now go into edit device settings, and hit Done from the app, I get “please fill out all required fields”

Stumped …anyone know what’s going on?


(codersaur) #6

Ah, I messed up the required properties on the input preferences.
Try the updated version I’ve just published to Github.


#7

Appears to be doing the exact same thing :frowning:

The strange thing is v1.07 is working on my TKB GEN4 without any problems…


(codersaur) #8

Are you referring to not being able to switch remotely or the “Please full out all required fields” issue?

If the former, check in the device settings that you have ‘Enable Switch?’ Enabled and that ‘RF Off Command Mode:’ is not set to ‘Ignore’. If either of these is set there will be some secondary info text in the in the main multiTile.

Failing that, I would remove the device completely and re-add.


#9

I am referring to both items - I still get the Fill out all fields error and am still unable to toggle power switch on/off state from app and physical device.

Enable Switch is ON.
RF Off Command Mode is Toggle State.

Removing and re-adding device has not helped restore functionality either.


(codersaur) #10

Hmm, something is not right somewhere. If you get the “Fill out all fields” error, it means the config will never gets written and the configure() method will not get called. So this issue needs to be resolved first. I would attempt to clean up the device by setting it back to a native/basic switch device type in the IDE. Then going into the device settings removing any ‘orphaned’ values. Then see if it then responds to basic switch commands…