[RELEASE] GreenWave PowerNode (Single) (NS210-G-EN) - Advanced DTH

#GreenWave PowerNode (Single) (NS210-G-EN) - Advanced DTH
Version: 1.01 (2017-03-08)
Source: https://github.com/codersaur/SmartThings/tree/master/devices/greenwave-powernode-single


This is currently the cheapest Z-Wave metering power outlet available in the UK. I suspect the device handler will also work with EU/US versions.

Key features in V1.01:

  • Instantaneous Power and Accumulated Energy reporting.
  • Room Colour indicator tile.
  • Blink function for easy identification of the physical power outlet.
  • Physical and RF protection modes can be configured using the SmartThings GUI.
  • Sync tile indicates when all configuration options are successfully synchronised with the physical device.
  • Fault tile indicates overload / hardware errors.
  • All Z-Wave parameters can be configured using the SmartThings GUI.
  • Auto-off timer function.
  • Logger functionality enables critical errors and warnings to be saved to the logMessage attribute.
  • Extensive inline code comments to support community development.

Main screen:

Settings:

Logger Functionality:

The logger functionality allows critical error and warning messages to be saved to the device’s logMessage attribute (not that there should be many :smirk:). This offers a way to store and review historical messages without having to keep the IDE Live Logging screen open.

Full installation instructions and a user guide can be found on github: https://github.com/codersaur/SmartThings/tree/master/devices/greenwave-powernode-single

All feedback welcome!

Z

7 Likes

Happened to see this pop up and gave it a try with the two I have - all looks good to me :sunglasses:

Thanks indeed! Great work.

Awesome! @zcapr17 I’ll be updating the 10 I have here, very nice work.

Cheers
Roy

A word of caution. I can’t be 100% sure yet, without more testing, but I’ve been having very slow repsonse to some of my sockets since switching to this device handler from the standard “z-wave metered socket”. Slow i.e. waiting 30 plus seconds from a socket to respond to a switching command. If at all. Sometimes it can be minutes later, or not at all.

Checked with online support and the logs and the commands are getting sent immediately. The switches then take an age to react - sometimes.

I’ve switched back to “z-wave metered socket” and they are responding as they should so far… will update after a dar or two.

I’m a UK user.

This is unlikely to be anything specific to this device handler; it’s not doing anything special in terms of sending commands. I find this kind of delayed response happens occasionally for all devices and occurs when either the SmartThings cloud or your local Z-wave network is congested.

That said, make sure the Power Report Threshold parameter isn’t set too low, if the device is sending power reports every second, it will clog up your z-wave network.

Param #0 is set as default (10) on all of them. Interesting to see what happens overall.

Will keep an eye on things

Thanks for the release…

Just received mine from Vesternet. Nothing plugged into it at the moment but the price vs feature set seems very good!

Probably use this to add control/sensing of my outside flood lights (IE turn on some wall bulkhead lights if power suddenly spikes indicating the that the lamp has been turned on)

This is working nicely for me. @zcapr17 your hard work is much appreciated.

I bought three Greenwave Powernodes before Christmas and have been using them as simple switches to control fans and Christmas lights, but it’s great to be able to use the power monitor feature too :smile:

I have four of these plugs around my house and they all appear to be working with this DTH, although I have noticed one potential issue.

One of the plugs is reporting its power usage about few seconds, whereas all the other plugs don’t. They are all configured with the same settings, i.e. Power Report Threshold is set to 30 as per the recommendations.

Any ideas what is going on?

Phil

Well, I’m switching from Zipato to Samsung, receiving my SmartThings hub tomorrow.
Meanwhile I checked all my GreenWave Reality devices on the old Zipato.
I have 7 (seven!) single power plugs and 3 (three!) 6-socket nodes.

I was glad to read here that they are supported by the SmartThings, BUT, all my GreenWave devices are firmware 4.20 and 4.21, and that seems to be bad news according to the notes here :frowning:

Has anyone ever found a way to upgrade the firmware on the GreenWave devices? I took one apart just now, having tooled a special two-pronged screwdriver in my workshop, and I do see a 4-pin female-socket on a board. USB?
Any ideas? If not then maybe I’ll call their office in Denmark.

The following link would suggest you can’t;

https://www.domoticaforum.eu/viewtopic.php?f=50&t=9525#p69177

Phil

Indeed Philip_Street. However, I have seven of these so I opened one up (after tooling a special two-pronged screwdriver) and found there is just one single hardware port (10-pin, my guess is USB compatible). It is obviously for upgrading firmware etc., but how?
So only the manufacturer and programmers can provide that info, and the FW-files. Just a question of contacting the right people…

BTW, thanks Philip_Street for your Philio PSP01-1 DTH ! (we seem to share a lot of hardware :wink:

Hello

I’m a bit of a newbie so apologies if I’ve missed something obvious.

When I try to save the script I get:

No signature of method: script_app_metadata_9d2b00a3_edf9_4a34_bcd8_847282dcadb1.metadata() is applicable for argument types: (script_app_metadata_9d2b00a3_edf9_4a34_bcd8_847282dcadb1$_run_closure1) values: [script_app_metadata_9d2b00a3_edf9_4a34_bcd8_847282dcadb1$_run_closure1@430d447d] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Any help would be greatly appreciated to mget my Greenwave NS210-g-EN switch working

Thanks Tony

If this helps replying now Tony I’m not sure what you have done there. Silly question, have you pasted it in as a new device handler in the developer site in the Code tab. This worked perfectly for me when I installed it in May so it should work fine

Bit of a long shot
Been using the DTH from the start and works perfect but i do have a couple of issues with the way the DTH displays on an Android S7 phone
The tile (now) for power useage and the oposite tile for resultant (W) used display really small Text values, so small i can barely see them and the same goes for the (Since) tile and oposite value, again really small text
infact the since value tile is just blank ?? although the value in the oposite tile is displaying Kw/h

Any chance anyone can help with these couple of issues please