Z-Wave Metering Switch (Standard DTH) - No Energy Reporting?


#1

I have a few of the Heiman HS2SK-Z (UK) and they’ve been working fine for months, but sometime over the past couple of weeks, energy reports have stopped. I’ve removed/readded some from/to the Smarthings network but i’m getting the same results.

It also looks like the power report is not sent so often as it used to be (which was too often).

Is anyone else seeing this. Does anyone else have these devices and is still getting energy reports?

I’m wondering if something changed with the latest firmware upgrade. I’m using the standard Z-Wave Metering Switch DTH (local processing).


(Jimmy) #2

Looks like they’re working on a fix for this https://github.com/SmartThingsCommunity/SmartThingsPublic/pull/3485

@tpmanley May know more


#3

@tpmanley, any comment on this? It is still broken for me. No energy reports and very intermittent power reports meaning the ability to do “on or off” power monitoring is pretty much impossible.


(Tom Manley) #4

@Paralytic That DTH hasn’t really changed since June except for the addition of some new fingerprints. It was near the end of August/beginning of September that you noticed the change?


#5

@tpmanley, I noticed it on Sep 18th and reported it but I don’t know how long it had been like that. I then removed/re-added the devices and I saw some energy events coming again but they stopped again on 20th September. I’d set up SimpleEventLogger to log things and it stopped then across all 4 of my devices using that device handler and the last energy entry I have is early on 20th September UK time.

And power events now only show in the app on a refresh.


(Kianoosh Karami) #6

@Paralytic Can you DM me the name of the devices you feel like it is not working correctly?


#7

@Kianoosh_Karami, its in the first post above - Heiman HS2SK-Z (UK).

I’m getting intermittent energy reports, but no power reports, but they’re otherwise working.

One of them has started to give more consistent energy report (still no power) so I am wondering whether its something to do with my mesh and repeaters, though they all worked fine previously. I’ve done a hub reboot/z-wave repair, but if no-one else has reported issues…

It would be good if someone who has these devices could report if their energy reports are working, then that would point the finger at my network.