Re-repairing my GE ZWave Dimmer with Aux Switch


(Marc) #1

My GE ZWave Smart Dimmer wasn’t responding, so I force removed it from ST and tried to do an exclude, repair, etc. and Smartthings is not able to find it. I tried resetting the breaker and pulling the air gap out of the switch, resetting it by pressing up and down 5 times and nothing seems to be working. One thing to note is that it is tied to a GE Zwave Auxiliary switch in the same room, so I am not sure if that has anything to do with this issue or the way I am trying to re-pair it to my hub.

Is this switch now defective? There are other powered zwave switches around this room, both outside my home and inside, so I doubt it’s a range/signal issue.


(MarkTr) #2

Does it still work when you toggle / dim it from the switch itself or from the auxiliary? The add-on switch shouldn’t have any impact on anything Z-wave related.


(Tony Fleisher) #3

The GE aux switches are not z wave; they are weird to the primary switch, so not likely a factor.


(Marc) #4

Yes, physically, BOTH switches work fine. Just can’t seem to pair it anymore to the hub.


(Nathan Curtis) #5

Have you tried running a general device exclude on the switch before trying to re-add it? Force exclusion doesn’t tell the switch its no longer part of the z-wave network. Until it’s doesn’t think it’s associated to the network anymore it won’t enter discovery mode.


(Marc) #6

Yes and i believe it did get excluded properly at one point.


(MarkTr) #7

I installed 4 GE switches (12727) today that I purchased used from someone in the group here. Two worked after a single cycle of exclude and factory reset. The other two took longer - I tried both of those a handful of times, repaired the Z-wave network, took a break and when I came back one of them had shown up in “Add a Thing”. I couldn’t get the other so I went out for a few beers and when I came back, I did an exclude, waited until that had timed out, then went back to Add a Thing and toggled the switch on, and it appeared immediately. Not sure which step made the difference, but it seems like patience can help


#8

Did you try using a zwave replace? Just replace it with itself.


(Marc) #9

Yes, this was the first thing I tried.


(Doug) #10

random question but ive found this helpful in testing, do you have a z stick?


(Marc) #11

That I don’t have yet…


(Doug) #12

ive found it to be useful, sometimes a device just wont pair for whatever reason, then i pair it to the z stick, then unpair and normally it repairs with the main network on the first try after that.


(Marc) #13

How is this done? So I purchase a Zwave stick on amazon such as below. Do I need to run any sort of controller software such as OpenHab on my laptop that has the USB stick plugged into it?

Aeotec Z-Stick Gen5, Z-Wave Plus USB to create gateway https://www.amazon.com/dp/B00X0AWA6E/ref=cm_sw_r_cp_api_G0UvBbR6XFNKM


(Doug) #14

no the stick is basically just a gateway, you remove your device from your current hub, or if it is just glitched up factory default it. Then you put the z stick into pairing mode and activate the pair on the device, once paired you then put the z stick back into pairing/unpairing mode and remove the device (should be a button press or something on the device, the same way you pair it to your real gateway) then you re pair it to your normal hub.
The only need for external software is if you plan to use the z stick as an actual hub. Its also the only really easy way to update aeotec devices over the air with firmware using smart things as a hub.

Since its just a temporary thing if you know anyone that owns a z stick you could use thiers.


(Ron Talley) #15

I had one do this to me. No matter what, it would not be found. Had to replace it. Guess 1 out of 50 wasn’t bad…


(Marc) #16

Hi,

I did some more troubleshooting and even went as far as to replace the dimmer switch with no luck. I looked at the Hub Events in the IDE and I noticed every single time I started to do a zWave include and pressed the paddle button, my Fireplace Floor Lamp (a totally different device) would re-join the zwave network and then end my zwave inclusion (with a zwave inclusion finished event). I even unplugged that device (it’s an outlet) and it still happens. I deleted that device, and then another one re-joins when I try to repair either one of them, so now I have 2 devices that do not work. It’s almost like I have a corrupt zWave network. Everytime I try to do a repair, I get a failure, but that has been the case for 4 years.

Any ideas?


(Doug) #17

do you have a lot of devices? or just a few? if few maybe remove them all and factory default the hub? Not sure what the procedure is but I’m sure it can be done.


(Marc) #18

Yes I have close to 100 and that would be a nightmare. I’m dreading the day I have to do that and would consider other products that have restore restore features at that point.


(Doug) #19

in that case i’d try my z stick fix, its worked every time for me.
worst case you’re in the same place but have a z stick for firmware updates to any aeotec device.


(Marc) #20

Well, I am seeing even stranger behavior. Now when I turn my Patio Light on/off, the fireplace floor lamp light AND Patio Light is going on and off. Before that it seems my Playroom light (the original problematic device) was tied to the fireplace floor lamp light. It seems that the only solution here is a complete rebuild of my entire zWave network, but I will wait for support to chime in.

Ever since I added my Abode zwave gateway as a secondary controller (which I undid), I’ve had very weird zWave issues and my zWave network has never been the same since.

Time to potentially look at other products. Perhaps Home Assistant or Hubitat…I don’t want to invest more into Smartthings as I don’t trust Samsung.