GE Z-Wave switch problems

In-wall GE Switch ZW4003/12727

This switch has been working for several years, but started misbehaving in the last few months – intermittently it stops responding to Smartthings and it also stops operating manually (eg, flipping the switch has no effect on the bulb).

I removed it (four taps up, four taps down, then did z-wave exclusion from the hub) but cannot get it to add back. Oddly, the Smartthings iOS app only shows zigbee switches under GE now, and whether I choose that or generic z-wave device, it just times out when I try to add it.

Does this switch have a physical problem? Any advice on how to get it to successfully add back?

Thanks in advance for any advice.

If it stops responding at the switch its a switch or wiring problem.

I am putting in a replacement switch (luckily just had one lying around). Any advice on why I don’t see z-wave option under GE Switch in the Smartthings iOS app?

Thanks. Replaced it, got it working with “generic z-wave device.” Still have no idea why the app is not showing GE Z-Wave switches anymore, will save that problem for another day.

1 Like

You’re better off with genefic switch on those anyway. That dth runs local on the hub. Custom ones don’t. With those old GE switches they dont support scenes or multi tap so you dont need the custom stuff from a custom dth anyway.

I have a z-wave 12722 for the last 4 years. It’s been working flawlessly until today. Now the manual switch will not turn the lights on. Last night we had a brief power failure. Everything else is working ok. I’ve tried turning off the breaker, and turning it back on again. I’ve been trying to exclude the switch and repair it, but so far it’s unsuccessful. When I tried to turn it on with the smartthings app, the blue led flashed briefly, but nothing happened. As suggested by a video I found, I pulled out the tab next to the led, pushed it in again, and then pressed the switch 10 times. Now the led does not come on when I use the smartthings app. I’ve tried to exclude it, but the smartthings app says it can’t be excluded because it’s functioning correctly (which it isn’t). I have pressed the switch once after it starts to try to exclude it. Are there any suggestions as to how to proceed, or do you think that the switch is dead?


1 Like

I’ve had a few of them go bad in a similar manner over the years. Sorry, but I fear yours has given up the ghost.

I was afraid of that. Does anyone have any suggestions as to how I can delete these from smartthings? I’ve tried a number of times. Each time smartthings says it can’t delete it because the switch is still functioning! I’ve tried hitting the rocker after putting things in exclusion mode. No joy :-(.

Cut power to the switch with the air gap or the breaker first