Radio thermostat ct101

I have a Radio Thermostat CT101 I would like to try and get working. Anyway one have any idea how to make this work ??

What kind of issue do you have? There are plenty of folks here who posted things related to this thermostat so I believe you should be able to get it working soon

I had a CT80 a few years back and had it working. I picked up the zwave module for it cheap on ebay and connected it that way. Someone had written a decent device handler for it and it worked for the most part from what I remember. I think I still have it in a box somewhere.

I’ve been using a CT101 for some time with no issues. It is a WIFI unit. The manual is pretty good about how to activate the radio. Then just put your hub in connect mode and it should connect ok.

Does it have a z-wave module ? If it has one, pair it up with the hub (you can google the instructions, pretty easy). Make sure it runs on a C Wire for best performance and you attach the C Wire BEFORE pairing it so it works as a repeater.

You can use the stock ST device handler for basic functions or the enhanced device handler below for advanced features and settings.

I have 2 CT-101 thermostats that is using the COOL settings for Heat. The changes I made to resolve this is Device type: Enhanced Z-Wave Plus Thermostat with Temperature, Humidity and Auto Time setting and CT100(suggested by ST support).
I have removed/excluded the thermostats,restarted the hub; I have used the reset for the thermostats- I have also tried different apps to manage the thermostat daily settings:the 5-2 thermostat with remote, Individual Change thermostat.

Anyone have any experience with this issue and have an idea?


Can you elaborate on this a little. How did you figure that it’s using the cool settings for heat? Screenshots of the thermostat or the device page would be helpful too

Sure- I set the Cool setting temp to a low temperature to assure no confusion as I tried to figure out where the temperature setting was coming from. I am attaching 2 screen shots. In these shots you can see the heat set to 44 and the setpoint at 44 degrees.

You appear to be running into the deadband issue. Look like you’re using a custom device handler. If this based off the stock st device handler it has inherited the same issue. The device handler will enforce a 3 degree separation between the heat and cool setpoints. So when your SmartApp send 44 for heat the device handler is likely setting 47 for
Cool (which your recently logs also appear to show).

The Cool temp was set to 44 in the app and the Heat temp was set to 65 in the app. When the app ran on schedule, the heat setpoint was 44 degrees as you see in the attached, which was the Cool setting. Sorry, I dont see the 3 degree difference from the 44 and the 65. This was while using the 5-2 thermostat app. I did a search ‘deadband’ issue and find: _Supports synchronizing SmartThings dead-band settings with thermostat- I see this is associated with the DH-Enhanced Z-Wave Plus Thermostat with Temperature, Humidity and Auto Time setting. I’ll update the thermostats and see if that corrects the deadband issue you mention. Thanks

Same issue. As per new ST device handler the heat setting cannot be greater than the cool setting since this tends to “confuse” some thermostats. The deadband code also enforces this sanity check.

Thanks for the update RBoy-This is what I have done since- I removed all the thermostat apps, and set the DH to the _Enhanced Z-Wave Plus Thermostat with Temperature, Humidity and Auto Time (Ver 4.0) . I set a schedule to autoset the heat to 67 Cool to 66, DeadBand setting is 3. Attached are the screen shots that show the notification was sent on time, but no change to the thermostat setting. Any idea what I am doing wrong? Thank you

As I mentioned earlier the heat setting cannot be greater than cool settings. The deadband settings only works for thermostats that support deadband, the CT-xx doesn’t support deadband configuration, so the default is 1 degree is enforced by the device handler.

If the commands aren’t reaching the thermostat that would indicate a z wave issue. Your thermostat is too far from the nearest repeater or it’s lost its connection to the hub. Try repairing it or bringing it closer to the hub/repeater or you hit the black reset button on the thermostat and that helps sometimes.

Rboy, I have a CT101. I have been using the stock DTH for some time with no problem. Thought I would try out yours for comparison. So I installed it yesterday.

Sometime during the night it changed my heat setpoint from 72 to 62. I can’t find any reason for it to do that. I don’t use night setback, just have the same temp setting 24 hours per day.

Any ideas where that might have com from? I changed back to the stock DTH for now until I get this figured out.

Device handlers cannot initiate changes. They are always done by smart apps. Open your device “Recently” page on your mobile and it’ll show you a list of all commands that were sent to the thermostat and by which app.

I did that and can’t find anything in the recent list that changed the setpoint. The only thing I found was something about setting the time. Never saw that before. I don’t have any smart apps or anything controlling that thermostat.

The entry says CT100 Thermostat set clock is setting clock to …then the date and time. Don’t know where that is coming from.

I’ll try it again. Maybe it was just some kind of blip or fluke.

I just purchased the CT-101. I took a picture of my existing (non-smart) thermostat, labeled the wires according to the terminals they were attached to, and then connected the wires to the same terminals on the CT-101. I set the hard switch on the CT-101 to Heat Pump for my HVAC, and type of heat to Gas for my aux heat, set the HVAC mode to C in the CT-101 HVAC menu (single stage HP, single stage aux heat). I could get the cooling system to kick in, but I could not get the heat pump heat nor the aux heat to come on. I haven’t even tried pairing the device to my ST yet. I uninstalled the CT-101 and placed my old thermostat back on to make sure nothing else went wrong during the installation, and all systems work fine. I know this is not a ST issue, but I was wondering if anybody else had similar issues with this thermostat?