Need help with working CT100 thermostat code with battery and humidity


(Ron S) #1

Really need help with working CT100 thermostat code with battery and humidity. I was using the z-wave thermostat device type and lnow @wackware’s latest code once I started having major issues all of a sudden today when both the CT100’s failed to shut off the heat and the temp kept increasing even though the status showed off. Would really also appreciate what your activity shows in the MobileApp. This will save me couple of dollars to call a HVAC guy to rule out some issues. I excluded the devices and it started working fine and I have again included it with @wackware’s device type and keeping my fingers crossed. Things were perfect till this morning.

This time I really need your serious help.


(John Essey) #2

Not helping, just stating that I’d also like to see a bit more done with the CT100.

I have a monitor set that if the CT100 goes above 80, alert me. Every so often (once every 3 months) I get an event notice that my temp is 88 or something crazy (above threshold). I freak out… I check via SmartThings, reports high temp. I check via another Controller (reports what I believe to be accurate), then I calm down. I opened a case with Support, was told that it’s due to my device type (using @wackware’s device type).

To be honest, I recall when there was an ‘official’ support devices spreadsheet in google drive, which included the CT100. Not sure whatever happened to that (was last year, I believe). Just thought some of the basic / necessary features like battery and humidity would be there at launch, or…a year later hehe.

Seriously though, I’d love for this device to have better integration, I’d donate whatever :smile:


(Ron S) #3

@johnessey totally agree! For once a dropcam in the basement helped me today. I noticed the CT100’s going up, up and up. Tuned them off via the app. Checked the dropcam in the basement from office and saw the furnace turning on at regular intervals even though the thermostats were off. Excluded the devices… Issues gone… Have re included them and now keeping my fingers crossed. I was about to leave from office 30 miles from my home to check what was going on…

And it is very much a supported device if you look at the device list and as well as when you add a device from the mobile app.

Expecting an Ecobee 3 tomorrow for AC and will see what issues that bring in. As such have opened an ticket…


(Todd Wackford) #4

@Smart,

Please send in a support ticket on that. My device code should not be the issue. I just did UI things.

T


(Minollo) #5

I have 5 CT-100 in two different locations, and I’ve never had this kind of problems; all I can complain is that when they just battery operated, their communication becomes a bit spotty.

Are you sure there was no sun coming in from any window and hitting the thermostat? One of my thermostats is hit by the sun for half hour in the mornings during this season, and it indeed jumps up several degrees during that period; but it comes down to reality as soon as the sun moves away.


(Ron S) #6

Not doubting your code one bit.


(Ron S) #7

The sun doesn’t shine on those thermostats.:frowning:


(Brad B.) #8

The only issue that I have had with mine is that no matter what I do, I can’t get the battery level to show. But, other than that, I rarely mess with the thing. Having humidity is cool though. Magic Home takes care of changing the temp.

Have you tried using the temp reading from one of your motion sensors?


(Ron S) #9

Looks like it is working okay all of a sudden since yesterday night. Go figure! I had excluded it from the zwave network and re included it back but using wackware’s better thermostat rather than the generic z-wave thermostat device type. And yeah, it compared it to others and the house was like a furnace. The temp. kept rising.


(Ron S) #10

Started again. Temp. started going up even though the thermostat operating state says Idle.

Drove back home 30 miles from work and excluded the CT100’s from ST and it appears it is working fine again. Don’t see the furnace running again unnecessarily of its own and temp. has stopped going up and up.

This is really weird. This is what it was showing when the temp. actually kept climbing up…

Current States
temperature: 66.5 F
heatingSetpoint: 63 F
coolingSetpoint: 78 F
thermostatSetpoint: 65 F
thermostatMode: off
thermostatFanMode: fanAuto
thermostatOperatingState: idle


(Ron S) #11

Guys, nobody to help out poor old smart here? The thermostat works beautifully without ST. If somebody can post or pm me their working code without C wire. The current ST zwave thermostat device type and @wackware’s version are very different. I am totally utterly lost for the version which works with CT100. The fingerprints are all so different too when I compare the CT100 and ST stock device type. I don’t see any in @wackware’s.
Appealing to fellow brothers @minollo @DITPL @April @wackware @tyler @duncan @jody.albritton @AaronZON


(Aaron) #12

@smart - I haven’t carefully reviewed all the details . . . .just wanted to note that there are no ‘hooks’ in a z-wave thermostat directly to the heating outputs (W terminals). I don’t think there is a mechanism available to any device connected via z-wave to force the thermostat to continue calling for heat (energizing W) even though the temperature is above the set point. Not sure if this is directly applicable to the issue . . .


(Ernie) #13

Hey Ron, I have been using the Better Thermostat with battery and time, which was a modification of wackwares original Better Thermostat device type by Danny C. It doesn’t have the humidity readout but has worked flawlessly. Only issue is that it takes some time to update temp changes. If you check the activity it will update then. Just curious, what does the setpoint on the thermostat itself indicate when the issues are occuring? Also, I recall reading that you were installing 2 CT100’s. Are both having issues? Also, check that the hvac type and heat type are properly set for your system (settings are in between the batteries. )


(Ron S) #14

Yes both are having issues and works flawlessly when not included in ST. Will update more once I get back home from work…


(Ron S) #15

The issue is when I turn both the thermostats to off via ST (when they are included), they show the status as off in the app but fails to turn the heat off and temp keeps rising. At times I see emergency heat coming up in the app. Have no auxiliary device, heat pump or anything. Just two wires.

While when they are excluded from ST and running of its own, it works flawlessly. Heats turns on and off based on the set point and all the stuff.


(Ron S) #16

Thanks all guys! Will try all the suggestions tmrw. Health issues today. :frowning: I am sure it will get resolved. :slight_smile:


(Ron S) #17

Thanks a lot, guys for all your help and suggestions ! @minollo, it appears that your code is working fine for me and the thermostats behaving the past several hrs. Hope it is just a few more days to spring here in Jersey so I can shut them all off.

Thanks to Brad from Support for following it up.


(Ron S) #18

Guys, I just wanted to apologize for the frustration regarding the CT100’s and the device type. I had the HVAC guy come in and he immediately found a faulty zone valve on the heating unit and not responding to Its corresponding thermostat. After 250$ down for the new valve and installation charges along with @minollo’s device type, it appears to be working as expected.

Just wanted others to know that if you are wondering whether CT100’s work with 2 zone hydronic heating with 2 wires only, it does.

Weil McLain gas furnace:

Zone valves:

Thermostat:


(Ernie) #19

This maybe a little of topic, but I think I recall you posting somewhere that you pay for worryfree. I thought that meant a worryfree contract with PSE&G. If I am correct and you cover your heating system you should be calling PSE&G for repairs thst will be probably be covered under the worryfree contract. If not, you may want to look into it. I have an older heating system that has required a few repairs through the years and this insurance has saved plenty.


(Ron S) #20

@ErnieG Thanks for reminding me… It didn’t even click in my mind. Will check. I didn’t consider it because I kept thinking that the thermostat was the issue… :frowning: and I also got the repair done by a third party… Double bummer!