Missing Devices Issues Migrating to New ST App

Thanks, @Brad_ST. I do see all the devices under the new account, however I’m still unable to control some of them. The ticket has been updated with the affected devices.

No. I understand the frustration but I don’t have the ability to change the region on the backend. That request has been made and escalated previously without luck. However we have been successful with creating a new account. If you have a gmail account you should be able to easily create a new Samsung account with a variation on that email address. While not ideal, you can create a new Samsung account for example@gmail.com with example+st@gmail.com, e.xample@gmail.com, etc.

The control issues seem like fairly standard routing/range/interference issues. I deleted a ghost Z-Wave node and ran several more repairs which may have improved device control.

@Brad_ST My region was changed before the migration by Samsung support. My account was on the US region since 10 years or so, then, after having a issue in spring you advised to change it to Sweden, since I’m in Sweden, after a lot of back and forth Samsung support changed the region, so I was on Sweden. Then, some weeks I think later, the classic Smartthings app wanted to migrate to the new one. So the moment I initiated the migration my Samsung account was on the Sweden region. So if my migration happened while I was on the proper region, then is my scenario the same as the one described in this thread? Because maybe it’s not and then can be fixed on the existing account.

Unfortunately you are in the same situation. Your location currently won’t sync properly because of the region mismatch.

The region that is displayed does change when the Samsung account support team changes an account’s region which led us to believe that was a viable workaround to fixing this issue. We have since come to understand that changing the region does not correct the issue as attempting to sync a location with the new app is still not successful.

Changing my location back to US would fix it?

No that would not help. These are the two options and both require creating a new account:

@Brad_ST Ok, I created a new Samsung account (my original one is @gmail so I used the gmail trick with additional email addresses on the same gmail account). I would like to go with option #2 as mentioned above in the thread (so I don’t add again all my devices as they are a lot, but instead I would like them migrated to the new account). What shall I do next? Do I create a new location there in the new account? Am I doing it online via the api? Do I setup the new app on my mobile with the new Samsung account and create the location from there? Do I need to create any location at all? Am I telling you here on the forum the details of what account to be moved where?
On the support mailbox no one answered to my tickets for months (I got even an automatic email saying sorry for the delay but if my issue is solved they would happily close the ticket), here is the only place where I got some feedback since June/July when the issues appeared. I would really like to get this sorted out as I see it got some momentum… got a couple of replies in 2 days… despite the headaches with a new account, at least if I see this solved, that would be super nice as it’s been driving me crazy…
Thanks!!!

With the new account, sign in at https://account.smartthings.com. Then update your support ticket with the details of the new account. I can then perform the transfer and let you know once it is complete.

@Brad_ST Brad, please see the ticket “Support request #1053009: Moving account data to the new account” for a follow up.
Thank you very much for you support.

1 Like

@Brad_ST I hoping you can help me as well. I’ve had the same issues as @wolfewl and osorin. I’ve put in multiple tickets, but the latest is 1057000

Initial issue was that i could not invite my wife as a member through the new Smartthings app. It worked fine in classic. My second issue is that i cannot add any new devices through the new app. If i add a device through Classic, in the new app they do NOT show up under devices, but DO show up under my home hub device list, but assigned to “no room”. I cannot control them from the new app, but CAN control them through classic, Alexa, ActionTiles and IFTTT. Basically 3rd party connects CAN access it but not the new Smartthings App.

History of Communication with Support:

  1. My Samsung account was apparently linked to the India region (not sure why, as i’m in the US). Smartthings support suggested i ask Samsung to change my region to US. This was completed for my account. This did NOT allow me to invite my wife as a member through the new app. I was told to create a new account and start all over. I have 70+ devices and this is not practical.

  2. I cannot add new devices through the new app . When trying to add a device, the device is never found. These are zwave devices, such as Sylvania flex strips, which are compatible. After several weeks of back and forth, Support told me to create a new account and start over.

I’d really appreciate if you could help migrate my hub and devices to my new account? I will update my ticket with these details.

@Brad_ST i updated my service ticket, but haven’t heard anything yet. Assuming the team is busy with the final days of migration to the new app. I’m kind of stuck until this issue is resolved. i can’t add any new devices or invite other members.

Can you sign in with your new account at https://account.smartthings.com? That action pulls the account from the Samsung account service into SmartThings and is a necessary step.

@Brad_ST Sure, i just signed into my new account. i don’t see any location or hubs in this new account right now.

@Brad_ST I assume you saw my ticket with my old account email and my new account email?

Before the transfer that is expected. I ran that transfer today and you should be all set now though.

@Brad_ST Wow! Looks like all my devices are working, i can add new devices and i can invite new members. It’s been a stressful month trying get these issues resolved through CS, so thank you for your help, really appreciate it!

1 Like

I am on the same boat. My account region is US (for some reason) and my actual location is in Greece so I have lots of devices missing, including my Konnected setup. I have two support tickets going, 1030687 (Devices do not show up in new SmartThings app) and 1034069 (Konnected user’s devices not appearing in new app). These tickets are almost two months old now (supposedly developers looking into it) and still no resolution. @Brad_ST Is there any update on resolving this issue without having to create a new account? I have services connected to this account (like ActionTiles) and I am worried creating a new account will mess things up. One thing I did try was to create a new location in the US and then re-adding my Konnected device to that location, which seemed to work (the Konnected devices showed up in the new US location), but then there is no way to merge the locations (so I can bring my US location devices back to the Greek location). Any advice?

I’m pretty sure I’m in a similar boat. Just posted a thread that has many of the symptoms described here: Problems with missing devices when transitioning from classic to new app

However, as far as I can tell my Samsung account and Hub are both in the same region. @Brad_ST could I get some assistance? ST support has not been helpful thus far.

I am having the same issues, my region looks to be Europe/London which is correct; ive had multiple emails from tech support, latest one 1018906 and i’m still missing half my devices and operability in the new app. Its damnable frustrating to say the least.
Devices only show on the internet logged into my account, or via the app looking at the hub. Cannot add rooms or devices, or anything else. Maddening, and i’m now looking at Hubitat and using Home assistant for the time being.
Can anyone guide me? I do have 3 hubs, and three accounts unusually. the hubs for my USA account seem to be ok, even the one I’m using in the UK, the main account for the UK though has about 60 devices, of which 29 currently show up.