Please help. Hub is installed. Cant add anything :( Schlage Lock


#1

Got home this evening and installed my hub. I have the Schlage Camelot Deadbolt. Activated ZWave on the lock, got the green check mark and the app on my phone picked it right up. Half way through the setup I got an error but didnt see what it said. The lock is now listed for me in my home/things/ and the lock shows as locked however when I press unlock nothing happens.

So I think maybe I didnt turn on enroll properly and thats why I got an error. So I enter programming mode on the schlage and hit 0. Now it flashes a red x every time and if I try to delete the device from ST app it tell me doing so may cause me to have to exclude it from the controller first.

What am I doing wrong? I am by no means a novice when it comes to technology but this is really frustrating. I would appreciate any help I could get

On the schlage I removed the battery cover and unplugged the batteries. According to documentation the inside light should flash red if enrollment is turned on but it doesnt flash red.


#2

Hey guys, I checked the recently tab for the device and the error was This lock failed to complete the network security key exchange. If you are unable to control it via smartthings, you must remove it from your network and add it again.

What do I do?


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #3

How far is the lock from the hub? It should be within 12 feet during pairing to ensure proper set up.


(Ben W) #4

You need to remove it from the network. You should be able to delete the device from the ST app, then go into repair mode again on the lock.


(Ben W) #5

Here is a post that sounds like it will fix you up.


(Ryan) #7

You to bring the lock closer to the hub. The hub runs on batteries, unplug it and pair it right next to the lock. They do this for security reasons, mine wouldn’t pair and I was 5 feet from the lock , then I moved it closer and it worked .


#8

Doesnt the hub have to be connected to the internet?


#9

Thank you. I have deleted the lock from ST. I have performed a reset on the schlage lock. I dont have the ability to bring the hub within 12 feet of the lock? It is currently about 25FT. I cannot find the ZWave utility in the app?


(Ben W) #10

The zwave repair is used after connecting, its under the location setting.

If you cannot bring hub closer, try to place it away from walls and other obstructions. Maybe in the middle of the room, during the connection. You can always get a long Ethernet cable from Amazon to bring the hub closer temporarily.


#11

If I go to my locations the only thing listed is my home.


(Ben W) #12

Click the gear in the top right. Then click home hub. It’s under there. Easy right?


#13

Ok I got the device excluded and its now give from the St app. Now when I try to turn zwave back on in the lock I just get 4 blinking x’s


(Walter Edwards) #14

How to fix a Schlage lock that will not pair. The lock will pair if to far away from the HUB, but not work. It will say that there is a security violation. The following procedure must be done exactly to work. It took me more that a few hours to find what worked. The reset lock command will not reset the Z-Wave part of the lock, a exclude must be done. Some times the remove lock from the app will work but not all ways.

The lock needs to be installed in the door. Do a reset by removing the battery and holding down on the Schlage button on the out side of the door and connect the battery. The lock will blink twice. Enter a default unlock code as read from back of the lock or book. The lock will go thought a calibration. Extend the bolt on the lock by pressing the Schlage button on the outside of lock. Bring the Hub within 1 foot of the lock ( I used a long network cable). Go the the z-wave utility in the app. Issue a general exclude. Enter the programming code on the lock then go to exclude mode by entering 0 in the lock. The light on lock will blink faster. Magic will occur. Make sure that the green check make appears. The app will say one device excluded.

It will pair now.


#15

Ok got it. For anyone who stumbled across this post having the same issue. You have to have the app searching for the device when you enable zwave. The booklet makes it sound like program code+0 turns on zwave. Thanks for the help guys.


(Ben W) #16

Yeah, always have the app searching first. Glad you got it up and running.


#17

How do I get me light bulbs added?

I have 8 Osram lights and 2 Hue lights. All of them are currently connected and running through the OSRAM bridge.

When I search in ST for the bulbs nothing is found.


(Ben W) #18

Sorry I am no help with OSRAM, no experience setting it up.

With the Hue bridge, you have to hit the button to allow ST to connect to it.


(Bernie H) #19

You need to reset all the lights. Osram are easy just follow the toggle power procedure.

Hue I’m not sure how to reset with the osram hub, I know once paired with the ST hub cannot be reset just so you know.


#20

So I’ve give through the rest procedure with all but one of my bulbs. Half of them will not reset?

Additionally I also have smart things finding two devices listed as Things. ?


(Bernie H) #21

If your sure they are the osram bulbs you can go into IDE and just change the device handler. Sometimes ST can be flakey recognizing stuff.

The reset can be a pain. Be patient and just on off it slowly and sooner or later your will see them reset. I just added a used osram strip to my system. It took more then the stated 5 cycles to reset it. All in the timing.