Schlage camelot lock not responding

I have tried putting the st hub in to exclusion mode and then entering the zwave program mode on schlage lock it searches and then I get the red x on the lock. then I try adding the device again with no luck. I can not go to edit device because the device is no longer listed in smart things

My experience is you will not be able to re-add it to ST for as long you as you get that internal button blink on applying power. I have two of these locks:

Lock 1 - I brought the ST hub within 2 feet of the app and the general purpose exclude worked. Confirmed by both the checkmark and no button blink. Lock then worked

Lock 2 - the approach above never worked and always had the button blink - no idea why. So I did a full reset on the lock, which clears all z-wave but also resets all the codes. The lock then connected with the ST hub 2 feet away

Note - If using one of the lock code smartapps, then a full reset isn’t a bad idea since you should clear out all of the old user codes before using the smartapp

1 Like

I have done a factory reset on the lock numerous times i cant seem to get it to release the zwave network although it does reset all the user codes. I tried to remove the lock from st without excluding it when it was not responding by doing a force remove any other ideas how to resolve this?

just returned the lock and bought a new one and so far so good was able to pair with the network and lock and unlock remotely and manually… hope it was just an issue with the lock itself and not the hub any ideas why it would just stop responding?

If it worked for a while then stopped, it is usually due to improper pairing, or too much interference, bad connection with the hub while programming it or operating it .
I would strongly suggest a ZW repeater between the hub and lock, be it a switch, outlet, whatever. Just to make sure lock is getting strong signal

1 Like

How to fix a Schlage lock that will not pair. The lock will pair if to far away from the HUB, but not work. It will say that there is a security violation. The following procedure must be done exactly to work. It took me more that a few hours to find what worked. The reset lock command will not reset the Z-Wave part of the lock, a exclude must be done. Some times the remove lock from the app will work but not all ways.

The lock needs to be installed in the door. Do a reset by removing the battery and holding down on the Schlage button on the out side of the door and connect the battery. The lock will blink twice. Enter a default unlock code as read from back of the lock or book. The lock will go thought a calibration. Extend the bolt on the lock by pressing the Schlage button on the outside of lock. Bring the Hub within 1 foot of the lock ( I used a long network cable). Go the the z-wave utility in the app. Issue a general exclude. Enter the programming code on the lock then go to exclude mode by entering 0 in the lock. The light on lock will blink faster. Magic will occur. Make sure that the green check make appears. The app will say one device excluded.

It will pair now.


Thanks @Walter. I actually just realized that I had a whole reply explaining the difference between just resetting and doing the full restore to defaults reset. I got distracted and never actually posted it. Pretty pointless now since you already did.

Precise reason why I have a Aeon zwave plus switch (no device type available as of now identified as zwave metering switch) doing nothing between the hub and lock which also serves as a night light with really bright led! :wink:

I know you have already returned the lock and got a new one, but just in case this will help someone else…

I had the same problem - my Schlage Camelot lock worked with my v2 hub to unlock/lock for a few days and then it stopped working. I think it had something to do with manually unlocking and locking the lock because after doing that, I was unable to unlock/lock from my iOS app since it could no longer get the correct status.

So I force deleted the lock from my Things so it no longer showed up on that list and then I tried to add it back to the hub but it could not find the lock again. I tried to exclude it from the app via My Locations -> Hub -> Z-Wave Utilities -> General Device Exclusion but it would not get excluded - every time I push the Schlage on my lock, enter the 6-digit programming code, and press 0, I would get the red X instead of the green check. After many unsuccessful attempts, I happen to notice that my lock was still showing up at but it had the status of Removed. I clicked the link for my lock and tried to Delete it, but it would not let me, saying that it was In Use. Then I noticed at the bottom of that page where the Edit/Delete buttons are, it showed the SmartApps that were using it. After uninstalling that SmartApp (for me, that SmartApp happened to be IFTTT), I was able to exclude the lock and add it back to my hub.

After adding the lock back to my hub, I thought it was still not working. But it turns out I have to wait about one minute and then it started working again; I was able to unlock and lock from the app.

1 Like

My lock was working with v2 and now it stopped. I REALLY hope this helps. I am extremely frustrated with my camelot especially since it worked in the beginning. Did you have to have the hub within 2 feet of the lock? I already have a GE switch as a repeater bout 10ft from the lock and the switch is about 10-15ft from the hub. Just to make sure I get this all correct:

  1. Make sure lock is not in smart apps and delete from graph.api… if necessary
  2. Run the general exclude on ST and then run exclude from Schlage
  3. Next go to ST app and then search for new devices

Let me know if i missed a step or two and thank you for detailing your solution.

Yes, those steps are the ones that I went through. I did also do a “Repair Z-Wave Network” under “Z-Wave Utilities” at some point (I think last step) as part of my desperation moves but I don’t think it did anything in my case since the lock is my only Z-Wave device. Since you have a GE switch (assuming it’s Z-Wave and not Zigbee), this might help you.

No, my hub was not within 2 feet of my lock when I added it. My lock was already installed months ago on a side door in my garage and I was not about to remove it just to get it connected to the hub. When I got my lock working initially with my v2 hub (I did not have any Z-Wave controller before this so the lock was never connected to anything else before), my hub was actually in an upstairs office next to the router that is connected to my cable modem. If I were to measure the distance in a straight line, it would be about 30 feet diagonally through a ceiling. But after the lock stopped working with my iOS app and when I was unable to add it back, I moved the hub to the garage but it was still 10 feet away. With this move, I connected the hub to a downstairs family room router which is connected to the upstairs office router via ethernet. However, when I was still unable to find the lock, I moved the hub back inside the house near my downstairs router, which is about 25 feet away from my lock and through two walls but on the same floor level. This was where my hub was when I got the lock to work finally. I have no other Z-Wave devices on the hub to act as repeater. I do have a WeMo light switch next to this lock and it’s connected to the v2 Hub, but since WeMo is not Z-Wave it can’t participate as a repeater.

One comment I have about this Schlage lock is that it is very slow compared to my other devices and I don’t know whether it is just because Z-Wave devices are generally slower. I have WeMo light switches, WeMo outlet switches, WeMo light bulbs and GE light bulbs connected to the hub. These lights and switches respond almost instantly (within the second) from the app. The Schlage lock, however, takes 2-4 seconds.

1 Like

Thank you!! I will try tonight when I get home

Read my post above. If you do as it says you will not have problem. Other way may work.

I got it to work without having to reset the lock. I am going to save this post in case it happens again and i will do that reset. Thank you all for the help!

I came across this post when my Schlage lock stopped updating and responding to SmartThings (after several months of working fine). I was about to try the reset procedure, when I found the “Replace” button on the device in SmartThings. I looked up the function of that button and found this: What does Z-Wave Replace do?

So I tried it, and it worked beautifully. I didn’t need to reset the lock or anything. So if somebody else has this issue, maybe try that first.


So my SmartThings app also stopped being able to control my 2 Schlage locks recently. It still shows the status of the locks fine, and sends me alerts when they are locked or unlocked, but when I try to lock or unlock them from within the SmartThings app, nothing happens. This was working for the last few months that I had the hub. What a headache. I don’t want to remove my locks from my doors to re-pair, and there are no network ports near the locks (one of them is in the garage leading to the yard). Any easy way to get this working again? Why aren’t these hubs more reliable? I did remove the backup batteries from the hub a month ago, after finding corrosion in the battery compartment. Is there a hub that is more reliable than SmartThings?

I had the same issues and could not fix the problem after working on it for a few hours. I contacted Schlage customer support and the rep patiently walked me through the process.

  1. The Schlage lock will need to be uninstalled from the door or be placed in very close proximity to the hub.
  2. Reset lock to original factory setting.
  3. Go to the app and go to “General Device Exclusion” and initiate.
  4. Try pairing the Schage lock once again.

I had to repeat pairing the Schlage lock 4 to 5 times before it worked.

1 Like

Walter I just wanted to give you a +1 on this solution for the Wink users out there. I spent countless hours and was about to throw out my Wink and purchase another device. I think the key really was making sure you do an ‘exclude’ command on your hub while it is very close to your lock. During the exclude command make sure you attempt to pair once. My lock finally gave me a green check instead of the red x. That would break the Schlage lock out of the crazy cycle of unable to pair with your hub. After paring you might run into issues with the lock not taking your commands. In that case I ran the remove / replace failed node option on the lock itself. I hope this helps other Schlage users having pair issues with their Zwave hub. Thanks so much!

1 Like

Glad to help. It took me hours to get it to work. I just passed it along.

1 Like

My Schlage lock has been working for over a year. All of a sudden it stopped responding to commands but we show me the state of the lock. I tried removing and adding it several times. I use Rboy’s app and device hander. I followed everyone’s suggestions to include having my hub within a foot of the lock. Eventually I figured out that I had to:

  1. Exclude the Lock from Smartthings
  2. Do a factory reset on the lock
  3. Remove Rboy’s device handler
  4. Have the lock about a foot away from the hub
  5. Add the lock.

Then I was able to get two way commo going again. However, I wanted to use Rboy’s app and device handler.

  1. Remove the lock from smartthings again
  2. Now add back Rboy’s device handler
  3. Add the lock again as above.

Now everything works again.

1 Like