Connecting Schlage Camelot Lock to Smartthings Hub


(Richard Ruby) #1

I’ve been trying to get my Schlage Camelot Touchscreen Deadbolt to re-connect with the SmartThings Hub. When I installed it, I got it to connect just fine, and was able to lock/unlock it from the SmartThings phone app. This lock is installed at our vacation home, and when I returned there, I am unable to unlock it from the app.

Using the advice on this blog, I disconnected the lock and I am attempting to reconnect it. When I go to SmartSetup/Locks/Schlage Camelot/Connect Now the app says “I’m looking for a Lock”. It just keeps looking for the lock, never finding it.

The lock works perfectly manually. It will not connect to the hub. I have reset my phone, reset the hub and followed all that I can find on the blog, but it will still not connect.

Please, I need help!

Thanks,
Richard


(Greg) #2

I would suggest to be sure you excluded the lock properly and are properly putting it back into inclusion mode when searching.

perhaps you just had a range issue when you returned and couldn’t unlock it?


(Richard Ruby) #3

How do I verify that I excluded it correctly? It no longer shows up in my list of “Things”. As for range, the hub is 6 feet from the lock.

Thanks for any suggestions!


(Paul) #4

If you encounter any trouble connecting your lock, it may need to be excluded before being added again. This is likely the case if it has been in use previously by our hub or another Z-wave controller.

In the SmartThings app, go to the left menu by tapping the icon in the upper left hand corner
Tap the gear icon to the right of your location
Scroll down and tap your hub
Tap "Z-wave Utilities"
Tap "General Device Exclusion"
Tap "Remove"
When you see the panel that says “Please follow manufacturer’s instructions to remove the Z-wave device from My SmartThings,” follow your locks removal process: Press the Schlage button on the lock, enter your 6 digit programming code, press the Schlage button again and then 0.
Once the app confirms the lock has been excluded, you can attempt to reconnect the lock via the directions outlined above.


(Paul) #5

Here are the directions above…

Add a Schlage Camelot Touchscreen lock to your SmartThings Hub:

Tap the (+) icon at the bottom of your SmartThings Dashboard
Select "Connect New Device"
Within 10 feet of the hub, press the Schlage button on the lock, enter your 6 digit programming code, then press the 0.
Set up the alerts or automations you want to use with your lock


(Ricardo Souza) #6

I am having problems with my Schlage lock as well! I Excluded it from my Vera 2 and included it into my ST Hub before I knew I could connect ST as a secondary controller. I’m now trying to exclude the lock from ST to re-include it in Vera, so that I can use the passcode functions supported by Vera. It has disappeared from ST but it won’t include in Vera - not even in Full-Power Inclusion, as if it hadn’t been properly excluded. Tried everything, including the General Device Exclusion described above. Even tried reseting the lock to factory defaults. Any suggestions??


(Hugo Donis) #7

Yesterday I bought a Schlage BE369NX CAM 619 and was able to get it connected to my SmartThings hub but am having problems getting the lock to communicate back to the hub.

The hub is now about 30 feet away, but there are plenty of other z-wave devices in between that can easily help transmit the signal (if its a range issue). I have already tried running network repair twice but still no luck.


(Andy Rawson) #8

I had a problem adding mine where it connected but didn’t finish the secure part of the Z-Wave connection so was sort of there but didn’t really work. I had to remove and then add it again twice before it showed a successful connection and started working. Not sure if you have the same problem or not.


(Hugo Donis) #9

Andy,

How did you know that the second part completed successfully? Was it something you could see in the SmartThings IDE or a pattern of blinking lights on the lock?

Thanks for the help


(Andy Rawson) #10

It has been a little while now but I am fairly certain I was watching the IDE Live Logging while pairing it.


(Rob) #11

I’m in a weird spot. I have one Camelot touch screen deadbolt installed and working for some time. I just bought more, and can’t get the second connected. The app, both on Windows Phone and Android, just spins forever. I have the hub within 3 feet and have held it inches from the device.
One time I got the app to show “Z-Wave Lock” and connected it, but then the device never successfully received commands from the app.
Over and over I can get the lock to think it is connected (green checkmark), and I can exclude the device which requires the hub to sense the lock! But I can’t get a real connection. Any thoughts?


#12

same issue here.

Lock worked great for a day or two, now cannot do anything with it (even though everything shows fine in smartthings).

Anyone managed to solve the issue?