Schlage Camelot Connect pairing

schlage

#1

Just plugged in my smartthings hub. I have a number of Schlage Connect locks installed in my home so I unscrewed one of them from my door and brought it close to my hub and entered the programming code and it was found by my Smartthings app. I now have a page in the ST app that shows the lock and options to lock and unlock it. However, these options are not doing anything. I click them and it says Locking/Unlocking in the app but the lock does not do anything or make any sounds. I deleted the lock and performed the pairing again. Then I restarted the app and reinstalled the lock in the door but the lock still is not responding to the commands of the app. Am I doing something wrong? Or is there a known issue with a fix for this?
Also if I have other locks already installed in doors, I assume that there is no easier way to pair them with the hub, aside from unscrewing them from the doors and bringing both sides of the lock assembly next to the hub?
And finally, once I get the lock and unlock features working through Smartthings, where can I find options to add and edit user codes for the lock?


#2

Where these previously attached to a Nexia controller? If so, a number of community members have reported that you have to go through a special process for those:


#3

As far as adding lock codes once you have it paired, see the following:


#4

Thanks for the quick reply. No, these locks were never connected to any other internet connectivity. I had installed them in my doors and programed them with codes manually on the keypad and used them without any internet connectivity.


#5

OK, then it could be a range issue. How far is the lock from the hub? And what is the closest Z wave device to the lock other than the hub ?


#6

Also, see the following, although it sounds like you may have already gotten past this step:


(Bobby) #7

I think is not you. I am having issues with a zwave sensor. I just excluded it and include it and none of the sensors within the device are actually working, and the motion stays as active.


#8

I have no other items. As I said in my post, I connected the smartthings hub and then without having any other zwave or smartthings devices, I unscrewed my lock assembly from the door and brought it right up to the hub, within a foot or so. The hub/app did not have any trouble finding the lock.


#9

Right, but when the lock is on the door, how far is it from the hub?

And just to be sure, you have the v2 hub, correct?


#10

I have a v2 hub. When this lock is on the door it is maybe 30ft from the hub. However, I was initially attempting to make the app lock/unlock the lock while the lock was not on the door, while it was next to the hub, right after I paired them, and it was not working there either.


#11

I fixed it. I went around and paired my other 2 Schlage locks with the smartthings app successfully and I was able to lock/unlock the doors using the app. I then tried several things including doing a factory reset of the problematic lock and performing a network reset. I think that is what worked as I then paired it with smartthings again and the problematic lock now works fine using the smartthings app.