[Osram motion sensor] Deleted, after searching it reappears as if it had never been deleted

the strangest thing that ever happened to me ever happened on Smartthings!
I’m trying to switch all my devices to EDGE, before the official switch, to avoid surprises or malfunctions all together, I prefer to deal with them a little at a time.

I have 6 Osram motion sensors and one by one I wanted to switch to Edge, I deleted the first one and then did the search to find it with Samsung’s EDGE motion sensor drive which should work. With 2 of these sensors it was very difficult to reconnect, I tried and tried more than 50 times before I could detect the sensor.
Yesterday I tried with the 3rd and the situation got worse:

  1. deleted the device from the App
  2. checked in the IDE that this sensor was no longer there (I did it because with the other two I realized that after deleting from the APP, the sensor remained in the IDE)
  3. tried the connection in EDGE a thousand times, until the sensor reappeared, but with the same name that I had given and from the IDE I saw the data of the first connection from months ago, exactly when I connected it, and also the associations a Action Tiles were still active.
    Alexa also notified me of the new device with the old name. To confirm that Alexa had also been deleted, while the google home notified the cancellation, but not the reappearance.

This is to say, or rather to ask, could it be that somewhere a device remains in memory even if deleted?
Maybe this is the problem why I can’t connect them?
I don’t think it’s a Hub problem, because yesterday I tried it with a different device and it connected to EDGE in a few seconds.

Really a very strange situation that I do not explain

1 Like

I have not faced the exact same issue, but it’s suddenly become harder to remove a device. Inmy case they were mostly multi-channel switches. The following has happened:

  1. At times, I delete the switch in the normal fashion (exclusion from the app), and the device is not deleted (i.e. continues showing in the app), or if it is a 4-channel switch, some are deleted and some not (e.g. 2 devices of four remain on the app). sometimes I manage to remove them through force deletion from the app, sometimes not and I have to go to the IDE to remove them.

  2. t times, I delete the switch in the normal fashion (exclusion from the app), and the device completely disappears from the app, but then I find the device in the IDE - always multi-channel switches. I try to delete the parent device but it fails - then I have to delete all the child devices individually before I delete the parent device. It’s slow work when you have a lot, but appears to work.

  3. Sometimes, when trying to exclude, I see 2 devices deleted instead of one - but I would not even be close to any other device, let alone pressing any buttons on such device for exclusion purposes. Then I have to go through all of the rooms in order to determine what device has been removed - or simply find out by chance.

However, in my case, I managed to re-include the said devices without any problem, with new Edge drivers and no history, and an alternative name. So it is not exactly the same as your problem. Still, quite frustrating, and it seems clear some behaviour has changed over the past few days since - though I did have some problems during exclusions in the past, it was not to this extent.


Hi @Diegocampy

For zigbee devices check the unsecure rejoint is set to active. change it to inactive

Check if devices use a custom DTH

Thanks @Mariano_Colmenarejo for your interest and advice.
My hub have Modo Seguro, I set to NO, I changed it to Yes and put it back to No. but I don’t think it is necessary, it was already correctly on NO.
I think the device handler is standard, to confirm this, in the IDE I have no device handler for Osram in the “MY Device Handler” page so I think I am certain of this. The IDE screen is perhaps useful for confirming (1 of the 3 osrams not yet changed and therefore still with Device Handler) .

1 Like

That has happened to me, as well, where I remove a device and re add and it appears as the old name. I figured out it was the devices that were using action Titles smart app. If i removed the devices from the smart app and then did the removal readd then it no longer re added under the old name


Tagging @625alex

1 Like

Interesting! All my devices are visible in action tiles.

My problem with osram remains.I do not understand what could affect the mating. I keep trying, but the third I just can’t connect, so I don’t trust to delete the other 3 that remain then.

Feel free to uninstall ActionTiles while troubleshooting this issue. When the SmartApp is reinstalled, all tiles will be reconnected.

ActionTiles has no control over device inclusion and management. If a device is retained after deletion, this is obviously a platform issue.

1 Like

I’m experiencing the same issue but do not have ActionTiles. I do suspect along the same line as I am using Home Assistant in my Smartapps…anyone else?

I am increasingly convinced that the problem lies with smartthings in his control panel. Even an aeotec 360 camera connected in wifi deleted because disconnected, then reinserted, is connected twice. I think they are problems with IDE.

Another confirmation, I don’t put the screenshot, but also an ikea repeater with edge remained in the IDE after deleting it from the app. In my house the situation is disastrous, the worst situation ever in years, I have had more than half a disconnected house for a week. I don’t know if this has to do with this transition phase or if I need a blessing … it all started when I deleted the first osram motion sensor to pass it to EDGE.

This is the third time something like this has happened to me, the first time I also changed the hub, but I don’t think it was the one Too many strange abnormal disconnections the hub was definitely not the problem.
All this is to say that I would not want these deletions that are not successful in the ide to affect the capacity for reconnection. I do not know