Too many strange abnormal disconnections

For about a week I had the first disconnections of 2 zigbee devices (vimar smart switch), reconnected with difficulty then I saw other vimar devices disconnected. After that I started seeing connected devices but even if connected, not working from App or routine, it works ano only with physical keys. Dopi problems disappeared or almost always without doing any thing. A few times I tried to reconnect But without succeeding.

From yesterday Other devices also have the same problem. I asked about an Italian group and many have this problem. Do you have any idea what’s going on?

@Mariano_Colmenarejo Sorry if I tag you, I read this post of yours (NEW RELEASE) Version 5 of the Edge Beta Driver: Zigbee Switch Mc - #52 by Mariano_Colmenarejo And I wanted to ask you if you think it might be a problem to use standard edge and DH drives, for devices of the same type.
I ask you for erche currently I have 13 vimar smart switches, only 1 uses your edge, while the others use the DH standard. If you read my top message, I have a lot of disconnection problems, I noticed that after 2 days the Edge-based device reconnected by itself and works, the DH-based ones do not. Now my doubt is whether to wait or what to try to do.

Hello @Diegocampy,

I think it has nothing to do with having some devices with DH and others with edge so that they disconnect.

What we do have to take into account and we don’t usually have is the following:

When we move a device that works with DH to an Edge driver, we have to uninstall the device and at that moment we can remove from the zigbee network a device that is serving as a repeater for other zigbee devices on your network.

From then on you may experience connection problems from other zigbee devices, either with DH or Edge.

This will tend to fix itself when the zigbee network rebuilds, but it may take a while.
Less time on zigbee than zwave, in my opinion. Zigbee is more dynamic I think.

You can force a rebuild of the zigbee network by turning off the hub for 5-10 minutes.

The zwave network has the zwave repair tool in the hub menu.

To analyze this, I would recommend looking in the IDE to see how the device is being used on the network before uninstalling it. This way we can predict which devices might have problems when uninstalling it.

We are in full conversion and almost daily we make changes from DH to driver, hub reboots… and we create indirect problems for the network.

1 Like

Unfortunately I also tried to turn off all night, turned on again this morning, but still 6 devices (all zigbee and all powered) I know or still offline.
I think there is some new problem, they are all stable devices that had never had problems before. In addition to the disconnections I notice that sometimes the automations do not work because the devices that should turn on do not do it, and I see it from the ide.
I don’t know if it’s worth deleting these devices and reinserting them. Doing so would necessarily be inserted with edge and this worries me at this stage

Since they are devices with DTH, you can check their metrics in IDE, if they don’t connect directly to the hub and do it through repeaters, pay more attention to failed messages, than to RSSI and LQI.

See if the ones that are disconnected have a repeater in common

1 Like

All the device disconnected have “unknow router” But even some that work well, this is what works as a button, but does not update from App :roll_eyes:

This has all, 72 message failures

I do not have any zigbee device with dth that connects through of a zigbee Edge device, but I think, remember that the DNI network address of the edge driver does come out correctly in IDE route, they do not come out ???.
Did you try to turn off the hub for 5 or 10 minutes to see if unknown device disappears?

Turned off all night, the problems remained when the problems were turned on again. :pensive:

@Mariano_Colmenarejo I don’t understand :thinking: sorry, my english is not very good :hugs:

Speaking of my devices that disconnect continuously, or that work badly, they are all vimar smart buttons, without edge they appear as a “thing” and then I have to manually change the DH. For this reason I am afraid that if I delete it, it will come back but it will use edge.


I was referring to turning off the hub for 5 or 10 minutes to see if the ghost device disappears, which seems to be the cause of the disconnection

The situation is tragic!
I erased all zigbee devices that used your edge drive @Mariano_Colmenarejo (To understand if something in the drives could create problems for me) nothing solved. I still have edge drive of @TAustin (shelly and virtual) and @ygerlovin (aqara sensor). Some of you among the users of your edge drives, have they had similar problems to mine?
I don’t really know where to bang my head and what to try to do.
My problems mainly concern vimar switches, some continue to disconnect, others even if connected, do not work from App or with routines, but only with physical button on the wall, and the strange thing is that when I command from a physical key, the app updates.
Excuse me if I tag you, but I really do not know what to do anymore, Every suggestion is welcome :nauseated_face:
I have over 80 automations, every time I delete a Device, I have to recreate all the automations that concern it, and I am destroying everything day after day.

Check this out. I’m not sure if it’s the same issue, but it might be.

If you haven’t done so already, I think I would be looking at power cycling Zigbee routers in case one of them has got a bit confused. However that is easy for me to say because all my repeaters are plugs/outlets that I can easily turn off or unplug. It isn’t so trivial for wall switches and lamps. I used to do it quite a lot because I have a lot of Tradfri outlets and they often got themselves into a mess, though less so since I updated their firmware.

Thank you for your interest, but I have no idea what this thing is :man_shrugging:t2:.

What should I check? I have about 15 zigbee devices that act as routers because they are powered (all vimar) and I can’t disconnect them easily.
Now I think that sometimes these days I also have problems controlling from APP ST hue devices (they work perfectly from App hue, But not from APP ST). Is it possible that the problems are due to the internet connection of my SmartThin Hub?
I have a 4g+ connection with router for a month, but I always see > 40mbit in My speedtest

@Diegocampy I’m not aware of any persistent disconnection issues with Aqara sensors, managed by my driver. I suppose if there were any, I would see some reports in the driver’s thread.

If when using a physical switch the application always updates, it suggests that the networks is fine.
I would suggest to try to collect some data about all devices, what DTH/driver they are using, their route (if available), signals and any events (detected disconnections, physical switch presses and whether the status was updated) and their times.

Also, using Zigbee analyser can be considered.

Completely random, sometimes nession disc even after only a few minutes without any operation.

Can you explain what it is? I don’t know.

I’m not sure how I can make any suggestions, based on this.
Lets start with a list of all your devices and how they are managed. Including WiFi, if any, connected to any cloud and see if there is some kind of pattern for disconnections

Hello, I just saw your post

Yesterday the problem was quite focused on the fact that all the devices that were disconnected arrives to hub through an unknown device ???, and that they were devices with DTH. All messages failed

Before getting involved in uninstalling devices and removing Edge drivers, I would try to focus on the problem.

  • The unknown device ??? has disappeared from your network?
  • When you reinstall any of the devices you removed, do they connect properly?
  • Have you noticed any change in the Wi-Fi channel of your router? if you have it in Automatic channel it is possible that ruter have changed the wifi to a channel that interferes with the zigbee channel of your Hub

I don’t know if it has anything to do with this.
Yesterday the problem seemed very focused on devices with DTH and a ghost device that was as a repeater in all the devices that were disconnected.
I don’t know if that has changed.
It could also have to see the Hub firmware update at the origin or start of the problem.

1 Like

Thanks to all of you who try to help me

Posted some reports of the device with problems. They are all Vimar Buttons and now I only have DH, no edge drive is piloting zigbee switch devices, only edge drives for virtual devices, for shelly and for aqara sensor.

All devices hue work fine, and the only zigbee lamp I own is osram and works well without disconnections but the DH Type used is ZLL Dimmer Bulb.
Route: This Device (68D8)↔ Soffitto Corridoio (1268)↔ Hub SmartThings

The problems are all here, now I was thinking of eliminating all the devices with Unknown Route And reconnect. Can it help? Recommendations?

Here are the problems:

  • Cancelletto Pedonale
    Cancel same days ago
    I tried to reconnect this morning, apparently without success. After half an hour a “thing” device appeared, modified to IDE with correct DH “zigbee switch”
    but not change from ST app or voice
    After disconnected… And No road marked in the ide

  • Soffitto Cucina
    DH no cancel
    Some time disconnections
    Yesterday evening connect but not change from ST app or voice
    Today work fine
    Route This Device (76E0) ↔ Hub SmartThings

  • Piano Cucina
    Connect but Some time disconnections
    Yesterday connect but not change from ST app or voice
    Cancel and reconnected now work but:
    Route:This Device (65CA) ↔ Unknown Route (???) ↔ Hub SmartThings (if i have cancel and connect, i don’t understand why this “unknow router”

  • Soffitto Ingresso
    Now connect but not change from ST app or voice
    (yesterday evening, now yes)
    Route This Device (5091) ↔ Hub SmartThings

  • Soffitto Salotto
    Yesterday evening connect but not change from ST app or voice
    cancel and riconnect now work fine
    Route This Device (B90A) ↔ Hub SmartThings

  • Faretti corridoio
    Yesterday evening all ok, now connect but not change from ST app or voice
    Route This Device (37CD) ↔ Hub SmartThings

  • Soffitto Corridoio
    Yesterday and now all ok
    Route This Device (1268) ↔ Unknown Route (???) ↔ Hub SmartThings

  • Soffitto studio
    Route This Device (87BB) ↔ Unknown Route (???) ↔ Hub SmartThings

  • Soffitto Bagno
    Yesterday connect but not change from ST app or voice
    Now work fine
    Route This Device (8016) ↔ Hub SmartThings

  • Specchio Bagno
    From yesterday and now connect but not change from ST app or voice
    Route This Device (DC4B) ↔ Unknown Route (???) ↔ Hub SmartThings

  • Soffitto Camera
    Yesterday disconnected
    Now work fine
    Route This Device (05E1) ↔ Hub SmartThings

  • Lampada fuori garage
    Yesterday and now connect but not change from ST app or voice
    Route This Device (5ECF) ↔ Unknown Route (???) ↔ Hub SmartThings

  • Soffitto garage
    Disconnect and riconnect yesterday.
    Now work fine
    Route This Device (C3AB) ↔ Unknown Route (???) ↔ Hub SmartThings

  • Lati gazebo
    Yesterday Disconnect
    Now work fine
    Route This Device (34FD) ↔ Hub SmartThings

Thanks again to everyone for your help

Edit after 1 hours:

4 new disconnections

Edit 6th February (24h later):

Still disconnections and problems. I decided to gradually delete all the disconnected or problematic devices, all together. They were all vimar, I restarted the SmartThings hub and now slowly wait to see what happens.
For now I wait and I do not do any search for new devices.
I see, however, that new “thing” devices are appearing from the ide. They are the vimar before setting it with DH “standard zigbee switch”. I didn’t know they could appear on their own