Some devices suddenly gone offline yesterday. And our presence sense virtual switches disappeared

Yesterday, while I was at work, I started getting notices that some devices had been removed. When I got home I found several devices display as offline. I rebooted those devices last night. But still offline. Also we had two virtual switches that activated when our Android phones connected. Those virtual switches have gone. This has probably been discussed, my apologies. I have not been able to find solutions through searching. I do not know how to investigate the cause or fix it. Has something changed in Smartthings? So many issues started happening with Smartthings. I feel like abandoning it and starting again. But would rather learn and keep it going.

I had the same thing happen, a motion sensor, an in wall zooz switch, and a ge in wall switch. all Z wave. the switches were moved to edge, the motion sensor i think was my last thing on a groovy driver.

So I need to move them to Edge? Can you give me a link to instructions how to do that please?

Probably just need to repair and should switch to edge driver. It worked with my motion sensor, but I haven’t tried with my switches yet.

most likely, they have already been migrated to Edge drivers and you simply need to switch to a community developed Edge driver. In most cases, you would not need to remove and add back.

FAQ: What is Edge

Legacy Virtual devices stopped working

for virtual devices… I would recommend use this Edge driver to create new virtual devices:

for the other devices that are offline… if you can provide brand/model for them, we can provide better advice for getting them to work for you.

At the moment there seems to be a couple of categories of things that are happening.

The stuff that we can explain.

We are at the fag end of the migration of devices away from the legacy platform. The typical sort of thing that is happening now is that devices that required us, the end users, to install a custom written or tweaked device handler to make them work properly, are now being migrated to a new Edge driver. Only there isn’t always an Edge driver to migrate to for the same reason that the custom device handler was installed so they end up migrated to something that looks like it may do something similar. Virtual devices are a particular problem in this regard as, with the exception of those that used stock handlers, ST can’t really identify what on earth these handlers are. So they end up migrated to a ‘LAN Thing’, which basically does nothing apart from acknowledge something is there that probably did something once.

The stuff that we can’t explain.

So devices suddenly becoming useless can usually be explained. What isn’t so easy to explain is the report of devices just disappearing. Not just being removed from Routines - that can usually be explained - but completely disappearing. That’s more of a head scratcher.

Yeah I had 3 devices completely disappear (two of which I had already moved to custom edge drivers), just repaired one of the switches, had to exclude first.

Ok that makes sense. Question is how? First of all, how do I identify that the offline devices need an updated Edge driver. Then how do I install the correct driver for each device to get it back on line? When I get home I will look at the exact models that are offline. I know they are: 2 indoor power socket devices, 2 outdoor power socket devices and my Ecobee thermostat.

Also, I had two virtual switches I created. One for me and one for my wife. They were used to store when each of us were at home or away. Were toggled on or off by our android phones presence. Problem is many of our automations were being driven by the state of those switches. They disappeared totally. So nothing works now. I have installed Virtual Device Generator jkp mention above (thanks buddy). And I created two new virtual switches. But now I have to get those recognized by Smartthings, activated by our phone presence and set in the automations.

What a nightmare. Maybe time to switch to another system.

I have managed to get everything back on line except for my Hubspace outlets. Do they need a new Edge driver? Any ideas how to get them connected guys?

Hubspace devices have no direct integration with ST.

You could use a standard virtual switch to link them through Google Home.

Or a virtual Alexa Switch to link them using Alexa. I find Alexa to be a little quicker.

Ahh ok thank you

Hey there… quick Q… Did you have any issues getting your ecobee thermostat populated back into ST? Just curious as I had the same disappearing act on a few hubs… but the standard c2c connection via linking the accounts will state successful, however no devices will populate into ST’s…? Thanks for any insight :call_me_hand:t3: