Open/Close Sensors and Battery

I just put all new batteries in my open/close sensors and they are already down to 60% after a few weeks. My guess in looking at the sensor history, is that the reporting of temp constantly is killing my batteries. May be wrong, but that is my best guess.

Anyone else have this problem? Is there any way to fix this or make it better?

Thank you.

I am using the Visonic Open/Close sensors… I forgot to mention that in case it is useful.

Thank you.

If you use the sensors with “Smartsense multi sensor” DTH could solve the battery problem with this modified DTH that have settings for temperature report.
This problem was notified to smartthings support and was tagging in november, but…???
Link to dth descripción and installtion:
Since 3.5 month, 9% of consumption in the higher used sensor and 5% in less use sensor.

2 Likes

My sensors are currently using the Smartsense Open/Close.

Are you saying I need to change this to Smartsense Multisensor?

If you want to change the frecuency of temperature report in order to decrease battery consumption you must install the dth with temperature report settings.
This is the dth linked on previous post.
There is not official dth with temperature report settings

I can see, the Smartsense open close sensor use 1800sec.(30 min) Interval for temperature report. Is correct?
you can also modify the original dth line 215:
zigbee.temperatureConfig(30, 60 * 30) +

by:
zigbee.temperatureConfig(30, 3600) +

This change the Interval to 1 hour

Sorry but I am not sure how to make the change you are saying.

Sorry,
I thought you knew the use of the smartthings IDE page.
Do you want to try?
I could help you

Yes, I know the IDE page, just not sure how to make the adjustment you mention. I don’t see a place to edit the device handler.

Follow these steps, better on the computer than on the mobile:

  • The device must have a good signal from the Hub or placed nearby, such as when you first pair it.
  • In IDE menu click in “My Device Handlers”
  • Click in “+ Create New Device Handler”
  • Click In “From Example”
  • Look for the example “SmartSense Open / Close Sensor” and select it.
  • Click in “Create”
  • You already have it created for you and you can modify it.
  • In DTH code, line 215 is the setting of the temperature report interval for the sensors that are not Ecolink, Bosch or FrientSensor. Yours is Visonic, you told me.
  • In that line change: zigbee.temperatureConfig (30, 60 * 30) by zigbee.temperatureConfig (30, 3600).
  • This sets the temperature report interval to 3600 sec. (1 hour)
  • For this to have effects:
  • click on Save
  • Click on “Publish” and “Publish for me”
  • Clich in IDE menu “My Devices”
  • Find the device to which you are going to change the Device handler (DTH)
  • Click to Open
  • Click in “Edit”
  • In the “Type *” field, check that you have the DTH “SmartSense Open/Close Sensor”
  • Open the drop-down list and go to the end, find the DTH with the same name, which you modified and published for you.
  • Select it and press “update”
  • The DTH change has already been made. As a reference, you will see that the “checkInterval” shows 16270 s, wait a few seconds and refresh the page, if the checkInterval returns to show 720 s everything has gone well.

In the smartthings app, check on the device history, that you have a temperature report for the time of the DTH update and then the temperature changes will be sent every hour or changes of> = 1º when they occur.

For others devices, repeat only the steps for install the type of DTH

don’t worry, nothing breaks here
Any doubt tell me

Sorry for the delay in getting back to you… I have don’t this and here are my findings…

  1. It changes to 7260 and not 16270

  2. After about 1 minute, this changes itself back to 720.

Suggestions?

Also, is there any way to eliminate the temperature check all together, as I could personally care less about it.

Thank you.

Okay too good. When it changes to 720s, it has responded correctly to the temperature setting.
Have the temperature reporting intervals changed to 1 hour?

I think the temperature function cannot be overridden. It is the device itself that sends this information according to the default configuration or the one sent in the installation

It appears to be hourly now… I think.

How would I do the same for a ST Branded Open/Close sensor?

Thank you for your help!

Wath dth use the open close sensor?

if you want bigger Interval report time, change the 3600 s by other Interval bigger in seconds

SmartSense Multi Sensor is what it is using by default.

It has temp and vibration too, which I could care less about either of those. These are in our condo, which I need the battery to last as long as possible so I can monitor it through the rental season.

Thanks.

Use this link for Smartsense multi sensor and follow the instructions.
in settings you can use 90 minutes for Interval report and 150= (1.5°) for report trigger of any temperature change >= 1.5°. Or as you want.
I have 3 of these model with settings: 60 minutes Interval and two of them with 1° trigger and other with 2° trigger. After 4 months of use a mean 10% of battery dropped.