Multisensors Samsung Battery drop quickly after hub v3 firmware update

Since the last firmware update of the hub v3 to version 32-12, Samsung door and window multisensors update temperature changes with an accuracy of 0.1 °. Since then the batteries have started to discharge very quickly because they send the information to the hub very frequently.
In less than a month the battery levels have dropped from 70% to 25% in the most used door and 50% in the others.
Has anyone noticed something similar?

If someone has these problems of low battery life in the door / window zigbee multisensors, Samsung GP-U999SJVLAEA, and movement GP-U999SJVLBEA, due to the sending of temperature information with variations of 0.1 ° C or every 5 minutes.
I detect it in early October, after the hub firmware update 32-12 v3.
As I do not use the temperature information to control anything and I only use them to detect opening and movement I have modified the DH “SmartSense Multi Sensor” and, “SmartSense Motion Sensor” to add in preferences a time setting for sending temperature, eligible between 300 and 3600 Sec.
I have set it to 3600 sec and now they send temperature information every hour or with variations of +/- 1 ° C.
I upload a few snapshots of the log and fit.
I have changed 2 empty batteries and I will monitor the consumption to inform smartthings support when they reply to the email I send them.

Added new DTHs links in post number 29 with two settings: Report Interval (1 to 240 min) and temperature change for report trigger (0.5° to 3°).



1 Like

Tagging @SamsungZell

Love to have this feature, I don’t need to know the temp change every minute, (or not at all)

If only Samsung could of preemptively seen the damage to the batteries their change does, beforehand, makes you wonder if they beta test anything at all. Maybe one day in the future they will fix their unnecessary change, so the user can decide how often they want temp readings, or if they need temp readings at all on yet another device, and we can use these sensors locally again.

My Samsung sensors update temperature every 5 minutes only if there is a change of at least 0.1 degrees.

This is correct Paul, but the sensors are placed on doors or windows, in practice they send me information on changes of 0.1°C every 5 minutes. Before, it did it with changes of 1°C and the batteries in 9 months consumed between 20% and 30%, depending on the use of the door. With the precision of 0.1° they have consumed the rest of the battery, 70% approx, in a month and a half.
Motion sensors have higher capacity batteries and hold up much better.

I do not think it is a sensor problem since it happened to me in all the ones that I have mounted.
With the modification of the temperature delivery every hour or variation of 1°C, 15 days ago, I changed 3 batteries in open/close sensors and I have two at 95% and another at 100%. I see if it continues like this!
Motion sensors batteries mounted around for 10 months and are at 70-75%.

After 1 month using the sending temperature report every hour, the batteries continue, two sensors at 95% and another at 99%.
It seems to be going well.

Is there a way to change the sampling rate of the original ST sensor? It appears that, from the app, I can only view the minute/hour/day sampling. It indicates that it’s checking every minute, which would explain why it’s been chewing through batteries like me and a bag of Oreo’s.

Ben, I modified the device handlers on the smartthings IDE page, https://graph.api.smartthings.com/.

I will put the links of the modified DTHs in case you want to use or see them. Let’s see if I can do it.

When installed you have to go to device settings and set the temperature report interval in minutes (5 to 120) . If you use the temperature to control heating or AC, you should put it between 5 and 15 minutes maximum. I have it in 1 hour, I don’t use the temperature to control anything.

Open/ close multisensor:
https://github.com/Mariano-Github/Smartthings-DTH/blob/main/SmartSense%20Multi%20Sensor-MCC.groovy

Motion sensor:
https://github.com/Mariano-Github/Smartthings-DTH/blob/main/SmartSense%20Motion%20Sensor-MCC.groovy

Links modified

1 Like

404 page not found

Can it be because the repository is private?

most likely

Links to public repository

Thank you very much, but I still don’t have the ability to set the time interval. I also tried going to the IDE>checkinterval>more…but when I click “more”, nothing happens.

Sorry if I’m being a bit thick. I haven’t had to make any changes to my environment in quite some time, so I’m a bit rusty.

If your original Device Handler type is “Smartsense Multi Sensor”
You could do theses steps:

  1. Open the githug link posted.
  2. Select and copy all code to the clipboard.
  3. Open IDE page.
  4. Click on “device handlers” in the menu.
  5. Click on “create new device handler”.
  6. Click on “from code”.
  7. Paste the copied code into github Page.
  8. Click “Create”
  9. Click on “Publish” and then “Publish for me”
  10. In “My Devices” find and click on the device you want to modify.
  11. click on “Edit”
  12. In “Type” field, renember your original Type. Display list and look at the end of the list for the “Smartsense Multi Sensor-MCC” driver and select It.
  13. Click “update”
  14. Close the smartthings app and reopen it.
  15. tap on the modified device.
  16. tap settings on menu and enter the time minutes, 5 to 120.

It should already work.

If does not works, select your original Device Handler type on IDE page for restore your original Device.

If you never haven’t done it, it may cost you a bit.
I hadn’t done it before either and it worked.
much encouragement.

1 Like

Oh…my…lord! I am such a pillock! I completely forgot about step #11 :joy:

Thank you, thank you, thank you!!! Works like a charm! I feel bad that you had to write all of that info on account of me being a potato head!

I’m very glad it works for you! :+1:

You sir, saved me the cost of either replacing the sensor, or continue to feed it expensive batteries. I appreciate you very much!

1 Like

Nice work @Mariano_Colmenarejo, and they still appear to run local which is great. Raising the upper level still to 6 hours say would be awesome. Makes you wonder how a multinational like Samsung deliberately didn’t have any foresight. Hey @SamsungZell do Samsung sell batteries by any chance?

1 Like