Occasionally ST MOTION Sensors stop working


(Bob) #1

I have 2 ST motion sensors for turning on some lights. Occasionally they seem to stop working. If I look at the ST app no motion is detected when moving in front of them. (Usually I can see that they report motion ).
The only way to get them working is to remove them completely and then rediscover them. They then work OK. Any ideas anybody?


Zigbee motion sensor problems
(Wayne) #2

I occasionally have this in the UK v2 hub too. When reported to support they said they have not seen this before. My suspicions are that the hub is a little underpowered and is occasionally a little overwhelmed. Have you tried logging onto the website and look at live logging for any clues when this happens? I saw a whole bunch of IFTTT parsing errors on mine and decided to remove all authorised devices which i do not actively use to see if it improves matters. Problem is that my issue was intermittent so will have to wait and see.


(Bob) #3

Not tried looking at live logging when this issue is live. Will give it a whirl next time the issue rears it’s ugly head.


(Craig) #4

I find that if you remove the battery for 30 seconds or so and put them back in this corrects the issues as well. I have it happen about once every few months for one sensor for some reason.


(Bobby) #5

It happens to me every time I reboot the hub and it seems as it is related to the change in state. So if the sensor was active when the hub went down and is inactive when the hub comes back (or vice versa) I have to power cycle the sensor (take the battery out for 30 seconds or more).


(Wayne) #6

I’m not convinced the problem lies at the sensor level. Reinserting the battery may be just the spark that brings it to life but I think the problem is at the hub. This is because the same thing happens regardless of motion sensor type. I have both z-wave Fibaro and Samsung smartthings motion sensors and the same thing happens to both types occasionally. The advantage with the Fibaro is that you can see it still flash when it senses motion and even when you bring the device right next to the hub nothing happens and the state is still stuck. Removing the battery and re-inserting also fixes.
So, unless all motion sensors from both Samsung and Fibaro are unreliable, I would be inclined to think the problem is at the hub rather than with the sensor. What’s interesting too with the fibaro is that the lux and accelerometer continues to work even though the motion is stuck in an active state like the Samsung. So the communication is clearly working.
I’m wondering if anyone knows of a way of resetting the state on a sensor on the hub remotely?


(Bobby) #7

That is very interesting. I have a lot of z-wave sensors, Ecolink, Aeon Labs and Fibaro and I have not experienced what you described that’s happening with your Fibaro, with one exception. One of my Aeon motion sensors got stuck on motion but taking out the batteries didn’t help. I had to do a factory reset. On the other hand, there hasn’t been one time since October that after rebooting my hub all of my zigbee devices would resume activity. I’ve had at least five sensors that needed to be power cycled. I cringe everytime my hub reboots. It would be nice to have a ‘routine’ that would bring my ladder in front of the failed sensors triggered by the hub reboot. @bravenel, here is a feature request for Rule Machine, can you add that to your list?


(Wayne) #8

It’s odd we all seem to have similar but different experiences. Right now coincidentally I have one fibaro constantly locked on motion and everything else ok. I’m away at the moment so not able to do anything about it. I’m considering doing a hub reboot but not 100% happy risking it whilst I’m out as there’s no guarantee it’ll fix it. As before other sensors like the lux on the fibaro seem to be updating fine. I’ve never needed to do a factory reset though to bring anything back to life but I have done so on a few sensors to see if it would remove the problem permanently but this does not seem to have had the desired effect.


(Michael and Jessica) #9

I’ve been having the same types of issues with my Aeon and Everlink sensors as well.


#10

I also sent an email to support (which has thus far not been responded to) about this very issue. I have 2 of the newest generation ST multi-sensors along with 3 Aeon Z-Wave multisensors. The Z-Wave sensors have never had problems, the ST sensors go dark (stuck in whatever mode they are in and unresponsive) once every couple of weeks. One of them is roughly 10 feet and line of sight from the hub, so I would hope it wasn’t a signal issue. Other ZigBee devices connected to ST do not experience this problem, it’s just the ST sensors.

I would have hoped that first-party devices would have been more reliable but that seems not to be the case here.


#11

My ST gen 1 motion sensor, plugged in with an adapter, worked perfect. But then I needed to unplug it for awhile when putting up Christmas decorations. When I plugged it back in, it was stuck on motion.

It works in battery mode, but not when plugged in. Any ideas?


(Wayne) #12

Without me doing anything, being stuck in active motion for seven hours it has decided to correct itself. Logs show nothing of interest and casually states that the motion detector is now inactive as if all normal.
Maybe we’re expecting too much for expecting motion sensors to report correctly 100% of this time? I only have 13 motion sensors but experienced similar problems even when I had 4. I’m sure some people have a lot more sensors.
Anyone with a very large number and not experienced similar issues on v2?


(Bobby) #13

All of mine (30+) once they get stuck, they stay stuck for days…never experienced reawakening with any of my sensors…I wish they would, tho


#14

I have multiple types of motion sensors in my house and the only ones I’ve noticed this on are the ST sensors. None of my Z-Wave motion sensors have had this problem.


(Stuart Buchanan) #15

I’ve experienced this with my Fibaro Sensors, pressing the button 3 times to put into inclusion mode fixes it once the blue light goes out.


(Wayne) #16

This all points to the problem being on the hub not the devices.
Did you also notice that the other sensors on the fibaro including accelerometer and temperature continues to work?


(Stuart Buchanan) #17

yes the other sensors return, its just the motion that gets stuck. the inclusion mode it seems effectively forces the hub to reset the device once the device comes out of the inclusion mode as the sensor re-sends its current values to the controller. you see this in the logs. pretty much the same as pulling the battery

it is a bug with smartthings but i imaging a fix will be a long time off coming. you just need to reboot the hub when everyone is out fof the house :slight_smile: or asleep and not moving


(Wayne) #18

It is kind of frustrating that you cannot rely on basic functionality like motion sensing. The other day I wanted to show off to a friend my automatically changing hue lights in the living room. We ended up in a dark room waving out arms around. Embarrassing. :frowning:


#19

Hi Everyone,

Long time stalker of the forums, first time posting!

I’m not sure if this is related, or another issue, but I’ve had a lot of issues with the v2 Hub, most recently over the weekend with only certain motion sensors triggering my lights. What I’ve noticed this time (along with the previous time) is that when I have a SmartApp that uses the Home’s mode, that SmartApp will get stuck in a different mode (e.g. Home vs. Night). But when I remove the “mode is only in” setting from a SmartApp, the SmartApp will start working again.

From the logs I can see the motion from my sensor, but I never see the trigger action logged with the switch the SmartApp is supposed to turn on.


(Stuart Buchanan) #20

This IMHO is where you went wrong, i learnt that you should tell people the benefit of HA, Never try to demonstrate it! smarthings is doing its bit to keep murphy’s law alive! :smiley: