[OBSOLETE] Zemismart(Tuya) zigbee Blind Motor

Does this work with Tuya curtain motors? Zemismart Curtain Track Work with Tuya Zigbee Hub SmartThings hub Zigbee 3.0 Electric Smart Curtain

edit: I got it working with the same DTH

I tried it as well. The tuya app integration to Smartthings is basically useless… I have never been able to connect any device from the tuya app to Smartthings… neither with the Smart Life app… In the Tuya or Smart Life app, this motor also only shows open, Close and pause, without position feedback or percentage so I assume this is a characteristic of the motor, it’s 1 way communication. I then connected it back to the SmartThings hub and used the Nue Blind Switch DTH. I managed to configure the middle position to be enabled via a scene switch through Sharptools. I am now using all my automations in Sharptools as the SmartThings rules became very unreliable.

To anyone thinking about connecting tuya or Smartlife apps to Smartthings forget it… only half a dozen lamps work, most devices won’t work… just use ZigBee and DTH directly in SmartThings… forget WiFi unless you are sure SmartThings can connect to it (I have several tuya wifi devices and none can connect to SmartThings through their integration )

Komkavik - I had this problem when I integrated here’s what found. When you install the screen you have to set the “up” and “down” in the motor when you configure the motor. This has nothing to do with smartthings. But untill you do this there is no status for ST to understand because it doesn’t know the % up or down because there is no offical up or down. This literally took me 5 hours of troubleshooting to realize.

You mean the top and bottom positions? I did that. When I press “up” in the remote control or “Open” in the Smartthings app, it opens to the position I set, same for close, closes till the position I set… still doesn’t allow % and the status is always “opening” or “closing”, never “open” neither “closed”… I tried resetting the limits before setting the ZigBee repeater, tried to set the limits after setting the ZigBee repeater, tried to set the limits with the ZigBee repeater… nothing works… in both SmartThings and Tuya app I have less functionality as with the remote control (in the remote I can set an intermediate position, in SmartThings I could do it only using timers in Sharptools)…

Do you know a specific sequence I should follow? I appreciate any help. Thanks!

How did you set the up and down limits? Customer service told me I needed the Tuya app and hub. Is that the only way? The current version of the motors doesn’t allow limits to be set by a remote?

I’ve bought a few very recently and they do. I’d have to re-read the instructions but it’s something like hitting the button 4 times then hitting “up” or “down”.

Another thing I remember finding after digging through code for a long time. All the settings within the “settings” cog within the smartthings app must be configured. If they are not you get a null value and error within the device type (seen within the logs). Can you go to the settings within the device type and make sure all 5 are set. Also this lets you set one preset stop location (you asked about that as well).

Thanks for the feedback. Unfortunately I have no success with the zemismart device handler… I am using the Nue ZigBee Blind Switch DTH which is the one that has been working more reliably… I can open, close and pause… preset position or percentage doesn’t work. I think the model I have does not give feedback of its position. The model I have has this dongle and I think the RF is 1 direction…

I installed the motor and set the limits and preset position using the remote. Then I connected it to the dongle and the hub… here’s a screenshot of the device config in SmartThings… The dongle acts as a switch, which the manufacturer is Feibit.

When I have a bit more time I’ll try to edit the device handler to make it capable of doing % using timers… I think that’s the only way.

Again, I appreciate the feedbacks!

1 Like

Yeah - the biggest thing that I couldn’t get to work with the zemismart was the settings within the app. Once I set these it started working perfectly.

I have problems with the open command given from google assistent, it will only close - any sugestions?

While I an at it, what about battery level?
I have bougt the blind motor with solar cells and according to suppiler, there should also be some kind of lightsensor built in.

need the remote

looking for the device handler for this, installed 5 last night ,
i have the "roller " blinds working with this handler
would it be the same ,

I too am interested in getting this to work. I’ve tried both device handlers listed and they both work, but I am unable to get Smartthings to show the current status of the blinds. I would love to try your device handler when you release it. Please keep us updated. Thanks

Any luck with this device handler? Thanks for any updates!

So how is everyone getting the motor to talk to smarthings? I have the zigbee version and 0 instructions. And the onyl button on my unit is the motor button for programming the remote. the little zigbee board inside had not led or button so I am unsure how to enable zigbee discovery. (Found youtube for install only)

I’ve read through this whole thread and can’t get any of the DTHs to work. I get an error code in the Smartthings app - ‘A network or server error occurred. Try again later’.

Extremely frustrating and not sure what to try next…

My problem is now fixed - just had to remove the device and add it again now it works great with the Zemismart handler.

Do your blinds show the correct state? I. E. Open when they are opened, closed when they are closed? Mine always show partially opened regardless of what state they are in.

Did you set limits yet?

Yes, the limits work fine.