[OBSOLETE] Iris Motion Sensor (2nd gen, 3326-L)

I have had better luck doing what @blebson suggests in the previous comment

1 Like

They don’t say here what button, But if I remember correctly I think it worked with the diamond button in the bottom left. But It was a while ago when I had to factory reset mine.

I have two of these IRIS V2 Motion Sensors and they have been working fine. They reported temperature changes as they happen. I adjusted both of the tempertaure reporting, one +2 degrees and one + 3 degrees so they report accurate. Ever since I have done that they stop reporting temperature changes. If I do a refresh, they report the correct temperatur. I removed the temperature adjustments and they still do not report on temperature changes.
Has anyone seen this? How do I fix them?
All the other functions work correctly.

@damohabir, try removing the battery and putting it back in a few seconds later. Something odd has been going on with zigbee devices for several people recently, including myself. That took care of my issues. Also, a hub reboot may also be needed if that doesn’t work. If that doesn’t work, then resetting the device should do the trick (look at post 12 above, and in that link, start at step 11).

Thanks for putting out this device type, it’s been super helpful. I’ve been using this device type for a few months and it has been working great for me. The only issue I have noticed is that the battery has been reading 77% since I first installed it and has never changed. Shouldn’t the battery have charge have changed at least a little over two months? It seems like it may be stuck at that. Is there any way to check and see if that is the case?

I cant seem to get mine to detect motion at all unless I physically touch the sensor. Do you think I may have a bad sensor?

@KingStrava I’ve had 2 go dead like that, which I ended up returning and exchanging. Since then, I found the following reset instructions that may help. Give this a try, and then add it back to your hub to see if that does the trick:

Step 1: Remove the battery and wait ten seconds

Step 2: Press and hold the reset button while reinserting the battery. Hold for an additional two seconds and release.
Note: The reset button is a small white button located on the side of the motion sensor.

If that doesn’t work, I would exchange it for a new one.

@xavier999, A few of mine are in that range fresh out of the box. I’m not surprised either. I bet the batteries aren’t the greatest.

As for how it changes, I’m pretty sure they report in a similar way that the ST sensors do, and that’s in a range vs incremental 1% changes. In other words, 88%-100%, then 75%-87%, etc, etc. There’s a discussion about battery ranges and how that works somewhere in the community. If I can find it I’ll provide a link.

1 Like

Ah, thanks, that clears things up a bit.

thanks so much for this device type.
I just started with it this past week. so I don’t have a lot to go on yet, but so far, it seems to be working just fine. :smile:

I see the code but no instructions…am I missing them in the thread or the github post?

@cvastola This discussion was broken off from another thread because it was getting huge.

You can use Mitch’s code and then switch back to ST’s default so the device runs local to the hub, or you can follow my instructions to pair the device as is and then switch to ST’s default.

1 Like

Thanks! I figured out how to add the device by reading the code…is there any benefit to using your steps over the code Mitch provided?

When you add the device it will use Mitch’s code right off the bat without any problems, and then you can switch over to ST’s if you want to keep device usage local on the hub.

If you opt to not create a device type with Mitch’s code, ST will add the sensor as a Thing, and then you’ll need to follow my instructions. Without a doubt following the instructions is the long way of doing it compared to Mitch’s. I’ve probably used Mitch’s code for most of mine because it was just faster.

So I tried to delete the code that I added because when I added it everything went fine but the lighting automation I set up wasn’t working…it was as if the motion wasn’t being detected. But I still see the device in my device types even though I have deleted it and when I click on it I get an access denied message…I am going to try and re-add it but I wonder what I am doing wrong…I just added the device type, it recognized the device as a motion sensor but no motion was detected. Weird…

Something is up/wrong with the IDE since yesterday I think. I get the same message trying to delete one of my device types. I’ve submitted a support ticket, but I have yet to get a reply.

Sometimes this has happened to me, and I had to reset and add it back. In just a couple situations I actually had a bad sensor. Try the rest process for the motion sensor:

Step 1: Remove the battery and wait ten seconds

Step 2: Press and hold the reset button while reinserting the battery. Hold for an additional two seconds and release.
Note: The reset button is a small white button located on the side of the motion sensor.

Step 3: Readd the device to the hub.


Do you think that is impacting my device from sensing motion? I wouldn’t think so, right?

Ha! You were quick on the reply. I shouldn’t, but…

Just make sure your device type in the IDE is there and working.

I am sitting at my machine…thanks for replying so quickly yourself! :slight_smile:

So I got it working…didn’t expect that the red light would flash all the time…is that normal?

No worries! Family is out shopping, so I’m getting my fix with ST before they get home.

You should see a green light flash when there’s motion. I don’t recall what red flashing means. Are you getting motion events in the app?