[OBSOLETE] GE/Jasco 46201 On/Off Switch

I wanted to start a new post on this switch as there are so many GE/Jasco switches out there, and they all work differently, support different features, and need different device handlers. I did the new dimmer back in September, but another community member reached out to me for the related on/off switch. The newest Jasco on/off switch is the 46201 switch- https://byjasco.com/products/ge-enbrighten-z-wave-plus-smart-switch-quickfit-and-simplewire . There’s also a 46562 which is almost identical (I believe its just an upgraded commercial version) This is Zwave plus switch supporting S2 encryption and central scene control, which captures many more types of button presses then the old one, like triple taps, so it is different then the older switches. The stock Zwave on/off switch works to control the light, but advanced configuration setting, association groups, and scene control, require a custom device handler. I made a new handler that captures all these new button presses, and shows them all in the native automations part of the new smartthings app (without requiring webcore or smartapp). Since I don’t have this version of the switch, its difficult to debug and diagnose issues.

Update - Thanks to @BrenenP for confirming the device handler is working. If you want to use it you can import from mwav3 smartthingscode master in the IDE or click the link at the bottom.

Please report any problems as an issue on my Github page or in this thread. PR’s also welcome for fixing any bugs. I’ll work on updating the related 46203 dimmer to work with the new button values on the automation screen in the new app as well now that this code has been confirmed to be working.

Link to handler for this switch here:


I am a new member to this community without programming experience.

I have a GE 12722 in-wall z-Wave Smart Switch that was wired and set to turn on/off porch lights at specified times. Somehow, while using a TV controller I think, I tripped it to a strobe light configuration. I have unwired it to get it to turn off. Is there a manual way to turn off the strobe mode or a SmartThings command to turn off the strobe command? Or, if I rewire it, will it time out from this mode and go back to turning lights on/off?

Thanks for any help you could provide.

Dale Hauglum

These switches do not have a strobe mode. Unfortunately the switch likely has failed and needs to be replaced. If you do a search online you will see reviews where this was unfortunately a problem for many with this switch and the solution was replacement. The 12722 is their first version and likely well out of warranty. The newer Jasco ones, like the 46201, should be more reliable. Or, I recommend an Inovelli switch https://inovelli.com/red-series-on-off-switch-z-wave/

Some have mentioned taking the switch apart and unsoldering a capacitor to replace it, but that sounds like a fire waiting to happen if you do it wrong. I would recommend replacing the whole switch.


Thank you very much. This is exactly the feedback I needed.

I appreciate your getting back to me.

Dale Hauglum

Thank you so much for this, it works flawlessly.

1 Like

Thanks for posting. Adding double tap functionality is a gamechanger and eliminated my need for buttons to trigger scenes manually and instead can use my existing switches to do this. For both dimmer and standard switches I can get double taps to work but has anyone else been able to get the triple taps to work? I see the option when creating new automations but I have not been able to successfully trigger a triple tap command. Any idea what might be causing the issue?

Since I first made the handler I actually had to replace an older switch that failed with the new 46201 and can confirm triple tap worked with the handler. I did rececently move the switch off smartthings though but I don’t believe they made recent changes that impacted it, but it’s a possibility. There were multiple versions of this switch though and it’s possible yours is the “in between” version that has double tap but no triple tap. You can try the live log in the ide and then triple tap the switch to see if anything shows up.

@stephenk I might have figured out another reason triple tap isn’t working. First it’s assuming you actually have one of the 46201 jasco switches with scene control, and not an older switch.

Older device handlers configured double tap by adding the hub to association group 3. This can get double tap to work for both older and newer switches. The new handler I wrote does not add the hub to an association group as the newer switch uses central scene control to trigger double and triple tap instead.

However, if you used an older device handler, it added the hub to association group 3, and that zwave association setting will"stick" even if you change handlers. I believe that then creates a conflict where double tap will work, but triple tap won’t.

So, bottom line is to clear the hub from association group 3 if that’s the case. That can be done by using the zwave tweaker or factory reseting the switch. You also could try to go into preferences, temporarily add another device as an association in group 3, then delete it. That should reset associations but I’m not 100 percent sure it will. The tweaker or factory reset definitely will though .

So I’ve just added this DTH and applied it to my new smart dimmer switch. It’s the correct model as mentioned above, but I cannot control the switch with the ST app. It errors out with the network error message. The switch works fine and when I toggle manually, it does update in the app. Any ideas? Here’s what I’m getting in the logs:

error java.lang.ArithmeticException: Division by zero @line 691 (off)

Hi, I’m trying to use your DTH for GE 46201 and I cannot figure out how to do it. I’ve added the custom DTH in IDE, then I try to add a device using the Android app. I tried 2 ways: scanning the QR code and just scanning. In both cases it asks me to scan the DSK S2 QR code and successfully adds the device. The problem is that it adds it as some generic “Z-Wave Switch”. I only see on/off button in the app. I even tried to edit the device in IDE and force the DTH to “GE 46201 On Off Switch” but that doesn’t change the Android app. I also saw comments in the code to try set the “force settings update/refresh” to true - did that from IDE but it had no effect. In 2019 I wrote a DTH for 46562 and had no problem, it scanned and selected correct DTH. Now that the app forces the S2 security how do you make it choose your DTH?
EDIT1: I think the default DTH that gets applied is the new Edge driver since I see a new option to change driver in the Android app. The changes i do in the IDE to use groovy DTH for some reason are not propagating to the hub as I can still see the Edge driver in the app and use it to control the switch…

You can confirm whether your device joined to an Edge driver by seeing whether the driver menu shows up on the device in the app:

If so, I have a driver that you can swap to that will support the other features of the device:

If you’re set on continuing to use a DTH, you’ll need to get it to join to a DTH when pairing. There’s no swapping between DTH and Edge after pairing. It seems like people are having more difficulty recently getting devices that have production Edge drivers to pair with DTHs instead.

Thanks, that indeed was the case - the switch got included with the new stock edge driver and was ignoring all my IDE changes. I installed your edge driver and re-added the switch, it picked up your driver as expected. I noticed curious change in behavior, not sure if it’s the new HW/FW or effect of the driver. I used to be able to register double-tap on other switches without them changing their own state: e.g., I can still double-tap up on GE/Jasco 46562 without it actually switching on if it was in off position. The new GE/Jasco 46201 doesn’t let me do that - it responds to the click immediately. So, if the switch was off it’s impossible to do double-tap up without turning the local load on. I suspect it’s the FW change since it makes the response so much faster. Any thoughts?

There’s an open issue regarding this in the Jasco firmware repo. You may want to watch it as they say they’re working on a beta firmware to address this.

Apparently it’s impossible to update the switch FW on Smartthings platform as of now…