[Request] DH request for GE Jasco Switch 52252

hello all, was wondering if i may request here for a custom device handler for the newer Enbrighten 52252 Z-Wave Plus Smart Light Dimmer Switch.

Locally, only features are On/Off and Dim and status LED control.

I did however use this DH from mwav3 and it seemed to work, but had some errors and issues, but the multi tap worked, so i would imagine its possible. thanks for taking a look !

bump to the top :grin:

The mwav3 DTHs are the most up-to-date that you’ll find in Groovy, though based on your model number I think you’d want his DTH for the 46203 dimmer.

We’re in the middle of a transition away from Groovy DTHs. The replacement is Edge drivers, which have the benefit of running locally on your hub instead of in the cloud. I have a driver that should support your device - see the link below if you’re interested.

2 Likes

thanks. looks like i have it all installed with ST Edge now. so when Edge is rolled out officially, will my custom DH for a z-wave floodlight sensor be transcoded into an Edge driver? or will it still be up to the manufacturer of the floodlight sensor to create a driver to run it local on my ST hub ?
Sensor im speaking about is this one from HomeSeer. HS-FLS100+

Z-Wave and Zigbee devices that are using custom DTHs when the cutover happens will be mapped to one of the stock drivers that ST staff are building. The stock drivers seem to be replicating the functionality of the stock DTHs, so if you have a custom DTH has extra functionality that you want/need to keep then it will be up to someone - you, the manufacturer, the DTH author, or someone else - to rewrite it in Lua.

1 Like

roger that. thanks again for your work. i suppose ill head over to the Homeseer forum and ask about their plans for an Edge driver.

Lua huh… i know i should have paid more attention in Stormworks :sweat_smile:

so one thing i noted when testing, not sure if bug… if i set double tap up to dim on to 30% on it will never allow me to use the single tap up to get 100% on full… it gets kind of stuck in the dim state. any recommendations?

Could you post a screenshot of how you have that set up? I assume that’s in a routine?

The default setting for Default Brightness Level is 0, which means that the device will return to the previous dim level when turned on. Try setting that to 99, which is full brightness, to see if that does what you want.

1 Like

ah, yes. i see how that works now. again, thanks.

1 Like

Unfortunately I stopped using Smartthings awhile ago so wont be updating any of the drivers I worked on to edge. Anyone is welcome to use the Groovy code on my githib to develop a replacement though.

1 Like

thanks for the reply @mwav3 looks like the way forward is Lua and Edge.