Notifications Not Working with v2?

Hi Folks,

Am I the only one experiencing issues with the new mobile app on notifications? I’m not hearing any sound or seeing any notification icons on my phones/devices as I upgrade them. They work before, and stop working immediately after I update the app. I get nothing. Any ideas? I’m utterly stumped. Text message are the only way I can get any notifications at this point.


Have you set yourself up in the new Contact Book via My Contacts? Ironically, I just got this email from ST a few hours ago:

Hey there,

We noticed you were an early adopter of our Contact Book feature. That’s awesome! We’re pretty excited about this feature, but I wanted to reach out regarding a potential concern regarding SmartApps that were set up prior to turning on Contact Book.

There’s a chance that SmartApps you had previously set up to send you notifications may not be properly using the new Contact feature and thus won’t properly alert you when they execute. The fix for this is as follows:

Make sure you’ve added yourself to the Contact Book by tapping the menu button in the top right and tapping My Contacts. Furthermore, make sure that the email you’ve entered for your own contact is the same as the one you use for SmartThings.

Open the settings for a SmartApp you had previously set up by tapping on the My Home (four square) button at the bottom of the app, tapping on the SmartApps tab, and selecting the SmartApp. (Note: if you had dashboard modules such as Damage and Danger set up, you’ll need to check for SmartApps in those modules as well).

Navigate to the notification settings for the SmartApp and select the contacts that you want to receive notifications (including yourself) either by text or by push notification (if they are also a SmartThings user).

Repeat steps 2 and 3 for all SmartApps that send notifications.

I’m sorry for any inconvenience this causes, but I figure it was better to reach out preemptively rather than find out these notifications might not be working the hard way! If you need any help getting your SmartApps set up with Contact Book please don’t hesitate to reach out to


SmartThings Support

I don’t think that is related to my problem. I am not using any special smartapps, this a totally vanilla build at this point, I’m keeping things simple for troubleshooting purposes.

Example: I have my phone and a tablet hooked up to my account. The tablet is running the old mobile app. I just set up a push notification when I turn on a particular light. I created the notification in my mobile phone with a new app. When I toggle the switch the tablet running the old app immediately notifies as I would expect it to. My phone remains completely silent. No icon and no sound.

My wife’s phone is also running the latest software. It is also silent. Push notifications just flat out do not work. I’ve tried everything I can think of, including completely uninstalling the app and reinstalling it completely fresh. I have cleaned out the cache data etc. Nothing works. There are just no push notifications coming through.

Any ideas?


Aha, this is why adding users is messed up right now. It’s related to contact book functionality. If I was braver I’d try this out, but I have two users migrated from V1, and I’m not playing with that until I know I’m safe. :smile:

That’s interesting behavior. I’d still set yourself up in Contact Book and then go back and update/change the notifications in your scenario you described above. I bet it works after you do that, including on your wife’s phone (your tablet will still work too).

It may be related, but the support person I’ve been working with since early September hasn’t mentioned the relationship yet. Make sense though.

My notifications recently disappeared on my phone with the new app as well.

Where is contact book I seem to be missing it for some reason have no notifications operating correctly

@jerzydiver, here’s a pictorial how-to:

Tap on the 3 vertical dots:

Then you’ll see My Contacts:

It’s pretty self explanatory once you open it up from there. If for some reason My Contacts doesn’t show up, just try one more time. For some reason My Contacts is delayed when showing up at times.

I don’t have this thanks thought so. All open tick fit with support

That is a legacy v1 setup. Those options no longer exist in fresh setups.

@jeff1, Perhaps…but it’s a function of the app, not the hub. Plus it’s the My Contacts feature that I’m referring to.

I think there is still a connection though regardless of the hub version. Older setups still show doors, etc. I have a tablet doing that right now. It provides notifications perfectly also. But any fresh install I do of the new app with my newly configured hub kills all of that. The options aren’t even there. It looks like legacy stuff continues to work, but new “doors” for example are impossible to set up.

I see some strides forward with the new hub and app - but also strides back. Example, I no longer have a garage door icon for control and indication of state. I have my virtual contact switch and the door sensor. BIG step backwards.

On the other hand I can now create automations for sunset and sunrise with offsets. That’s a huge step forward. So clearly a mixed bag with this update.

The lack of notifications however is a persistent and huge problem. I put on a support ticket but suspect the staff are inundated right now.


ST support did get back to me on this. Initial thinking is that the situation is caused by my account being used on multiple devices, but after logging out of the other devices and logging in only on this phone I see no difference. Still no notifications. ST thinks the issue is on their end and they have added it to their queue. Which I’m sure is quite long at this point!


1 Like

I realized that while I changed my account password, I had NOT officially “logged” off my account from my two in-law’s smart phones. Even though they couldn’t do anything due to the password change, the logout was still required. Once I did that - everything now works as expected.

So that’s good!!! Now the bad - the “Add Users” feature is reporting that “This feature is coming soon.”. UGH!!! So if I want notification - I can only use ST with one single phone now. Not ideal. Very frustrating.