Push notifications not working?


(davedogcaddy) #1

We’ve stopped getting any and all Smartthings push notifications on both our (Android) phones for the last few days. Is it just me? Any ideas?


#2

All good here, including one just now for one of my cars pulling up. If it’s been a few days, something else is up. Where you expecting notifications from SHM, or some other SmartApp?


(Blake Westerdahl) #3

I am having some issues as well. I am using the “Notify me when” smart app. I have three instances of it. One stopped working around the last hub update. Another stopped working two days ago. The third is still working for now. I’ve tried deleting and recreating but it didn’t help.


(davedogcaddy) #4

I’m not getting any notifications from even the vanilla built in Smartthings apps/features (like home/away). Also no notifications from laundry monitor either. This has all been working fine for a year. Don’t see anything about this in the Smartthings status page.


#5

Depending on what Notify Me When was watching for, could you create a custom SHM rule instead to see if it works that way?


(davedogcaddy) #6

I don’t think I’m using ‘notify me when’…


(davedogcaddy) #7

We used to get notifications when either of us left/arrived (using phones as presence sensors), and when the washer/dryer finished (using Laundry Monitor smart app and the Samsung multifunction sensors). It ‘just worked’ i don’t recall setting up anything special to get the notifications - we do still seem to be getting notifications from rboy’s lock app though…


#8

No worries. I was replying to @trotsky40.

That has a required field for a contact when first set up:

To me it sounds like some of the SmartApps you should be expecting notifications from need a little kick in the shorts. You can do that via the IDE and going to My Locations and then going to your SmartApps list. Once there, click on Update. You can also do that via the mobile app by going to the SmartApp and just walking through each screen.


(Chris) #9

Any chance you’ve been logged out of the app? Seems to be a common issue on the latest release.


(davedogcaddy) #10

No, I’m logged in. Looks like what is actually occurring is Smartthings thinks both our phones haven’t left… Since the 18th! Rebooting the hub didn’t help.


(davedogcaddy) #11

I’ve always used Laundry Monitor with that field left blank as it says it will do push notifications by default if nothing is entered. At least that’s how I read it…


(davedogcaddy) #12

But back on subject somewhat, it seems a bunch of stuff broke all at once. Both phones (presence sensors), one of my two motion sensors, and one of my two multi-sensors where all ‘stuck’ on whatever state they were in at some point of the 18th. Removed/re-added the phones, and reset the sensors by pulling/reinstalling their batteries and everything seems to be back online now. This should explain why no push notifications. Time will tell. Any idea what happened?


(fightingmajor) #13

Set up Contacts. I have had a better experience in getting notifications when doing this. I’m not sure why ST does not have this set up by default instead of having to jump through hoops to get it working.


(Aaron S) #14

Not specifically from the information provided. If you haven’t already, please shoot a note over to support@ so we can flag this and investigate.


(Russell) #15

Was there a fix for this? I’ve noticed that I’m not getting a push notification when my multipurpose sensor opens.

The “Notify Me When” is set to “Contact Opens Multipurpose Sensor” is set to “Notify me via Push Notification” but on Android this isn’t working but my wife says it is on iOS.


(davedogcaddy) #16

In my case I had to pull the batteries out of the offending sensor and re-insert them - this reset the sensors which were ‘stuck’ in one state. If you are getting notifications on iOS though it has to be another issue…


(Russell) #17

I can see the status change in the app. Just seen that the app has been updated to 2.2.1 & it’s now working again!


(Dean Smith) #18

I’ve noticed that since the “contact” list has gone in - notification are now only going to SMS destinations and not Push’d to my Android device.


#19

Had same problem…I logged out from the app and log in again and it worked