Nothing but problems with new App (June 2021)

I have stopped using the iOS app for pretty much everything as it is completely unreliable at this point.

I am using the following currently:
a) ActionTiles for accurate device status
b) webCoRE for automation

The staff member coming here looking all concerned and then the hilarious/rambling response a week later was just too much for me to handle. ST support has been a joke for the last few years with stock responses and then closing the ticket without resolving the issue.

I’m currently researching other options. If things get worse, I’ll most likely switch to Hubitat or something else.


I am done switching to Hubitat I have been with ST from the beginning but this new app and the loss of all devices and all the effort people have put into it is wasted ! I have had nothing but loss devices no connection no status updates ! I am going with homebridge and home kit we will see what happens with over 100 devices and Hubitat!

With all the rebuilding with ST. I will take that time loss and start over with out Samsung and see if works with Hubitat!


I am trying an experiment…

I grabbed my wife’s iPhone this morning and noticed that it seemed to control quicker and not have any lagging with refreshing status of devices. I also noticed the only Favorite she had was STHM (in contrast, I have 10 favorite scenes and about 15 favorite devices). I had never set anything up for her because she only uses it to control STHM.

I am deleting most of my Favorites and trying to control through the Device and Life screens instead. Will see if it makes a performance difference. Could be that the issue is with the Favorites tab?

I have no favorites set except for four scenes. I have the lag issue.

Yes it was wishful thinking for me, as I’m now finding out. Mine is still lagging.

I’m going to play with my wife’s phone some more to see if hers is truly not experiencing the same issues as mine. Might point to some difference between the two if hers is having no issues.

1 Like

I also find ActionTiles being pretty good at reporting the status of my switches (mainly Fibaro Dimmer 2s) whereas the SmartThings App is awful. I either get that it can’t access the switch or the wrong status (eg off when it is on, and vice versa).

Surely if ActionTiles is dependent on the SmartThings Hub (I have version 2) to report status and it gets it right most of the time and with relatively limited lag, why is this so complicated for the Samsung SmartThings App!?

Aren’t there some guru developer types out there that could just produce an alternative to the awful Samsung SmartThings App (for updating device handler settings etc)?

Just happy that ActionTiles exists, else my home would be less than Smart!

1 Like

I suspect that there is a bit of a mismatch between the API and the apps. A single API call (and two or three followups if you have a lot of devices) can get you a list of all the devices and their health status. That is quick. However if you want the status of other attributes it requires an API call per device and that can be slow. Unfortunately that is exactly what dashboard tiles require.

It would probably be much quicker to handle much of the UI at the server end and use a webview, though that might have unacceptable implications for cloud resources.

That said, the Android app isn’t that sluggish these days and if you minimise what is on the Favourites page to what you really, really, really need that helps a lot. So it can be done.

I’ve never tried it but it seems that it is the iOS app that has been struggling, even at the best of times, and they do seem to have made a complete rick of the latest version of it.

It was not always like that. I always used to think the Android app was the second class citizen compared to the iOS one.


If and I assume … Best I got on that

If it is the Apple version of the app that is causing issues try installing and using an app called home remote, it gives access to all devices that ST allow and allows there control, just don’t open or use the ST app until its fixed

Or use the ST app to create,edit check automations (if possible) and get out quick

Thanks. Any idea why I never had issues with the Classic App, but the new Samsung Connect App is simply unworkable in terms of relying on determining whether a light is on or off!? You wouldn’t have thought something that appears so simple could cause so much issue! :-).

It really isn’t a problem that I see with the Android app and it does make me wonder what the iOS app developers are doing that is different.

I don’t have particularly fond memories of the Classic app. I had to use it because the new app wasn’t available on my phone, and if it had been it didn’t have any useful functionality anyway. However my recollection is of an app with a quirky, if not downright odd, UI which wasn’t particularly reliable itself.


Well I saw 0 progress with ST, I have been with them from the beginning, however the system is useless now. I started the conversion to Hubitat, and so far so good, I have had more issues getting the devices off of the ST platform than getting them on the Hubitat platform. I am hoping that Hubitat isn’t sold to another Samsung disaster.

It is like ST used to be. A couple of issues I have so far, are presence with iPhone is a bit flaky, thermostat program is ok but need drivers for Honeywell, have not got that done. Locks all work, after 100 devices moved all work very well. With those couple of exceptions. Very fast and no lag between executing the trigger and the actual result. All locally controlled. I also have Homebridge running and I have to tell you it is working excellent gives you a lot of options on the automation side.

Well I have threatened to switch for the last several years, I shutdown the ST hub yesterday for good I hope.


I am out as well. It’s been 2 months and nothing’s been fixed, which to me implies that this platform is dead.

I got my Hubitat yesterday and now almost 24 hours later I have disconnected the SmartThings Hub.


Yeah, I have been dealing with SmartThings and Family Hub via chat, email, and phone since August 10th. The features that I used on my refrigerator like shopping lists, haven’t worked since the new update and the removal of the Family Hub app. I can’t believe they got rid of this without testing the functionality first. SmartThings is arguably useless at this point. At least give us the option to go back to previous versions until you iron out the MANY issues with the new app version.

1 Like

Read the thread below… it would be in the last place you would think to look… under cooking :slight_smile:


I know where to find the shopping lists, albeit after quite a bit of searching around. However, SmartThings won’t load my shopping lists, I just get an endless spinning circle. It actually loaded one time earlier today (first time ever since the switch over), I added a few things. When I went to look at it a few minutes later, I got the login screen again (no idea why I would have to log in every time), logged in, then nothing but the loading circle.

I’m Moving to Hubitat Too. SmartThings is going down.

Is hubitat that much better?

It is stable, there is a learning curve and depending on how much stuff you need to move it can be time consuming, I had issues with Zwave devices in ST removing and excluding them, once I got them into Hubitat it wasn’t too bad including them, I would suggest taking it in stages. It runs inside your network so no cloud is needed. It is much better than ST and less issues and runs faster.

Yeah I had the same problem annoyed the hell out of me.
Logon to whisk with your “samsung account”and link it when prompted.
Even after doing that the fridge keep asking via smartthings cooking to complete the setup.

To get round that, on you phone load the smartthings app and under life tab delete the smartthings cooking and re add it . Then just follow the prompts to setup preferences.

After that you can use shopping list etc and tell bixby to add things to shopping list etc on the fridge.

1 Like

Well… where to start…

For those having issues:

  • What OS are you using Android/IOS?
  • I am using Android
  • What devices are causing problems?
  • Basically every device. Most peculiar is that when I program the middle button on the remote the actual instruction ends up on the top button. The app doesn’t seem to do much for the motion sensors. Programming them with time and day doesn’t seem to work at all. A setting on a remote control button doesn’t show up at all, or shows up under the wrong button.
  • Are you using custom drivers?
    I am on a Samsung S9 and I allways keep to the standard software.

  • What hub and firmware version are you running?
    The hub is a SmartThings Hub and the firmware says 00003900006.

If you’re not sorthing this MERDE out I might just as well switch to Philips Hue. At least their system works as intended.

I am deeply disappointed with how poorly you have handled this.

1 Like