Nothing but problems with new App (June 2021)

Thanks. Any idea why I never had issues with the Classic App, but the new Samsung Connect App is simply unworkable in terms of relying on determining whether a light is on or off!? You wouldn’t have thought something that appears so simple could cause so much issue! :-).

It really isn’t a problem that I see with the Android app and it does make me wonder what the iOS app developers are doing that is different.

I don’t have particularly fond memories of the Classic app. I had to use it because the new app wasn’t available on my phone, and if it had been it didn’t have any useful functionality anyway. However my recollection is of an app with a quirky, if not downright odd, UI which wasn’t particularly reliable itself.

2 Likes

Well I saw 0 progress with ST, I have been with them from the beginning, however the system is useless now. I started the conversion to Hubitat, and so far so good, I have had more issues getting the devices off of the ST platform than getting them on the Hubitat platform. I am hoping that Hubitat isn’t sold to another Samsung disaster.

It is like ST used to be. A couple of issues I have so far, are presence with iPhone is a bit flaky, thermostat program is ok but need drivers for Honeywell, have not got that done. Locks all work, after 100 devices moved all work very well. With those couple of exceptions. Very fast and no lag between executing the trigger and the actual result. All locally controlled. I also have Homebridge running and I have to tell you it is working excellent gives you a lot of options on the automation side.

Well I have threatened to switch for the last several years, I shutdown the ST hub yesterday for good I hope.

3 Likes

I am out as well. It’s been 2 months and nothing’s been fixed, which to me implies that this platform is dead.

I got my Hubitat yesterday and now almost 24 hours later I have disconnected the SmartThings Hub.

2 Likes

Yeah, I have been dealing with SmartThings and Family Hub via chat, email, and phone since August 10th. The features that I used on my refrigerator like shopping lists, haven’t worked since the new update and the removal of the Family Hub app. I can’t believe they got rid of this without testing the functionality first. SmartThings is arguably useless at this point. At least give us the option to go back to previous versions until you iron out the MANY issues with the new app version.

1 Like

Read the thread below… it would be in the last place you would think to look… under cooking :slight_smile:

2 Likes

I know where to find the shopping lists, albeit after quite a bit of searching around. However, SmartThings won’t load my shopping lists, I just get an endless spinning circle. It actually loaded one time earlier today (first time ever since the switch over), I added a few things. When I went to look at it a few minutes later, I got the login screen again (no idea why I would have to log in every time), logged in, then nothing but the loading circle.

I’m Moving to Hubitat Too. SmartThings is going down.

Is hubitat that much better?

It is stable, there is a learning curve and depending on how much stuff you need to move it can be time consuming, I had issues with Zwave devices in ST removing and excluding them, once I got them into Hubitat it wasn’t too bad including them, I would suggest taking it in stages. It runs inside your network so no cloud is needed. It is much better than ST and less issues and runs faster.

Yeah I had the same problem annoyed the hell out of me.
Logon to whisk with your “samsung account”and link it when prompted.
Even after doing that the fridge keep asking via smartthings cooking to complete the setup.

To get round that, on you phone load the smartthings app and under life tab delete the smartthings cooking and re add it . Then just follow the prompts to setup preferences.

After that you can use shopping list etc and tell bixby to add things to shopping list etc on the fridge.

1 Like

Well… where to start…

For those having issues:

  • What OS are you using Android/IOS?
  • I am using Android
  • What devices are causing problems?
  • Basically every device. Most peculiar is that when I program the middle button on the remote the actual instruction ends up on the top button. The app doesn’t seem to do much for the motion sensors. Programming them with time and day doesn’t seem to work at all. A setting on a remote control button doesn’t show up at all, or shows up under the wrong button.
  • Are you using custom drivers?
    I am on a Samsung S9 and I allways keep to the standard software.

  • What hub and firmware version are you running?
    The hub is a SmartThings Hub and the firmware says 00003900006.

If you’re not sorthing this MERDE out I might just as well switch to Philips Hue. At least their system works as intended.

I am deeply disappointed with how poorly you have handled this.

1 Like

I can see where this is leading. I will tell you what version I have and what hardware I use and I will be told that I have to upgrade to the latest stuff. Well, in my book that is not acceptable. A system that is not backwards compatible for more than a year or two is rubbish. I will probably upgrade, however - by leaving the SmartThings ecosystem. Philips Hue will be happy to see me as an extended customer. A bit more expensive but then I won’t have to buy new hardware every second year.

I use the V2 of the hub. The app is the latest (broken and rubbish) version 1.7.73.22.
I use a variety of remote controls. The motion sensors are Samsung SmartThings 2.2.11-4
The door sensors has the same version number as the motion sensors and is also Samsung SmartThings.
For buttons I use the IKEA controls. No version number available.
The plugs are TP-link.
The light bulbs are IKEA and TP-link

But the issue isn’t the hardware. They all use Zigbee or Z-wave protocol. If it was the hardware then why would all of it stop working or malfunction at the same time? Especially since they are different hardware from different manufacturers. The issues arrived after updates of the app, so it is clearly the app that is a pile of dung. I don’t do my own programming so I am only using the presets, routines and automation.

The reason I went with SmartThins was because of compatibility with a variety of hardware from many different manufacturers. Clearly, I was mistaken. I might just as well switch to a totally proprietary system like Philips Hue. At least they have shown a more consistent backwards compability.

/Rolf

1 Like

I’m really finding myself angry with Smartthings at this point. The app is a steaming pile of crap. Nothing but incorrect statuses, spinning icons, failure to control, network errors. Support is absolutely useless.
They acknowledged half a dozen cases from me, asked for many logs, even promised me an improved beta version to test over two months ago. And still I wait. And spend 5 minutes every morning trying to disarm STHM. Heaven forbid I actually try to control a device from the iOS app.

3 Likes

I want to know which engineer team at Samsung thought “You know, when our users open up their SmartThings app and click to view their devices, they aren’t going to be interested in their smart home devices but rather, what they really want is to see what bluetooth headphones are paired with their phone. Let’s go ahead and create a category called “Personal Devices” that is the default screen they have to see every time they want to view their smart home devices, and no, this category and its contents can not be deleted, modified, renamed, or anything of that sort”.

2 Likes

Every time? When I select the ‘Devices’ tab I am taken to the last room I was in, even if I have force stopped the app or restarted the phone since I last used it.

2 Likes

I could deal with the weird UI behavior if the app let me control a device or get a correct status within the first 20 seconds of opening it.

Aha good of you to point that out because after trying to re-create the issue I found that I must have been moving between my locations (I have 4) while not viewing the devices screen. It’s only after viewing a new location that the devices tab defaults to the “personal devices”. Once I get to normal usage and not configuring this thing all the time, hopefully this won’t be an issue. Thanks for your attention!

My First alert smoke alarms that worked fine now cant be added becaude they all of a sudden need a hub to work. It now shows none of my devices.

1 Like

If only Samsung was a world wide company with the financial backing to do a decent job with their software development.
Wouldn’t that be the least they could do since we have invested tens of thousands of dollars in their products.

1 Like