New User with connection issues

Greetings!

I just purchased the Smartthings Hub v3 a few multipurpose sensors and wifi plugs as well as a dimmer switch. I really look forward to setting up and using my ST; however I am running into an issue setting it up. :confused:

I downloaded the smartthings app and have followed the directions as to setup the hub but it keeps getting to 48% complete and saying that my device cannot connect to the internet. I have tried connecting directly to the back of the xifinity router in the basement as well as to the hardwired switch I have in my living room. Also have tried connecting to both 2.4 GHz and 5.0 GHz wifi to no avail.

I have tried a reset on the device with holding the button down on the back with no power then attaching the power waiting for the yellow light to stop flashing then proceeding like new.

I have logged into my router to see connected devices and it does tell me that it has been connected to the router both through wifi as well as through the hardwire connection in all instances - directly to the back of the router and through the switch.

During the connecting process when it says the lights flash green and red it does do that and continues flashing those colors while it is trying to connect to the internet then shows me the error that it cannot connect.

Any insight would be great…beating my head against the wall over here

-Justin Wombwell

If you are just trying to do it now and you are a US user, then just wait a little. There are some difficulties on the server side.

Have a look here for the current incident description and subscribe for further emails.

https://status.smartthings.com/

1 Like

Also the hub requires certain ports (can’t remember which) to be open On your router during setup. Most hubs have UPnP enabled so don’t run into these issues. If you have it disable the. You will need to research the ports required and set up a port forwarding rule in your routers config.

The easiest method would be to enable UPnP

Fantastic thank you for the help guys. I will look for what ports to forward as a backup and make sure upnp is enabled if it’s an option. I will also check again when I get home from work if it was a server side error.

No ports are required to be forwarded to the ST Hub. The hub makes an outgoing connection to the ST Cloud servers, and persists that connection for bi-directional communications. Please do not forward any ports, as that just opens up your home to hacker attacks.

1 Like

Just made it home and i do have uPnP enabled however zero config is not enabled under that settings page? is this something that I need to enable?

I did try and connect again to no avail. I am currently doing a factor reset on the ST hub and will try connecting again. I also uninstalled the app on my phone and reinstalled.

-Justin Wombwell

Still nothing. Tried wireless and wired. Tried with and without zero config on. Tried 2.4 and 5.0 ghz.

I am at a loss right now.

Send an email to support. They will give you detailed instructions or if in the US, just call them.

1 Like

Agree with @GSzabados, send email to support.

In terms of the ports, it does need ports open but only during setup, if you have UPnP enabled then that is usually sufficient.

Hopefully support can sort it out for you. I also know the servers in the USA were having serious issues yesterday, many people were reporting it, so maybe it was just that, have you tried today yet?

Yeah upnp is on. I will try support here in a little while yes I am in the US.

Tried this morning and still getting thrbsamr issues both wifi and wired. I did a reset on the modem the switch my phone and the st hub this morning to rule something out that way as well.

see screenshots attached. During the connecting 48 %, stage the lights are blinking red and green on the hub.

Screenshot_20191025-094305_SmartThings|243x500

Was told to return the device and try a new one. The issue sounds like to the pro that it’s a faulty hub. Will get a new one later and keep the post updated. Thanks for the help by guys.

1 Like

thanks for the update, and once you have a solution please do post it and mark it as the solution, that way others can find it in the future.

good luck

Will do

Just got a new hub and I am experiencing the same issues that I was with the first one. That makes me believe that it is something on my network or something with ST

Any suggestions on anything to try? I did not try opening up any ports but I did temporally disable all firewalls through the router
I also manually added the MAC address in under the mac filtering even though that is turned off

Take it to a neighbor’s house and try it there? That’s about all I can think of as a simple test.

1 Like

I will attempt that later, they are all at work right now

This is very frustrating, I have never had an issue connecting anything to my wifi or my network in the past

what model of router do you have, have you tried searching to make sure there are compatibility issues, its a long shot and I haven’t heard of any but still worth a quick google search

What type of ISP connection do you have? What type/model of modem? What type/model of router?

I am wondering if you inadvertently have a double NAT setup, which is confusing the hub somehow? Just a guess…

also, some routers allow you to turn off IPv4 and use only IPv6, again its a long shot but just make sure you have both enabled, if it supports both, especially IPv4. I would have thought if this was the issue you would be having compatibility issues with more than just the ST hub. Which version of hub is you have? is it the newest one v3?

The issues with connecting new devices yesterday are resolved.

How long have you waited while it sits at 48%? From what I recall the hub will look for and install firmware updates as soon as it connects which can take a while.

sometimes 10 min some times 2 min

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.