Devices disappeared from IOS and web app but all show in IDE (April 2023)

The Smartthings IOS app worked as expected earlier today but when I went to use the app a short while ago almost all my devices and some rooms are no longer visible in the IOS app or the web app. I can see all the devices in the IDE still and when I called support they had to escalate. Not sure if anyone else is having issues today…


I have not seen any issues on my end.

No problems here.

I had the same issue today. At 9 PM EST most of my devices have disappeared on my Android app. I’ve lost most of my devices, scenes, and routines. It looks like all of my devices are still in my IDE

Me too. Don’t know the time but everything is gone when I got home yesterday.

I don’t even know where the hub is supposed to be in the new app???

This morning all of my devices, scenes, automations via edge drivers are gone! The hub itself doesn’t even show up in the app. This is so annoying. Hopefully things come back or this might be the nail in the coffin to ditch smartthings. I’d gladly pay for something that worked consistently.


Same. This morning all z wave and ZigBee devices as well as the hub (Aeotec) do not appear in the app. I’m using Android. I also have SmartThings connected to Google home and Amazon echo and the devices are gone from those as well.

I reported it too Samsung through the SmartThings app and there hasn’t been a response yet.

Same thing here. Very frustrating and pushing me more and more towards Hubitat. Looks very random as I see a couple lights connected via hue show but most are gone from the app and automation’s aren’t firing (but show in IDE). Even my Samsung devices such as motion sensors are gone from both the Android or IOS smartthings app.

1 Like

And of course Support wants me to delete and reinstall the app and list out what missing … Not gonna happen.

I replied with links to this forum.

The same thing happened to me. Pretty much everything is gone including the hub This REALLY pisses me off. I have days of work ahead of me setting everything back up, if I can remember how to do it and what all I am missing!

So now, in trying to re-setup some of my devices, I re-enrolled in one particular edge channel. When I try to install a driver, the message says my hub doesn’t support edge drivers. WTF??

While the lack of acknowledgement from ST thus far is discouraging I would sit and wait for now. You may end up causing more issues.


Chiming in…
All my devices disappeared from the ST App

After re-adding the hub, I thought of the same thing. Thanks for your reply. I guess I should just sit and wait.

1 Like

I just logged on IDE. All my devices are listed. There is No Hub connected on the app nor any hub

You may want to start using SmartThings API Browser+ in place of IDE.

Mine are all gone too. Started at 9pm last evening.

I’m glad I’m not alone. I have a key old V2 hub and was like, man, did they shut me down?
But I checked and the hub isn’t retired.

I have a V2 hub. I had a status green. Decided to reboot (unplug and plug). Now the Hub stays green…then occasionally reverts to Blue

Still No devices show up

I just checked my IDE unlike some of you, I don’t see my devices there either. Only my IPhone is listed as a presence sensor and rooms listed as placeholders. No Hub, no other devices. Really bad SmartThings!