New Leviton In-Wall Dimmers

I just bought and installed a Leviton DZ1KD-1BZ dimmer switch. It has 7 LED lights that it controls. The switch paired easily with my Smartthings. But after a few minutes, the switch shut off, the LED on the switch flashed red and the switch disappeared from Smartthings. Do I need to return it to Home Depot? I’ve repeated this several times with the same result.

Try adding it manually by selecting the model manually when you’re adding it. It seems to work better when pairing and it won’t error out. It also takes a while for ST to finally see the device even though the dimmer reports a successful pairing.

I think mine might need to go back to Home Depot though. These have been acting really wonky for me lately. They stopped updating status to the controller. I repaired the z-wave network, removed, re-paired the dimmer itself and still no luck. Using the switch manually isn’t updating the status anymore. ST also stopped reporting the dim value. Now it’s two dashes instead of a percentage. I had changed nothing since installing and using them for several days. I started noticing the incorrect device status a couple days ago. Did ST change something in the Z-Wave Dimmer Switch Generic device handler? That’s what mine gets added as each time and I don’t see an alternative option to change it to in the IDE. There is also some physical wonkiness with the dimmer that I noticed since I first got it. Sometimes when I try to make it brighter or dimmer by one level, just tapping the dim bar will take it to full bright or off. It doesn’t matter what level it’s currently at. If I’m at dim level 3, it will go all the way to the brightest. My last resort is to try and factory reset the dimmer itself.

EDIT: Seems like a factory reset and re-pairing of the dimmer has fixed the reporting issue. Seems back to normal. Let’s see if things deteriorate again in a few days.

Does anybody have the Leviton DZ6HD or DZ1KD dimmers with matching dimmer switch remote DD00R hooked up and working?

I know that the DZ6HD sends instant status updates to the hub when physical adjustments are made, but do the same instant updates occur (no manual refresh needed) when physically adjusting the DD00R remote?

Does anyone have the DD00R remote?

I installed one yesterday but I think there’s a bug. The remote has the LED dimming indicator (left side) always on.

On the DZ6HD these indicators are only ON when the lights are ON

Yes, the LEDs on the DD00R are not tied to the settings for the LEDs on the DZ6HD as you would expect. Also, if you try to adjust the dim level before turning the light on you need to wait a few seconds before turning the light on or it won’t work. Also, instant status updates for on/off do not get reported to the hub when using the remote.