New android classic app Nov 15 crashes when saving any smartapp

For me the new android version (nov 15) crashes when saving any smartapp on final save button. Happens for both of my locations. Can anyone else try it and confirm. Old app restored works fine.

I just made changes to Sharptools and Simple Device Viewer and they both saved fine.

Running Android 8.0.0, latest app version 1.7.40-21

1 Like

Upgraded again to new version and redid test as I hadn’t tried those aoos. Same issue. Ie

1 Like

They also forgot to add the icon library.

Updated Classic app or updated new/V3 app?

I just tried to save Sharptools in the updated classic app and it crashes just as the OP is experiencing.

Good catch @prjct92eh2

+1 new app :stuck_out_tongue:

1 Like

Also seeing crashes after saving any SmartApp, Routine, or SmartHome Monitor settings. The changes do appear to save, it just also crashes.

Since the last update it crashes immediately after I launch it (goes to home screen), and I have to launch it a second time. I cleared the cache, but it continues. Pixel 2 XL on Android 10.

1 Like

Mine does the same immediate crash and then works on reopen on Pixel 2 on Android 10. ST Classic App was updated on 11/19. Mobile presence has also stopped working (never changes) since the update on both devices. Other device is Pixel 3a on Android 10.

Have Android users tried to go to the app and deleted cache (app info-> Storage -> Clear Cache).

Should not do any bad… I seem to see the issue gone since I did that.

I did clear cache after posting here and that so far has fixed the crashing. Did not fix presence, but that is likely a different topic from this thread. I do believe it is related to the app update.

Tried updating again snd cleared data snd cache sf. Still crashes on saving smartapp. Android 8.0 lgv20

I haven’t tried to save a smart app. Most of my automations are managed through webcore.

Same here… Pixel 2 XL and it’s just crashing no matter what I do.
Very annoying!
It doesn’t even know when I arrive or leave home… Completely useless now.

Noticed the icon are also gone… (light bulb, switches etc…)

Same issue here with 3 new LG V50’s Also presence will not work.

How long before this is fix?

This may just send me over to HE, since they have become more stable now.

Clearing cache did not fix the crashes and presence was still broken. Yesterday early afternoon I uninstalled 2.18 and reinstalled 2.17 on my Pixel 2 XL, my wife’s Pixel 2, and our kid’s Moto G6. I had backed up the APK already, but you can get it from APK Mirror. Then I went to the Play Store and for the ST Classic app I disabled auto-update. When you open the app it prompts again to re-enable permissions, like location and disable battery optimization (optimization could make presence detection unreliable). Otherwise, everything was like it was.

I thought I was going to have to add the phones again as new “Things” (so I’d also have to re-add them to my automations, too). Instead, I just went to the settings for the old “Things” I had for the phones and saved them again. Later that evening after I had left home and returned I noticed that they had synced up.

1 Like

I didn’t notice the icons were gone! I also had the immediate crash again this morning.

I briefly did the same and rolled back to 2.17. But I’ve now decided to give the new smartthings app a try… I only have a handful of simple automations I manage via the app, so I recreated them in the new st app. Would definitely be cumbersome to move many automations. I know it’s not ideal, but I’m willing to give it a shot.

1 Like

Worst **** update in history, a sabotage not an update.
Crashes all the time and presence no longer working.
This was the first update of the app for almost an year, what changes were they actually trying to push out ?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.