New Alexa Skill Not Discovering Devices After Migration

I have 2 open support tickets with Smartthings. Amazon says it’s a problem with Smartthings. Smartthings says it’s a problem with Alexa and I even had a Smartthings support person tell me they don’t make Skills, Amazon owns it.

My scenario…

  • I have v2 hub with about 50 devices.
  • I was running the Smartthings Classic App on my Galaxy S10 device using my Samsung Account
  • I was running the the latest Amazon Alexa App
  • I was using the Classic Skill in Amazon Alexa to connect to Smarthings
  • I did not have any routines programmed in Alexa.
  • I do not have any smart devices connected to Alexa. Everything is connected through Smartthings.
  • I have various Alexa devices in my house (classic, dots, shows)

Every things was working great. No issues. Then about 2 weeks ago I started to expereince a few random, minor issues. I noticed in my Alexa App that I had some duplicate Smartthings devices listed as well as some old devices. I decided I would clear everything out of the Alexa App and refresh. That’s when this problem began.

So I did the following steps…

  • I first removed ALL my Smartthings devices from my Amazon Alexa App. Everything is gone. I also go to alexa.amazoncom and no Smartthings devices show up. Below, you can see only Alexa devices show up in my Alexa App.

  • I then DISABLED the Classic Skill in order to break the connection between Alexa and Smarttthings
  • In the Classic App, when I went to SmartApps, Amazon Alexa no longer showed up.
  • I then tried to ENABLE the Classic Skill, but the Classic Skill is no longer available, so I couldn’t do that

  • I then installed and ENABLED the NEW Smartthings Skill. Of course, this does not show up in the Classic App as a SmartApp, like the Classic version did, so that didn’t work.

I installed the NEW Smartthings App on my Galaxy S10 phone. All my devices show up. My Routines from Classic DO NOT show up. I can interact with my devices. Things appear to be working.

  • In the NEW Smartthings App, if I go to “Settings” -> “Connected Services”, Amazan Alexa shows up shown below

  • No matter what Alexa device I try, I ask her to “Discover Devices” and after about 30 seconds, she comes back saying she can’t find any new devices. None. So my Alexa App continues to show 0 Smartthings devices.

I contacted Smartthings Support around 21 April and after 30 minutes, they couldn’t resolve the issue and transferred me to Alexa Support. I spent 45 minutes on the phone with them and they couldn’t solve the issue. Between the 2, everything was attempted Uninstalling apps, reinstalling apps, disabling skills, enabling skills, clearing cache, force stop application. I even tried to remove 1 device from Smartthings, re-add it back then try to discover it in Alexa. She still can’t discover the device.

Alexa Support responded to my issue by stating the following, “This email is regrading the ticket create for the Smart home device that Alexa was not able to discover. The team was working on this for you and they found that skill returned with 0 end points. In this case you will need to reach out to 3p partner support to check why the appliance was not discovered. It looks like there is some server issue with the third party devices.”

But here is a curious thing I observed that no one can answer, and by no one, I mean the 2 Smartthings and 1 Alexa support person.

  • In the NEW Smartthings App, if I go to “Settings” -> “Connected Services”, Amazan Alexa shows up shown below

  • In the NEW Smartthings App, if I click the “+” to add a new device -> “Voice Assistant”, Amazon Alexa shows up as well. But here is the curious thing. Why does is show that Amazon Alexa is "Connected to "? Nothing there? Google Assistant is showing that it’s connect to my Home (my 1 and only Smartthings location). If I press on Amazon Alexa, nothing happens. BUT…

  • Then I go to “Settings” -> “Connected Services”, Amazan Alexa and DELETE Amazon Alexa as a connected service, she disappears as expected, BUT then…

  • I go back to “+” to add a new device -> “Voice Assistant”, and now Amazon Alexa is “Connected to Smarthings” Before it was blank, now it says it’s connected to Smartthings. Now I can press this and it takes me to the Alexa Skill Store as shown in the 2 images below.

  • But I when I ask Alexa to discover devices, she still can’t find any of my 50 devices. Again, I’ve tried installing, uninstalling, enabling, disabling, removing devices, adding devices. I feel the issue is with the Skill and neither Amazon or Samsung are taking ownership of the problem.

This is beyond frustrating!!!

In the Alexa app, is there a SmartThings skill currently installed?

There have been some changes with the Alexa integration lately, so not too surprised that support is confused.

Here is the current support doc. Note the alternative process to use if Alexa doesn’t discover devices (with the first process):

Yes, image above shows that it is “linked”

1 Like

None of those steps work.

Huge shout out to @Lars and the engineering team at Smartthings for digging in and solving this one. Well done!

1 Like

Hi, I have this exact same issue. I have also opened a ticket with Smartthings as well as Amazon. Amazon says it’s a smarthings issue. I’ve been working with a rep at Samsung, but at this point she said she’s going to forward this to the engineering team… Can you share what you or @Lars ars did to resolve this? It’s been almost a month since I regret deleting the smartthings classic skill from alexa.

If you PM me your SmartThings account email I will take a look. There has been a few issues like this, usually related to something being out of sync in the user account.

1 Like

I’m having this exact issue, is there something I can reference when contacting support? @lars

Same problem - Alexa not able to discover any SmartThings devices after migrating to the new Alexa SmartThings skill. Can you please share how you resolved this issue.

1 Like

@Lars , I’m having the same issue too. I’ve tried disabling the skill on alexa and disabling alexa in smartthings, then relinking in the alexa app. No luck. Has a solution been found to what’s going on? Thanks for your help!

If you don’t see any devices, this is usually the result of something wrong in the state of your account which is not something you can resolve on your own. Please contact support, and/or PM:me and I will investigate.

Migrated to the new app yesterday, disabled the old skill, Alexa assumes she has control of everything but doesn’t actually change states of lights.

1 Like

Hello. I have a similar problem. I added the Smartthings skill to Alexa and it only discovered my N950 soundbar. But i cannot manage to add my A/C. I have tried to disable and re-enable the skill. Not working.

Update: Seems to be a problem relatet to this type of device. Altough i can fully control the device from smartthings app, it does not show up in Alexa App.

But i found an answer here.

  1. login to
  2. find your aricon under the devices list
  3. Click the Edit button on the bottom of the device details page
  4. Change Type from “Samsung OCF Air Conditioner” to “SAMI Samsung Air Conditioner” and hit Save (don’t worry, you’ll be able to switch it back)
  5. Now refresh
  6. Your Aircon from SmartThings will show up and you can assign it to a room. However you won’t be able to control it (all settings are grayed out)

The A/C now shows up in Alexa App but i cannot open the device page. Seems it is not supported yet.

Same problem. As OP. Nothing has worked. Alexia won’t detect any of my smartthings devices. My smart home has become a dumb home. I PM Lars, and hope he can resolve it. But it seems like there are a huge number of people hitting this issue.

I had problems in the past, but usually tricks like the one andutgv just posted would resolve it.

The exact thing happened to me. But I am using iPhone. I have tries everything you’ve listed. Even went on Alexa_amazon_com to add SmartThings skill and using the website to discover SmartThings devices but nothing works. I am at a lost now.

Same issue here. this seems to be a problme for alot of folks. Really need someone to onw the problem. This has got to be one of the worst migration/upgrade ever.

If you jsut look at the Alexa Skills feedback, the last three are below:


1 start by Shane T. on September 27, 2020

everything is now broken in the new app and skill most zigbee stuff does not work. if you just brought a smartthings hub take it back while you still can

3 of 3 people found this review helpful


1 start by JayC on September 26, 2020

really screwed it up.

7 of 7 people found this review helpful

SmartThings not smart

1 star by Paul J. Hansen on September 26, 2020

worst update ever not able to add some existing devices ,lights etc total junk
every time you update you male ot worse

6 of 6 people found this review helpful

Thanks to Nezmo for his respons eon my other thread. It provided a solution for anyone experiencing this same issue of haivng device disappearing from Alexa and not finding them again in Discovery search. Below is my quick summary of what Nazmo detailed in my other thread…

For those reading this and having the problem, just rename the device/scene in the ST App. Then save it. Wait a few min (I waited 2-3min). Then go back to Alexa App, and swipe down to refresh the search. Then, the renamed devices will show up. It sucks to have to rename all the devices, but at least there is a solution while someone is looking at the fix. you can rename it back if you like.

Did not work for me. God, how I wish it had.