Nothing works in Alexa after migration

Like everyone else i was forced to finally migrate to the new app and install the new Alexa skill. Of course now nothing works with Alexa.

Alexa now says, “The skill linked with _____ is not enabled. Please enable the skill to control this device.”

So yes, the old Smart Things skill is not enabled because you kept telling me it was frickin’ mandatory to upgrade, so I did. Now the new skill is enabled and it doesn’t work. WTF? How do I fix this?

Follow the instructions in this post

1 Like

Thanks but I already clicked the migrate link in the Classic app on my phone and then logged out of the Classic app once everything was migrated.

I also disabled the Classic ST skill in Alexa and there’s no way to get it back as it has been removed from Amazon’s skills library.

So, I disabled the ST skill in Alexa, removed all ST linked devices from my Alexa device list, re-installed the ST skill and then ran discovery. Nothing found.

Amazon is announcing new devices on 9/24 and my plan at this point is to buy an Echo Plus with the built-in hub, maybe even the brand new version if one is announced, and throw away Smartthings. I’ve completely had it with Samsung, their terrible smarthome products, exploding washers, burning phones, arrested CEOs, the whole thing. Enough.

Did you remove all devices and scenes using the website? That’s key.

Then wait. Then try discovery.

Yes that’s how I did it, on How long am I supposed to wait? It’s been a while.

I only waited a few minutes, maybe 10 at the most, between deleting everything related to SmartThings and running Discovery.

I recall discovery being weird. IIRC, it reported it had discovered 10 devices (out of 50-ish). I ran it again and it said no new devices discovered. But somewhere in there all of my devices had been discovered.

All I can suggest is to try again. Remove the skill from Alexa via the app. Let it sit a few minutes. Hit the website and delete any and all objects that mention SmartThings. Wait 5 or 10. Add the skill. Maybe make an extra check for devices here. Then try discovery.

Don’t know what’s coming new but the current Echo Plus only supports Zigbee devices, I believe.

Might be time to find something you can smash into tiny pieces with a large hammer!

I have seriously done that with tech that had frustrated me beyond endurance!

1 Like

I finally got through to SmartThings phone support after an unbearably long delay. The rep told me it’s a known issue and they plan to release an update to fix it on Tuesday. I have no idea if that’s truthful but I hope it is.


Maybe it’s part of the hub update that starts rolling out Monday…

1 Like

Not clear on your last.
ST is planning an update to which on Tuesday?
On the alexa skill?
I’ve been having issues with ST devices not firing an alexa routine but alexa can control ST devices. Support says its a known issue also, but no time frame.

I was thinking it was a hub firmware update coming and didn’t think to ask if the rep actually meant the Alexa skill.

In the post just above yours, Hal mentioned a hub update starts rolling out Monday which would fit with what I thought the rep was telling me.


Ditto, WTF!

I had a similar (same?) problem. I found that the following steps worked:

  1. Rename a device or scene in the new app and save it.
  2. Immediately rename it back to the original name and save.
  3. Wait 3-5 minutes and it automatically populates to the Alexa app (Android). No discover devices necessary.

The first time I got it to work, I had renamed the hub location as step 0, and named it back as step 2.5. I’m not having to do that now, so I don’t know if that was necessary to prime it the first time to work now. I suspect not.

1 Like

OMG that worked!

I didn’t rename the hub location, I just renamed each device one by one. When I was nearly done, one device was not still being seen by Alexa so I deleted it from ST and reconnected it as a new device. At that point Alexa found the new device, plus 6 Ecobee sensors that I had not yet renamed, plus all my scenes which I had not yet renamed. Makes me wonder if I had just deleted one device from ST, reconnected it and then told Alexa to discover devices, would she have found everything? Maybe.

Anyway, thank you!

I tried everything mentioned here and on several other posts and nothing worked. I was ready to give up till I did 2 final things and it worked.

  1. I went to smartthings IDE and watched the logs appear as I turned switches on and off. I have a harmony hub and noticed all my smartthings devices where presenting on the log with “Harmony Device” at the end. So I decided to remove my Harmony hub from Alexa and smartthings to see if having the same devices connected to 2 hubs was creating an issue.

  2. I reset my home internet modem and router. I know, this should have been my first move.

After the modem/router booted back up everything was discovered by alexa again! voice control is back. I’m almost positive that resetting my modem/router is the only thing that needed to be done. I’m just happy that everything is working again.

I had a chat with @lars about my issue after I’d already gotten things going again. It turned out to be a Peanut plug sending a messed up manufacturer name to Amazon (specifically, “Securifi Ltd.\u0000\u0000\u0000\u0000\u0000\u0000�W…and it went on and on”.) Amazon failed to handle that name and rejected the entire device list. Apparently Chinese manufacturer names can also get rejected by Amazon. Weirdly my other Peanut plug is returning a normal name with no problem. Anyway maybe that will help someone having similar issues.

We made a fix for this issue yesterday so anyone having problems please try again and let me know.

@Lars - My Aunt is having a similar issue where nothing works after the big migration. I tried factory resetting her Alexa and reconnecting the Alexa to SmartThings through the skill, and still nothing responds to turning on lights. She doesn’t have a peanut plug, but has GE Enbrighten Z-Wave Plus Smart Outlet Receptacle. Any help would be appreciated.

Can you PM me the account email and I can investigate? Have you tried to go to in a webbrowser? There might be duplicated devices on the alexa account not visible in alexa app. If so remove all devices via the webpage and then try discovery again.

Just sent you a PM, and will use the URL you provided to further troubleshoot.