Need help reconnecting ZWave Switch that disappeared from my Smartthings app

I have a GE switch (ZW3005) that is no longer being recognized by my Smartthings app.

I’ve attempted to reconnect it using the process depicted in this forum (add device on smartthings app, search for device, click the rocker switch up once to pair, etc.) but the device is not being discovered by the app. I get the error code: 34-302

The switch works fine when I operate it manually.

Any advice on how to reconnect this switch?

have you tried a z-wave exclusion on the device before trying to add it? or run repair z-wave repair to see if there are any errors or ghost devices?

I have not. I don’t see an option to access the hub in my smartthings app. It seems many of the how to videos and guides i find online refer to an app that doesnt have the same look and feel as mine. I am using version 1.7.64.21 which should be the latest.

Thank you for the quick response!

to access the hub in the app, best way is to go to menu > devices > find and open the hub (by default it is named Home hub unless you renamed it) > click the 3 dots in the upper right of the screen > select z-wave utilities

try excluding the device first, then attempt to add it :slight_smile:

Thank you, jkp! Looks like i actually was successful at reconnecting it, it showed up as a generic name (which also makes sense), but I was looking for it under the name it previously held. I realized this when I followed your direction to access the main hub!!

Really appreciate your help on this!

Any idea why the switches periodically disconnect from the hub?

1 Like

It depends what you mean by “disconnect.”

In order from most likely to least likely:

  1. If you mean that the smartthings app still sees the device but when you look at it it has a message that the device is “off-line.“ Then that’s an artifact of the smartthings cloud architecture, it probably doesn’t really have anything to do with zwave. It’s really annoying when it happens and you can find lots of threads in the forum about it but it just seems to be kind of random.

  2. It is possible that your zwave network is getting overloaded with local traffic and some repeating devices which are normally available become temporary unavailable and then your switch will also be regarded as being unavailable even though the real problem is the repeaters that are closer to the hub. If this is the problem you need to “strengthen the mesh“ by adding more repeaters.

You should be able to see something in the data for the device that tells you whether there have been a lot of message failures and trying to get through to it. I don’t know exactly how to do that in current version of the app, but hopefully someone else will comment on that.

The first thing to do is to run a Z wave repair and see if that helps or what error messages you get. you won’t see an immediate improvement when you run this utility, it can take a day or two.

And here’s a thread on how to diagnose the messages you do get when you run the Z Wave repair:

FAQ: Zwave repair not working (how to fix error messages)

  1. if by “disconnect“ you mean that the device disappears from the app altogether, instead of being there but having an “off-line“ message, this can happen in one of two ways.

It is unusual, but possible, but something gets screwed up in the smartthings cloud and The app can no longer find some of your devices even though they are in fact still on your network. Sometimes when this happens it happens to a whole lot of people, sometimes just to a few. Sometimes the devices disappear for a few hours or a day or so and then reappear. This can happen also happen to scenes or automations.

There really isn’t anything you can do except report it to support so they can look at your account but eventually they usually get it straightened out again. So if you think this is the problem, first check the status page at

https://status.smartthings.com

Although not everything that’s posted on that page and sometimes it takes a few hours. Still, it’s worth checking.

Next, contact support:

  1. again, if the device has disappeared from the app all together, but your other devices are still there, there is one other possibility that is specific to zwave. If you were in the process of excluding a different device and somebody happened to hit the missing switch with exactly the right tap pattern during that process, then the missing switch might also have been excluded. This can happen, particularly with light switches. I’ve even known it to happen once in a while with neighbors in an apartment building.

Manufacturers have tried to reduce the likelihood of this happening by making the Tap patterns more complicated over the years. So it’s possible, but these days you don’t hear about it very often.

If this happens the only thing you can do is what you’ve just done, which is to add the device back again.

There might be some other reasons this could happen but I think these are the four most common. :thinking:

Thanks for the info i will try to figure it out for more.