GE On/Off Switch wont connect after move

devices
hub
wallswitch
zwave

(Chris Sturgis) #1

My wife and I recently moved house. I of course took my GE Z-wave switches with me along with my smartthings v1 hub. Additionally I deleted the location from my account (and the hub) hoping for a fresh start in the new house. After taking care of the welcome code issue from deleting the hub everything is back up and running now, with 3 exceptions.

I brought 3 GE On/Off paddle switches with me that were previously installed in my old house. I have installed them in the new house and they function properly in manual operation. However they would not connect to the hub. Last night I swapped 1 of them out for a brand new, fresh from amazon, switch and it connected quickly. I swapped another of them out for a new in box switch which I received some months ago, before the move, and it quickly connected as well.

What gives? Why wont the old switches connect? Is there a reset procedure that I can perform to get them to connect? The new in box switch sat in the same environment as the previously installed switches so i can think that it is environmental damage. I just dont get it.


(Beckwith) #2

Did you try excluding them first?


(Bobby) #3

You need to do a general exclusion before you can add your old switches.


(Bobby) #4

@beckwith we are trying but we are no @JDRoberts are we?


(Chris Sturgis) #5

Wouldnt have thought you could exclude something that is not a part of the system. I will do this with the 3rd switch (the one that is still installed) this evening and report back.


#6

Specific exclusion is for when the device was part of your network and you know its device ID and that’s usually called “remove” in the zwave utility list.

“General exclusion” is part of the Z wave standard and is for when the device was not part of your network and you don’t know its device ID. It was added to the standard specifically to allow for situations where the controller itself had been damaged and you needed to move everything to a new controller. But it also turned out to be useful because sometimes a join doesn’t quite work and The device ends up thinking it belongs to a network but not knowing that it’s your network. Also, sometimes the device is joined to a test network at the manufacturer and doesn’t get cleared before it gets shipped.

Anyway, the point of all that is that any Z wave controller can issue a general exclude that will be heard by all the Z wave devices in range. At that point if you put an individual device into exclusion mode, whether it ever belonged to your network or not, it will then clear all of the controller information it has stored. And it will then be ready to be added to a new controller. (Or added back to its previous controller if the problem was a failed join.)

So usually the first troubleshooting step for any zwave device that doesn’t join correctly is just to do a general exclude on it. One of those can’t hurt, might help, things. :sunglasses:


(Todd Wackford) #7

I found this very handy for testing zwave devices. Good for checking device health for join and remove.


(Chris Sturgis) #8

That worked, thanks everyone.

Next question though. When pairing them they would only pair as “Z-wave generic switch” which works well, except I am not able to change any options for the switch (namely the behavior of the LED). Went into Graph.api to change the device type and GE Zwave switch isnt an option, nor Jasco…What gives part 2?


(Chris Sturgis) #9

anyone have an answer for this last issue??


(Beckwith) #11

In the IDE change the “Device Type” from “Z-Wave Switch Generic” to “Z-Wave Switch” right above it. It used to select this correctly, but there is some issue where it sometimes takes the generic one which does not let you control the LED status light.

Seems like a recent bug.


(Chris Sturgis) #12

thank you sir/maam/other