New Hub Will Not Connect to Existing Zigbee(Samsung) Devices

I am on my second replacement hub and cannot connect my 20+ Samsung sensors. These were originally connected to a v2 hub. It quit working, so I bought a new one a couple of weeks ago. It worked with all wifi & zwave devices, but not Zigbee. I replaced that hub with a brand new one yesterday with same results. The devices act as if they are connecting to the mesh network, but neither smartthings apps will detect them. I have followed all reset instructions many times. Samsung support has been less than helpful. Any idea how I can get this going. I refuse to replace nearly $1000 worth of perfectly good sensors.


Could there be anything causing interference such as a wireless router near the ST hub, usb cable or telephone devices?

It is plugged in via ethernet to an access point nearby, but I have disabled the 2.4ghz AP.

Funny thing is, lights on devices do the red/green flash for a few seconds, and then show a solid green like they are connected, but ST app times out after 10 mins or so.

Have you tried adding devices using the ST Classic app?

I have many times with the hub I just replaced. Stuck to the new app with the new hub trying to narrow things down. I will give that another shot, but don’t have high hopes.

Positive thoughts yield positive results :grin:

Certainly. just been fighting this for weeks. thanks for the positivity. I will give it a shot and report back.

Is it possible that the QR code scan for the newer devices is causing me issues? The devices seem to green light while the app is verifying code. Just a thought, although older devices without QR code do not work either.

I’ve also wondered if the devices are all connected to the “old” mesh network and refuse to allow the new hub in the club. They sure seem to be talking to each other, but not recognizing the hub. All devices have been reset according to device manuals.

1 Like

So the new hub is not showing up in the classic app. It says that I need to connect a hub and wants a legacy v2 code. What am I doing wrong?

Try changing home location in the app. I bet you have two.

When you got the new hub, did you remove the old hub and all devices in IDE?

I removed the original v2, but not my first v3. Maybe I am looking at things wrong, but the IDE does not seem to reflect changes from the new app. Is it a shard thing?

You can click on My Locations in IDE and see all locations and associated hub/apps/devices in them.

I will try all of this. I really think my devices are somehow still associated with my v2 hub, but when I factory reset the v2 and try to add it with the code, it says that it is currently in use with another account and to contact support. IDE shows nothing concerning the original v2.

Thank you very much for your attentiveness on this. I certainly appreciate it.

Did you try with new bettery? Device will work when they are low battery but usually doesn’t when try to add them as new device.

Yes, I have put new batteries in many of my devices. The same thing happens with my Zigbee power outlets and light bulbs, however.