My Contacts - is it back?

This seems like quite a coincidence to the post I made about this yesterday

I saw contacts this morning, and I thought it was weird. it was gone before I took much notice.

I did not need caffeine, but was a beer in when I tried this. Still got to work.

Thanks for the post, I would have never tried.

edit: Contacts does feel a little half baked, probably why its not available widely yet.

1 Like

this sounds like a great feature to bad it doesn’t seem to work on ios, guess i’ll have to wait for an official release.

Nothing for me, tired it 10-12 times

Looks like Android, any luck on IOS? I have Android BTW :slight_smile:

Rick

when i force close the app; then launch a new session – its there until the app finishes loading. ( the sequence is 1. notifcation 2. smartapp 3. contacts. then after the app completes loading; its 1. hub is online 2. notifications 3. smartapps.)

appears to be written in the app to have contacts but then disappears. very observant of the op.

You can try the other way to enable it but this is of course not an officially supported way to do it.

While logged into the ide go to https://graph.api.smartthings.com/account/list then click on your account
Now in your browser address bar replace
account/show
with
contact
And then enter to go to this new address.
Click the import users button and you should have contact book enabled now.

16 Likes

Since this is enabled for you, you might want to check out Alexa Helper. The documentation stated this would be enabled at some point and that by using it you can push or SMS messages to people. See if this is enabled in any of your scenarios (like any on/off control scenarios). Be sure you have 2.8.6 (updated just now to keep the contacts from being a required parameter).

I followed the IDE solution for contacts above and now Contacts show up on my phone, however the only contacts are me and my wife, no additional value at the moment

Rick

Thanks! this did work! and thats awesome!

But as a warning to anyone else this overwrites all notification information from smartthings (SHM only?. apps that send notification seem to still work) so if you enable contact and stop there you will get no notification (from SHM) at all until you go through and set all notifications you had to use contacts

I am very excited to see this functionality throughout the system including being built into smart apps. it would be nice if there was another option when selecting notification destinations to select all (so when new contacts are added they automatically get the notifications), And the ability to disable messages for some items based on mode. for example send a txt to the neighbour about a water leak but only if the mode is vacation.

Also any time I select USA or Canada for my phone number location it changes it to bermuda and screws up the number :frowning: but it does still send the txt’s

Yep…seems they coded their stuff internally using this new process: http://docs.smartthings.com/en/latest/smartapp-developers-guide/sending-notifications.html?highlight=contacts

2 Likes

I’m just a little curious… Did you read the first and second posts of this thread?

My bad. Post deleted.

Lol, I was just screwen around. No worries my friend.

1 Like

Worked. This is awesome. Thanks.

I’ve tried both these methods with no luck. When I log into the IDE my initial address is https://graph.api.smartthings.com/user/show and if i change to contact I just get a 500 error.

I’m also on IOS and the hamburger method doesn’t work as well. Would love to have this.

Hey 4loveofpunk

Once logged into the IDE, select My Locations then select your account name, this is the URL where you will change account/show with contact

Give that a go
Rick

2 Likes

Hi
The app way is not working for me and I ma extremely confused as to how to set this up through the IDE. I’m in the UK. Please Help

This worked 100%, thank you!!

@Rigi03 use the method @Toy4Rick suggests. Go to your IDE and select My Locations from the top left then select your account name. The thing that took me a minute to figure out is to leave the string of code at the end and ONLY change account/show to contact which you’ll see I have highlighted in blue and leave whatever the code which i have represented in purple :wink:

EDIT: I screen shot the wrong address, should be account/show, see my new here.

2 Likes

I get access denied when I try this :frowning:

I was getting the same error over and over until I finally figured out you have to leave that string of numbers at the end plus the forward slash.

Just follow these steps…

  1. Log into IDE - https://graph.api.smartthings.com/

  2. Look to top left and choose “My Locations”

  1. Click on Account - Probably your name

  1. In your address bar you will have something that looks like this below

https://graph.api.smartthings.com/account/show/9872349838dd8ejd83j-uejduejeu-uejdjdue

  1. Change it to this below (with whatever your last stream of code is)…

https://graph.api.smartthings.com/contact/9872349838dd8ejd83j-uejduejeu-uejdjdue

If it doesn’t work the first time, keep trying, I feel like I had errors a couple times as well, but then seems like it just worked so either I did something wrong, or the trying a few times helped. But I just got it working about an hour ago.

J

10 Likes