Multiple Issues with ST integrations and devices (June 2021)

I am hoping someone can shed some light on recent issues with a whole host of devices and integrations.

In no particular order:

  1. Honeywell TCC no longer seems to update ST in a timely manner when, for example, a setpoint or thermostat mode changes. So, for example, I used to get an SMS sent when a cooling setpoint remained below a certain threshold for more than 2 minutes. Now I get nothing.

  2. Zigbee switches no longer work at all.

  3. Z-Wave switches will turn on, but it takes minutes for the ST IOS app to show that it’s turned on - and so it can’t be turned off until ST updates.

  4. Ditto for a GE dimmer switch that controls my kitchen lights. It will turn on, but takes forever for the status to update before it can be turned off again.

  5. August and ST integration is broken (as detailed elsewhere) but the alternative of using Z-Wave is just so unreliable as to be useless. The lock is less than 20’ from the hub and rarely works. It either shows as offline (when it’s not - I can use the August app just fine) or the lock / unlock commands don’t work.

All of the above worked just fine until about a week ago when the wheels came off in spectacular fashion. I can’t believe that things are so badly broken. Am I the only one with these issues?

Obviously I have tried all the basic troubleshooting including restarting my hub etc. etc. Nothing has changed in my environment and routines that were working perfectly for months if not longer are broken. It’s frustrating beyond belief.


Yes something just happened, native smartthings devices are very laggy and third party devices aren’t working for me at all

WOW! I can’t toggle any of my virtual switches when I got home today. I did notice they pushed that latest firmware update to my SmartThings Hub while I was out. Guess I’ll try rebooting the Hub to see if I can get my virtual switches to work again.

I ended up power cycling the SmartThings Hub since the IDE reboot didn’t work and now my virtual switches are working again, WHEW!


yap, a physical power cycle vs. ide reboot seems to be working.


The Honeywell TCC started getting buggy for me about 10 days ago.

I have tried both an IDE reboot and a cold reboot by pulling the power and neither have made any perceptible difference to my setup.

Some things work - so, for example, when I open the door from the kitchen to the back yard the Aoetec sensor correctly triggers the routine that turns off my back yard camera and my AC if the outside temperature is above 80F. Location mode changes still seem to work and so my Robo vacuum has started vacuuming upstairs this morning once my wife left for work.

However, my Zigbee switches and all my lights still don’t work. The app remains incredibly slow to update device status. Things like temperature changes / setpoint changes from the Honeywell thermostats still aren’t being reflected.

Well, whatever was broken with ST seems to be a lot better. With the exception of my TCC thermostats everything is back to normal. Performance is once again snappy and all my devices are responding to the app and to my Webcore routines. The August lock integration problem (detailed elsewhere) is also resolved which is excellent.

1 Like

I tried the IDE reboot because my zigbee switches have stopped responding as well I haven’t tried a physical power cycling and I’m not home right now to be able to try that I hope that that fixes the problem as it has for some of you but for those that have posted indicating they were still having issues as of the last post are you still having issues or what did you do to resolve?

None of my Zigbee devices work either. I am able to monitor the Zigbee devices in ST. But, I cannot control them (turn them on/off).

Read my other reply to your other post. The app upgrade changes this reply :slight_smile:

In the last two days I’m having massive issues of about half of my devices showing up as offline and irregularly responding to commands and updating status. Many of the devices with issues are plug in switched plugs or wall switches that act as repeaters (mostly zwave for switches and the combo zigbee/zwave plugs).

It’s so bad I’m trying to do a zwave repair and lots of devices can’t update the mesh. Ugh! Haven’t (probably should have) tried a hard unplug/reboot of the hub yet.

What just happened is that Samsung made changes to its platform, either without properly testing the impact on existing use-cases or without caring. Either way, not good.

1 Like

Same - can’t even find Z-Wave repair in the new new app design - but since updating everything is broken and for the first time in 3 years i’ve not been getting hot water over night!!

Tap on the Devices tab, locate and open your hub, click on the 3 dots in the upper right of the screen, choose z-wave utilities

1 Like

I can’t even open the hub in the app at the moment, everything i’m opening is just spinning and timing out.

I’ve tried two hard power resets and a reboot in the IDE but nothing is working

Same thing here. Hoping this morning things would finally work, but like other posts, just spinning. When attempting to choose z-wave utilities, app crashes. Of course uninstall/reinstall/reboot, all tried and no help. App sees light is online, but just spins when presses until it times out. EDIT: After another reboot, lights seem to be working correctly again this morning. Z-Wave utilities still crashes app, “Smartthings has stopped”.

same here z-wave shows online but no controle in app(other devices slow and laggy) the other thing i noticed my hub no longer blinks green when in pairing mode. I cant pair new or repair old devices.

I hope this is temporary but it’s not the first time in the last few days. Ironically i’ve had a new hot water cylinder fitted so obviously went to blame that for not having hot water twice for the first times in 4+ years, but alas it’s SmartThings.

I hope this comes back up soon - starting to think I should double switch my hot water tank and have something else control the first switch which is always on unless SmartThings goes down - although monitoring that is difficult at best.

Dealing with a full-on meltdown after the June update was pushed. My Smartthings hub dropped off my Eero Mesh network and I can’t figure out how to re-add it, so nothing is responding to turn on/turn off prompts. Hoping I don’t need to do a factory reset and the need to run a zwave exclusion, deletion and re-add on all my devices. Really getting tired of how clunky these upgrades go!

1 Like

Things certainly have been hit and miss over the weekend. Yesterday afternoon was particularly bad with nothing working. Things seem better today but my hub reported itself as being off the network but remains accessible and routines are working.

As others have said, there’s been a wholly inadequate amount of testing for this new release. I am not sure whether Samsung underestimates the number of users who rely on ST for their home ecosystems but persistent issues like these really do encourage people to start looking elsewhere!