Several Issues with my new ST V2 - Frustrating

Hi all. I’ve had a pretty frustrating past week with the issues noted below. Some of this stuff used to work, now it’s faulty, buggy, reverting to not working, the list goes on. I only have a few devices so I can’t possibly imagine how insanely frustrating and un-trust-worthy this stuff will get with even a modest collection of connected devices. Here’s my detailed list in hopes somebody from ST or the community can assist me, or it’s all going back to ST for return.

Also please note I hold the reset button on the back of the unit for 10 seconds every other day trying to fix this stuff, most of the time everything is still not functional. Below is the current state.

  • Door sensor (packaged and ship with my ST Hub - Black Friday deal)
  • Originally worked just fine. It is mounted sideways on the door frame, and was properly showing OPEN/CLOSE state with no issues for ~2 weeks. When I left for the holidays, it was CLOSED the entire time (as it should be), and when I entered the space it didn’t change to OPEN. I then tested several times, with no state change in the ST app, and no resulting actions of course. I will be next trying all of this again to see if it works, but why did this get stuck in the first place!
  • My other note is that this is ~25-30’ away from the hub, and almost has line of site.
  • Motion false alarms
  • My motion sensor has a few false alarms daily. This turns the light on for minimum 3 minutes according to my SmartApp “Smart Lighting.” It also causes the Security Smart App (first tab in the iOS app) to go into alarm state all the time. I really have no fix for this that I’ve found, it’s pretty bad though.
  • This is about 15-20’ away, and there is one wall in between it and the hub. It’s about 10-15’ away from from the door sensor as well, in the same room.
  • GE light switch dimmer (z-wave)
  • I purchased the 100% compatible GE light switch w/ dimmer ( I added it to the app, and since day one it has not worked well at all. Here’s my summary attempt:
  • First of all, attempting to turn off the switch from the app did nothing for a good week. It just said “turning off…” then would eventually go back to showing “ON.” The light would stay on. The only way to get it off was to dim it to 0%, but then I have other problems as noted in my final bullet below.
  • I could usually turn the switch ON with the app, but sometimes it wouldn’t work.
  • The dimmer works ~50% of the time from the app. It’s extremely clunky and refresh rate seems so poor, who knows what’s going on.
  • During an “intrusion” alarm, it’s supposed to turn on the light and set it to 100% dimmer, no matter what it’s previous state was. I’ve found that most of the time (but not all of the time), during a simulated intrusion (i.e. door opens, when my door switch used to work), the light wouldn’t do anything if it was previously dimmed to 0% via the app. GE light switch seems to remember last % and therefore doesn’t turn back on if it was previously set to 0. This isn’t consistent though, seems to be fairly random.
  • This switch is about 2-25’ away, and there is one wall between it and the hub. It’s again in the same room as the motion and door sensor.

Is this what everyone’s experience is like with smart things? I’m a tinkerer, an EE, and love technology like this, but if this is par for the course, I need to find another system even if it’s less open and less customization. Thanks for any help.

Other post with similar problem recently: Hub V2 - New version issues? , Frustrated with ST! , probably there are more as well.

Not had those problems.

First in reference to your Zigbee issues. Could you have you hub too close to your router? I have seen similar issues due to wifi interference with 2.4 ghz standards. It needs to be as far away as you can make it.

The Ge switch I have as well, and do not have that problem. Could be a bad switch, or it could be something that is blocking the signal between your hub and the switch. You say that it is 2-25’ away, that is a bit of a stretch. How far is it and if you move the hub near it, does it get any better? What type of construction do you have in your house?

It is right next to my router, hopefully that’s the main issue.

Can I use wifi to allow the SmartThings hub to attach to the network, or must I be connected via ethernet CAT5/6?

Sorry for the typo, 20-25’, not 2-25’ away. Everything is in one room, it’s the next room over from the hub. All walls are plaster, no closed doors on the first level.

I can’t really move the ST hub closer unless I can use wifi for network.


I would definitely move the hub, maybe get a longer cat 5.

But hey, reading this actual just helped me.

About a week or so ago I moved a lot of my hardware. I changed the location of my router, modem, ST hub, and Phillips hub from downstairs to an upstairs room.

Last week I had a huge problem with my zigbee devices. I got it working again but they have been acting weird.

After reading this I realized that I have put my ST hub literally less than 2 inches from a very powerful router.

I will be moving that today!

I hope that fixes your problems. Not sure about the motion sensor, I’ve only found I’ve sensor that I trust, follow this link to read all about it.

Is the GE switch a Zwave our zigbee switch? I’m betting the door sensor is zigbee as well.

Please let us know if moving your hub helps.

Also, after you move it, unplug it and remove the batteries. Let it sit for at least 15-20 minutes before restarting it. This amount of time is needed for the zigbee devices to freak out and rebuild the mesh network.

Hope this helps.

I’ll have to move the hub and see how it goes.

Door sensor + motion is zigbee, so those are mesh and honestly that should be great distance-wise even now, except for the hub being next to a router. The light switch is Z-Wave.

What device type are you using for the switch? Does your neutral wire have a good connection knob as well as the ground? Definitely with checking.

The distance off the parts from the hub is ok, just move the hub away from the router and reset it like I said above.

The device type is the standard ST one, it popped pop after ~60 seconds of searching for devices in the iOS app.

The connections are definitely solid, and the switch works fantastic as a switch, just the communication w/ ST that’s not good.


When you paired the switch, did you start with it off?

Step one - have switch off
Step two - start the app to pairing mode
Step three - turn switch on, count to two, turn switch off. Repeat until the app finds it.

It should be found within two cycles of the switch. If not, there is another issue.

I recommend you remove the switch, be sure to excuse it properly, and repair the switch. There may have been a problem in the initial configuration.

I’ve installed about 35 of these exact switches and learned the above steps work best.

I’ve reported a lot about my reliable setup, I’ve never added that my hub and router are two floors apart. It was important enough for ST to put it in their instructions, I figured I should follow their advice.

1 Like

This weekend only my ZigBee devices were not responding. After trying several different resets/configurations the only thing that helped was to move the ST Hub away from the WiFi router (at least 6 feet) and changing the WiFi to channel 1.
Hope this helps.


Ok, I unpaired the GE light switch.

Then I took out batteries, disconnected power and LAN, waited 20 minutes.

Reconnected LAN, batteries, power, this time about 6’ away from the router (for now).

Re-paired light switch, seems to be much more responsive, so far so good.

Zigbee ST motion and ST multipurpose don’t work anymore. Unpair both, take out batteries, bring next to ST hub, put batteries in, re pair. Again they are working.

But how long will this last and why did I have to do this?

Thanks all

It may last forever… or they could be broken right now…

Odds are is that when you initially paired everything with the hub close to the router there was a data corruption in the data packets sent from the hub to the devices for the configurations. This most likely occurred due to the interference from the router.

Moving it away and redoing the install cleans up the install configuration.