Monoprice 4 in 1 sensor won't pair

Does anyone have one of these sensors paired with a V2 hub?

I’ve tried and searched and tried and tried. The hub just doesn’t find the device and no messages appear in live logging.

I bought two of these and both will not pair.

Monoprice are asking me to send them back.

@rboy hope you don’t mind me tagging you (I’m a subscriber :slight_smile: )

1 Like

Have you tried excluding them first?

1 Like

Things to try before pairing:

  1. Reboot hub
  2. Exclude the device
  3. Reset the devices

You can find step by step instructions to pair the device and some troubleshooting tips at the end of the first post here:

Note that you need to press the button twice to initiate pairing and exclusion.

I tried again:

  1. Reboot Hub from IDE
  2. Reset device by pressing the button 10 times in 10 seconds (little hole on the outside of the device next to the vent/grill on the plastic)
    • LED flashes 5 times
  1. Initiate exclusion mode in IDE and press button twice
    • LED Flashes 5 times
  1. Wait 30 seconds
  2. Open App on phone
  3. Got to My Home->Things->Add a Thing (Note: the instructions say to do this from the Market Place, I think this is for an old version of the app)
  4. Press button twice
    • LED Flashes 5 times

At this point, the app says “Looking for Devices…It’s taking longer than expected to find devices”.

Note:
My Hub firmware says: 000.025.00050 - I don’t know if this is stopping me from pairing.

if you have a v2 hub and have 25.50 then you should contact ST support because v2 hubs just went up to 27.6

any chance you have any Device Handlers that could be stale? try opening any custom device handlers in IDE and Publish for me again.

Thanks everyone…

The device handler I’m expecting to use is:
[Enhanced Z-Wave Plus Thermostat with Temperature, Humidity and Auto Time setting] from rboy

It was showing in the IDE as Status=Edited - republished and now it shows Status=Published

Went through the pairing process again. No luck.

I’ve contacted Smartthings support about the firmware level.

did you exclude and re-pair after publishing the handler?

Yep - tried exclusion and repairing. Nope.

Everytime I press the button I get 5 LED flashes - apparently it’s not already connected to a network.

how close is the sensor to the hub when trying to pair?

Generally about 20 feet - but I’ve also tried it within 1 foot.

Curisouly, I’ve got this response from Monoproce:

Thank you for contacting Monoprice.
Upon checking, this item is compatible with Z-wave hub, and we didn’t test it yet with Samsung V2 Hub.
If you want, since your item is still in warranty for refund. I can send refund request instead of replacement.
I do apologize for the inconvenience.

one last question - you are logging into IDE @ https://account.smartthings.com?

https://graph-ap02-apnortheast2.api.smartthings.com

Added - I get redirected to ^^^^^

try logging into the URL I posted and see if it redirects you to the URL you posted

Yep - it does redirect.

OK, work with @RBoy and hopefully he will be able to help you :slight_smile:

1 Like

Do you have other device handlers in your account? If you’re running into the stale DTH issue, any unused device handler can be blocking it. Just to ensure that it isn’t the stale DTH issue : FAQ: My lock/device does not pair or appears to pair but it won't show up in the mobile app or IDE, remove all device handlers (or republish ALL device handlers one by one), then try to reset, exclude and pair it again within 5ft of the hub.

If it works then it was a stale DTH, now install the custom DTH and either switch the DTH or pair it again.

Another way to check if you’re running into the stale DTH issue, open the IDE -> My hubs -> Click on List Events, there you’ll see it pair successfully in the list of events. If you don’t see a device being paired after the pairing starts (you’ll have to refresh the page), then it’s a bad sensor.

If that still doesn’t work then you may have a bad batch of sensors. It happens sometimes, a few folks have reported it and usually RMA’ing it and getting a replacement solves the issue.

Thanks rboy.

Still no good.

I see this in the Events list:

I don’t know what these events mean.

I’ll ask Monoprice for replacements. I’m not too enthusiastic about paying another $70 for shipping.

These events are unrelated (they are UPnP events). Basically your device isn’t pairing itself which is for one of 3 reasons:

  1. It needs to be excluded (can be easily done and when it excludes you’ll see an event in the same place showing that it was excluded). If it doesn’t exclude then you’ve got a bad device.
  2. It’s having trouble communicating (easy to fix, bring it closer and reboot the hub)
  3. Batteries are dead

If it’s neither of the above then it’s a bad batch and you should have Monoprice send you replacements.

Are you sure this is the v2 hub and not the SmartThings wifi hub?