SmartThings Community

Mobile presence sensor stopped working

presencesensor

(Paul) #1

Anyone noticed recently mobile sensor stopped working? I just noticed yesterday that both mine (Android) and my wife’s (iPhone) presence sensor did not report new status e.g. both me and my wife arrived home for an hour and presence still said away, or vice versa. Now I’m at work and still it’s showing mine as present.

And no I’m not working close to my home, it used to work flawlessly until recently. I can see in activity log my presence is pretty off against my leave and arrive routine.

Any ideas? Do I have to delete the mobile sensor and re-add it?

Thanks in advance
Paul


(Tyler Jones) #2

Im seeing the exact same thing after nearly 6 months of pretty flawless performance (I’ve had trouble in the past before that). Thought it was related to the beta firmware upgrade but I’m being told the hub has nothing to do with presence sensors. I have android, wife has iphone, and both stopped working well sometime early last week.

I use GPS any time I’m in the car to help improve the reliability of the triggers. Mine seems to be working find leaving the area, but is about 5-10 mins behind when coming back. Had to install a backup trigger to my garage door sensor to disarm the house.

If you hear anything, please let me know.


(Craig) #3

Same here takes 5-10 minutes to before it shows me home but I also have Nexx garage that uses location and opens the garage door when I get home that quit working I think about the same time. My phone and my wife’s both have the problems both Android Samsung S8 phones.

Both have been working for months with very few problems

Would love to find a fix for this


(Jason) #4

Same here, I had to pull both presence sensors out of our cars because it was opening and closing our garage door a few times an hour, simultaneously… meaning both presence sensors would leave and arrive at the same time…not sure why. Then my phone got hung up on away for almost a day over the weekend. I tried all the tricks to snap out of the freeze and finally got the phone to trigger a “home” reading. I reached out to support and still waiting for over four days. This is very unlike the support I’ve received in the past.


(Paul) #5

They surely messed up with the mobile presence sensor in this firmware update, was working perfectly before for a long long time. Like yours, mine stuck in away even I’m here connected to wifi for hours already. My wife’s iPhone tends to fix itself after one time of detection failure but mine is consistent.

So I deleted my mobile presence and re-added it, yesterday it was working perfectly, even arrived one minute before my wife’s iPhone, but I had my phone charged so let’s see how it goes today if my phone is on battery saving mode.

BTW I was suspecting Android 9 update ruined this but since some of you are using S8 then I think it’s definitely ST’s fault


#6

We’re getting this problem too on my S8 and my wife’s Pixel 2. Mobile presence used to work flawlessly and detected our arrival when we turned onto the corner of our street. Now it just sits and waits anywhere from 2 minutes to an hour before detecting our arrivals. Deleting and recreating the mobile presence on the app did nothing to fix it. Instead, we decided to get a couple of the arrival sensors to deal with this problem in the meantime.

I made a few observations though.

  1. We primarily use the SmartThing Classic app, but we also use the new SmartThings app to schedule our Samsung PowerBot vacuum to clean when we leave the house, and both apps used to run in parallel smoothly. Now the new SmartThings app has the same problem, and it usually triggers our arrivals at the same time. So my initial thoughts were that both SmartThings apps were messed up.

  2. We also have a Nest camera, which also does not seem to recognize that we’re home, and that made me suspect it might be O/S related. Battery optimizations have been disabled on all 3 apps.

  3. I did some Googling and found that geofencing on Android phones uses the Google Play Services API (link). I also noticed the Google Play Services was last updated on September 6th 2018 on my phone, which coincides around the time we started having these issues.

So I think it might be related to the latest version of Google Play Services, though I have nothing to back it. I think OP mentioned that his wife’s iPhone is having the same issue, so there goes my theory then.


(Zen) #7

Same problem here since a few days ago I am using s9+, noticed that as one of my webcore routine not running as the presence is one of the criteria I hate google updates, I always wonder if they test things properly before releases it


#8

Ummm … also sounds like ST … double wammy :unamused:


(Paul) #9

Hmmmm, this really looks like a complicated/multi-layer problem.

New observations on this week:

  1. Deleted and re-created mobile sensors on both my android 9.0 pixel and my wife’s iPhone X. Nothing helped. My phone still lagged very long and my wife’s still not showing away when left. My suspicions are as follows.

  2. Android: noticed that whenever my phone is on battery saving mode, the geofencing stopped working even when I turned that off and connected to home wifi, it still took ST an hour to figure out I actually arrived. I’ve set every battery saving features off for SmartThings classic app, I don’t have the new app installed or setup. I guess it might have something to do with the play services update @jononthelam mentioned.

  3. iOS: Last two days my wife’s iPhone failed to show away when she left the house, leaving me very frustrated. However she turned mobile data off because she’s used it all of the data plan. Even she’s connecting to WiFi outside didn’t help. So I guess geofencing in iOS needs mobile data to work? I’ll update my observation later .


(Zen) #10

I have tried to reconfigure the location in the ST app in 2 S9 that seems to do the trick, we ll see


(Paul) #11

How do you do that? Is it the location circle in settings?


(Tyler Jones) #12

Still having the same issues here. My wife’s iPhone has triggered a few times now, but not consistently. My Android phone is still 10-15 minutes behind after I arrive.

Interestingly enough, mobile presence for when I’m leaving has been working flawlessly.

Interesting find about play services update on Sept 5 v13.2.80. I’ve noticed some small issues I’ve been having with other GPS related apps as well recently. Maybe I’ll try disabling play services and reinstalling.


(Daniel Ionescu) #13

Go to settings, Apps, Google Pay Services and clear cache and data. It’s same as uninstall/reinstall just faster.
Also see this [HOW TO] SmartThings Presence reporting using Tasker/SharpTools/AutoLocation regarding battery optimization.


(Paul) #14

Yeah I’m leaning more on this side now, for me the leaving always works, but arrival really depends.

Update since my last post:

  1. For iPhone, looks like mobile data must be on for iOS app to do proper geofencing. Got my wife’s data turned on and it’s working good so far.

  2. For Android, things are more complicated. To me play service update really is the culprit for this inconsistency. Whenever my phone’s on battery saving mode, geofencing will stop working, even I cancel it or connect to home wifi network. I even tried one day to turn off battery saving before I return home and voila it changes to present in seconds I drove into our community.

Just want to try @nychan idea to see if it would work


(Zen) #15

Yes just save the location again


#16

Yes, the mobile presence works fine for when we leave too. It’s when we return home that it takes forever to figure out.

I’ve messed around with the geofence/location size a few times too and that didn’t seem to do anything for me. I’ve cleared the cache on google play services and that didn’t do anything either. I’m not quite ready to clear the data yet as I’ve had a bad experience with that messing up my phone and I had to do a factory reset, which I don’t really want to do at the moment.

So for now, we’re just gonna live with the physical arrival sensors even though it’s one more thing to carry around. I’ll wait for the next Google Play Services update and see if that fixes anything (probably not).


#17

Oh, I tried disabling battery optimization on location services and fused location too, and that worked for a really short time. I drove out of my garage and around the block. It worked within those 10 minutes. Thought I had a sure thing.

Went out later in the day and came home only to set off the alarm :confused:. At that point I decided to get the physical arrival sensors.


(Tyler Jones) #18

Whats seems to have worked for me is the following steps:

  1. Deleted and recreated the phone presence sensor in Smartthings Classic app
  2. Clear Cache on Google Play Services
  3. Clear Data on Google Play Services
  4. Disable battery optimization on PRESENCE
  5. Disable battery optimization on FUSED LOCATION
  6. Already had battery optimization turned off for Smartthings itself.
    (the link NomadTech posted above has good advice for how to do all of this, as several things are hidden by default)
  7. Made an adjustment to the geofence in the Smartthings app to hopefully “reset” it somehow.

After doing so, my device finally triggered this afternoon coming into the geofence for the first time in nearly 2 weeks.

Note - Im using the Smartthings classic app


A little warning on the physical presence sensors… they work and work well, but battery life is maybe a week and a half tops. I recommend stockpiling batteries. Or maybe the new LTE ones which are rechargeable.


#19

Yea it’s a little annoying having to deal with replacing the batteries on the arrival sensors, though in my experience they last between 2-4 months. I do use a battery monitoring smartapp to alert me whenever the battery lives of my devices drop below 20% to stay on top of it.


(Zen) #20

Oops the presence problem reoccurs again hard to see what the problem is one s9 one s9 plus, similar issue