Mobile presence sensor stopped working

presencesensor

(Davin K Dameron) #21

Kind of annoying that this is still broken. I don’t have any important automations that use presence, but my poor dogs sit in the dark now if we’re out when it gets dark because WebCore doesn’t know we’re gone. :frowning:


#22

I got a system update pushed to my S8 today. Will report back on whether that fixes the issue on my phone.


(Daniel Ionescu) #23

@jononthelam
Just security update. Nothing else.


(Rick Van Der Valk) #24

Mine isnt working either on my samsung s6. I deleted my presence sensor and now cant put it back on. Anyone know how I can fix this? For being a smartthing, its starting to suck.


#25

Yea, you’re right. Update did diddly squat.


#26

Here are instructions on how to add mobile presence back, though if you’re having issues like the rest of us are with SmartThings detecting presence, it’s probably not going to do anything.


(Paul) #27

Latest update as of Oct.3:

SmartThings classic app updated to latest, Did the battery optimization tricks @Illt67 suggested, and nothing changed.

Basically whenever battery saver mode is on, my android presence simply will stop update. My wife’s iPhone working perfectly though.

Google pixel with Android 9.


#28

Noticed that Google Play Services was updated to 14.3.66 on my phone. Cleared the cache along with the cache partition, but it doesn’t seem to have fixed the issue. Oh well… :neutral_face:


(Chris Hughes) #29

OMG this is driving me crazy. Me and my wife both have Galaxy S9 Plus’ and our presence is sporadic. I’m at work right now and I left the house 2 hours ago. The app still said I was at home until I just cleared the data on google play services and rebooted my phone. My wife left an hour ago and it still says she’s home. Smh


(Paul) #30

Yeah I’m pretty sure it’s Google’s fault, totally not trustworthy, luckily I’m coming to my home with my wife so temporarily worked out.

My Chamberlain garage door is also sending delayed notifications when garage is opened, often up to 5 minutes late

GOOGLE NEEDS TO FIX THIS.


#31

We can’t be the only ones facing this issue. I’m not 100% positive that it’s Google related for Android phones, but most signs seem to indicate that.

In fact, this might be wishful thinking but I would really like to hear from someone from @SmartThings who could perhaps shed some light on whether it is a SmartThings issue or a Google issue. If it is a Google issue, are they doing anything to address it with them? Nothing from this support guide fixes the issue, and I am not willing to do a factory reset because it is unlikely to fix it.


(Darrell) #32

Similar problem here. I have 4 phones set up as presence sensors (1 Android, 3 IOS) and 1 IOS phone updates only randomly.


(Craig) #33

Contact Samsung phone support and smartthings support is the best thing to do until the take responsibility for the problem. There are several threads on here with people having problems being slow or not working they all started with a security update on Samsung phones on dated 8-28-2018 so far nobody at Samsung will take responsibility for the problem so just keep hammering tech support until they get off there butt and fix the problem. This is about the best explanation I have found for the problems in Android Oreo https://codelabs.developers.google.com/codelabs/background-location-updates-android-o/index.html?index=…%2F…%2Findex#6

As far as I can tell Google made changes to android but warned the manufacturer at the beginning of the year and Samsung and Smartthings have not and will not take responsibility for the problem and fix it. So just keep beating on them. Remember “the squeaky wheel gets the oil”


#34

Interesting. So this looks like a @SmartThings issue after all.


(Paul) #35

Thank you for the info @WeBeCampin, you’re probably right about SmartThings, so basically they didn’t update classic/connect app Android I compatible… And now P is here, god knows what other glitches we will encounter.

BTW anyone using WEBCoRe presence sensor on Android with Android O and higher? Does it have the same problem?


#36

Adding my voice to the presence problem as well. My family has 3 phones connected as presence sensors. 2 have been working great for a long time (Nexus 5x on Android 8.1 & Moto G5 Plus on 7.0) but the Nokia 6.1 (8.1 and now 9.0) has gone off the rails in terms of working where it used to work fine. It basically doesn’t work at all until you open the app, will work for a few hours, then won’t report again till you open the app. Phone is using the classic app and is not battery optimized. While it was on 8.1 I had the setting to allow background function, now on 9 I don’t see that as an option so am unsure. Wifi is always on. I tried to log out, uninstall, re-install, log back in and made no difference. I am loath to remove and re-add the presence as I have a bunch of automations tied to it and don’t want to have to adjust all those twice (once to remove then to re-add). Just not sure what else to do at this point. I don’t feel much like reaching out to help as the past many times I have done that really have netted nothing.

I put in place some notices when it appears this has happened (i.e. no motion at home for a while but someone listed there), but its my daughter’s phone and she isn’t allowed to use at school so she rarely sees them. I end up manually changing the state of things.

Any suggestions outside of remove and re-add presence?


(Paul) #37

Been there, done that… Basically no solution for now, still very sporadic for me, but only on Android, iOS has been great.

For now I’m just wondering if WEBCoRe presence would be better


(Hector) #38

I may be the only one but since the app update a couple of weeks ago I’ve seen considerable improvement. I am not getting the long delays on presence updates. Android is still not as fast as IOS but I’m not getting to the house and seeing the presence update an hour later as I was before. It should be better as it should be updating before I enter the house though not after I am inside.


(John) #39

I’ve been having the same issues here. Both my wife and I have Android S8s. Sometimes it will detect I have left but takes forever to know I"m home. I have my alarm setup to disable when someone arrives. It is always going off when we get home.

Is there a fix for this yet? I have reassigned my geo fence without any luck. Removed and added mobile presence sensor. Still nothing. Very very frunstrating.