Mobile Presence Stopped Working

I’ve seen threads here that mobile presence has long been troublesome, but I’ve had it working reasonably well for 7 or 8 months. It does take time to register presence and if I hurry from my car to my door, I might set off the alarm. Expanding the radius helps.

But this function stopped working entirely a few weeks ago, hard to say when. Late December, maybe. Anyway, tech support offered two suggestions, neither of which worked:

  1. Change my location to a different time zone and change it back, and
  2. Remove mobile presence & add it back

After I told them neither worked, they wanted me to make a video of my actions in removing and adding mobile presence. I said “no thanks”. It’s hard not to think they’re giving more onerous requests in order for me to abandon them, rather than the reverse.

I’m considering using the kiosk keypad solution, but I am disappointed that SmartThings is as flaky as the HomeAssistant setup that I’d had before.

two questions…

  1. android or iOS?
  2. is it presence (present/not present) or the automations that use presence that is not working? do the logs show you arriving and/or leaving?

Android.

Well, I have no presence indicator, so the only way I know it’s working is if the automations fire, which they don’t. The logs only indicate things like motion sensors activating when leaving.

Let me offer one correction. The device always thinks I’m home. When I leave the presence detection criterion in the automations, manually turning on the alarm causes the automation to fire to turn it off again.

if you click on menu, go to messages… you should be able to see “somone left home” or “someone arrived home” when presence is triggered.

No such messages, and I don’t recall ever seeing them. I’ve only seen the output of my automations.

1 Like

Yep, definitely the presence sensor. Did they have you try…

  • turn off location in menu > settings
  • uninstall the ST app
  • reboot your mobile device
  • reinstall ST app
  • enable location in menu > settings

Not that it will resolve the issue, just wondering if you tried

I had already rebooted the device for other purposes, so I didn’t do that. On the Google Play site, they did suggest reinstalling, but I’m not going to do that. If I have to rebuild my system on a regular basis, then this application doesn’t do me much good.

I will reboot again, just to make sure.

Nope. Still no go. And I’ve noticed something else odd. One of my automations will turn on an outside siren briefly as I approach the door when the alarm is armed. It turns it off after 1 second. My goal is that it should serve as a warning to a potential intruder. What’s happening now is that it doesn’t turn off after 1 second. Weird.