Meross switches don't connect back to ST properly

Quick question. I’ve installed a couple Meross smart switches, used the connection instructions ( and voila, the switches appeared and it seemed to be well.

However, when the switch is manually triggered, Smartthings doesn’t indicate that so I lose the ability to control the switch. Has anyone had any success with these yet?

Do the switches have the latest firmware installed?

1 Like

Yes it’s working fine here but they’re missing some advanced features. We’re working with Meross to try and get them a more holistic integration with ST. Hopefully in the next few months.

If you’re losing control then the switch is having trouble with the WiFi connectivity. It may also be a temporary C2C issue which should clear up in a few hours if that’s the case.

1 Like

I really don’t think it’s a connectivity issue. I can control it remotely from Smartthings. But if I turn it on at the switch, it doesn’t update Smartthings so I can’t turn it off. Is that a known issue with Meross switches?

1 Like

Been playing around with it more tonight and basically it just won’t stay in sync. Very disappointing. I wanted these to work.

Most cloud based wifi devices will not provide instant updates on status changes to ST unfortunately. Usually they will be polled for any local changes after a period of time but there will be a delay.

Has that been your experience with IFTTT devices as well?

Most WiFi devices, if they comply with the SmartThings architecture are required to be push/callback driven. We have about 7 different WiFi plugs here in our labs and the majority of them work just fine including Kasa, Meross and SmartThings plugs with instant updates which are pushed by the C2C servers. TPLink Tapo has some issues.

@rteeples it looks like Meross is having an issue where commands are being sent from ST but the callback from the their servers to ST is not happening due to a synchronization issue. The solution here was to removing the connection, delete the device and the re-add the connection to Meross. If that still doesn’t work I would recommend contacting their support team and reporting it to them.

1 Like

Same thing happened with me. Everything was fine till I think I manually pushed the button on a Meross outlet switch and now all my Meross switches won’t work in ST but they DO work in the Meross app (so its not a wifi issue). So here is the next weird thing…I delete the suspect outlet from ST, and trying to re-install it and EVERY TIME every single smart device I have gets dumped into one room! Why does that even happen? Now I have to go re-assign all of them to the proper rooms. What a waste of time! And I still don’t have the outlet back that I originally deleted. I have to mess with it more…

I’ve been having issues with these plugs from day one. Keep partially losing connection to ST. I regularly have to go back to the classic app and rediscover everything (which doesn’t mess up their locations). Really hoping there will be a fix soon as I’ve invested quite a bit on money in to smartthings. This and the current Alexa issues are starting to make me regret it.

Meross released a new integration on Monday that is available through the new app. You need to remove your existing integration and relink your Meross account by clicking + (plus) in the upper right of the screen, select Device, by brand, Meross.

Since updating, I have seen some improvement with connections between ST and Meross but also a few issues with device status not displaying properly at times and slight delays. But overall, a definite improvement.


Same phenomenon for Me with meross wall switch. No status update in smartthings application if I switch on with wall switch button. It works fine with voice or smartthings application. But is someone use button I lose control and automation. I have to switch on and off by application to control again.

1 Like

I have the same issue.
Using the plug button, ST and alexa do not receive the status. But using alexa voice control or clicking in ST i get my automations.

The same happened to me this week. I bought 2 Meross smart wall switches and I tried to pair them through ST. Everything goes fine until I discovered that plugging on the switch paired, no light was on and on the ST app everything was off. I asked to Meross and to Samsung but noone helped me. For sure this week I will return them on AMZ. I’m really afraid to read this forum and see that after 1 year the situation is the same. I will try with other brands

be patient. Meross generally responds but it may be a few days. i have noticed they resolve reported issues within a few weeks but YMMV depending on the issue.

1 Like

I opened a support ticket in meross too. Other times they have answered quickly.

This is the failure send to meross:
Again the sync between meross and smartthings is failing.
When I activate or deactivate a plug manually or in the meross app, in meross application the status is updated instantly, but in smartthings it does not update until I refresh the configuration of linked services in smartthings.
If I activate or deactivate the plug with the smartthings app, the status is instantly updated in meross and smartthings apps

Meross has answered this:

"Thank you for contacting meross.

Please remove the linked services in smartthings, then link them to smartthings again.

Have a nice day!"

I didn’t have much hope, but I have done it and everything is working fine with meross and samarttings.
The bad, I had to rewrite all the automations where the meross devices were …

1 Like

After today smartthings issue, solved half hour ago, meross integration works slow.
we will wait to see if it stabilizes.
It takes 10 minutes executing on and off events that I clicked during the incident time.
I say this in case someone has removed and added the meross link again and thinks that nothing has been successful.

Meross continúe works fine when smartthings server stabilized after the incident

Again the sync between meross and smartthings is failing.

When I activate or deactivate a plug manually or in the meross app, in meross app the status is updated instantly, but in smartthings it does not update status.

If I activate or deactivate the plug with the smartthings app, the status is instantly updated in meross app and smartthings.

Removed link with meross and reinstalled failure continues

Opened ticket support in smartthings and meross
Updated april 2: solved

Did you have to do anything to solve this issue as I’ve noticed today that manually operating switches is not updating in smartthing for me (so automations don’t work). The changes show instantly in the meross app. Refreshing the switch in smartthings brings everything back in line temporarily